I want old Sense Back !Support


Last Updated: 2012-09-26 09:52:34
  1. jonathaneuk

    jonathaneuk Member

    If anyone could help downgrade my HTC Desire S back to the old software 2.1 and the old sense I would be much appreciated :thumbup:

    Currently on 2.3.5 but would like my performance back and old lockscreebln etc back....

    Hope someone can help me

    Thanks :confused:

    Advertisement
  2. marvin123

    marvin123 Well-Known Member

    Since breaking down and then having my HTC Desire S phone back with Sense 3.0 and 2.3.5 installed by the repairers, I am convinced that even my longer life Mugen battery doesn't last so long as before, which is annoying.

Share This Page