I9020A ICS Update Canada - Robelus/Koodo ?

Last Updated:

  1. OnlySkillz

    OnlySkillz Well-Known Member

    I have the I9020A in Canada, on Koodo. Still no ICS OTA update. Still waiting for it. I am still using GO Launcher EX with the ICS theme lolz.

  2. Take a look at the sticky at the top of the thread list, there is a link to the manual update file. You'll have it in 5 minutes.
  3. bfksc

    bfksc Well-Known Member

    I have the same model on Rogers and I received the OTA update yesterday morning. It's rolling out gradually, but when you get it seems to depend on when the phone does a poll to look for new updates or serial numbers or something I don't know. Anywho, it's definitely on the way. But you can either do a manual flash of the firmware as mentioned, or you can try doing the *#*#checkin#*#* hidden command on the phone dialer to see if your phone is ready to receive the update. The servers are no doubt very busy with sending out updates, so you may need to try the checkin command several times before you succeed.

    So far so good with my v4.0.4 update. Everything seems to work fine, and no battery issues - it's all good here. I did do a factory reset shortly after the update to wipe the phone (not the "SD card" memory though) and have a fresh setup, but it seemed to work fine for the 30mins of play time after the initial update. I'm a happy camper.
  4. OnlySkillz

    OnlySkillz Well-Known Member

    Still haven't gotten the OTA on Koodo. And my checkin has stopped working lolz.
  5. bfksc

    bfksc Well-Known Member

    Turn your phone off. Power it back on and run the "checkin" procedure again. I was lucky that I didn't need to run the checkin over and over to find the update. This is normal behaviour though, the process is supposed to be automated and allow users from around the world to update dozens at a time. But unless Google has multiple gigabit servers online with the update, you can't expect everyone to get the update at the same time. So, either relax and wait, or run the checkin over and over and hope for the best.
  6. Johnny LaRue

    Johnny LaRue Member

    I'm still waiting on ICS with a Koodo Nexus S...
  7. bfksc

    bfksc Well-Known Member

  8. Johnny LaRue

    Johnny LaRue Member

    I lost patience last night so that's exactly what I did! I followed the directions posted by apearse here:


    I didn't check to see what could possibly go wrong but it worked like a charm. I disabled ADW Launcher and SwiftKeyX just to get a better feel for the update. ICS looks and works great.
  9. candroid11

    candroid11 Well-Known Member

    I'm on Koodo. Just got mine a couple days ago after a million *#*#checkin#*#* attempts
  10. Ballpeen

    Ballpeen New Member

    Hoping someone can help. Got my ICS upgrade yesterday. Everything seems to work great except no data. I can't connect to the koodo 3G network. Is anyone else having this problem? Phone is Nexus S.
    Thanks in advance if anyone has any advice.
  11. bfksc

    bfksc Well-Known Member

    Check your APN settings under Mobile Networks. You should have at least one configured from your SIM with the proper settings. If there is no APN enabled, then data will not work. You can create your own APN and input the settings, but it should not be necessary as the network normally downloads the settings to your SIM card so they are always available. If you can't find any settings online for Koodo, just call them up and tell them you don't have any data settings after an official update, and they should just "resend to switch" which passes all the data along to your SIM card.
  12. Jakaloke

    Jakaloke New Member

    I finally got the ICS update yesterday (Koodo/NexusS). I've been looking forward to it since I've been reading all kinds of great things about it. I'm not disappointed, but I'm not totally blown away, either. I was hoping for a radical improvement, but so far it seems to be more about aesthetics than functionality. The data tracker is nice, but I had a pretty good ap for that already (My Data Manager), in GB. The camera functions are a definite improvement, and it's a lot faster to find something in the ap drawer (although I prefer the appearance of the rolling scroll in GB). Oh, and the new "Roboto" font is very nice. One really big improvement in functionality is the ability to see which aps are open by long-pressing the home button (as well as closing them by swiping to the side), the same feature that's in Honeycomb on my tablet.

    I definitely like the multi-coloured, electronic "X" graphic on the GB start-up screen better than this new weirdness in ICS, but I almost never restart my phone anyways so that's a minor gripe.

    Generally speaking, I like the new os, but I liked the old one, too. So far I'm not sure which one I like better.
  13. Ballpeen

    Ballpeen New Member

    Thanks for the help. I found the Koodo APN settings online and for some reason they had changed after the update. Got it working now though. Thanks!

Share This Page