Icon Bug on Apps2SD - Solution in Post #47 hereSupport


Last Updated: 2011-08-18 16:33:20
  1. spridell

    spridell Well-Known Member


    yes it is definetly a bug.

    Many people on other forums also reporting the same thing.

    Now I wonder if this happened when we got the update to Sense. Does anyone have a 3D that hasnt been updated yet? Maybe they can test this out and see what happens.

    Advertisement
  2. JD_from_da_80s

    JD_from_da_80s Well-Known Member

    This happens to apps I put in a folder. Usually the correct icons show up in a day or two.
  3. SporkLover

    SporkLover Well-Known Member

    I observed the same thing today. I just moved my apps back to the Phone because there is nearly 1gb of storage space available.
    marctronixx likes this.
  4. itsnotagame

    itsnotagame Member

    This just happened to me as well did a restart and lost icons on my home pages. Moved my Sprint football app back to the phone from the sd card and it fix all the other ones.
    marctronixx likes this.
  5. RandoTheKing

    RandoTheKing Member

    I'm having the same issue as well
  6. Southern337

    Southern337 Active Member

    I'm in this boat with you guys as well. Never had this problem on my Nexus One when I kept all my apps on SD card. However, they will still launch the app so I know it's not broken.
  7. spridell

    spridell Well-Known Member

    Looks to be a Sense 3.0 problem. Does anyone have a Sensation? Would like to see if that phone does it also.
  8. swnic

    swnic Well-Known Member

    Yea, I'm in the same boat. Kinda annoying but the apps still function. The fix I've been using is to return a couple apps to the phone and then all is right. Hope HTC fixes this:D
  9. cuellarm

    cuellarm Active Member

    Guys, for what it's worth, the exact same issue is happening on the Evo 4G after the upgrade to Gingerbread a few weeks ago, only it seems to happen when the icons have been placed inside of folders, not on the home pages directly. You'll find it documented on the Evo 4g forum. No solution has been found other than switch to a different scene and then switch back, but that is only temporary. If you reboot, it happens again.
  10. Southern337

    Southern337 Active Member

    I'm waiting for the unlock so I can get pure GB experience. Also want that new Google Video chat.

    I only had widget issues when moving apps before but this is a little weird for the apps to just lose their picture but still work.
  11. Annie19

    Annie19 Member

    Same issue for me. I noticed it the first day I got it. It's fine until I restart or shut down and reboot. It appears to be apps I have moved to SD card. These are apps I have directly on my screens..not in folders.
  12. Recoil1

    Recoil1 Well-Known Member

    I am happy this is not just my phone because I wasn't quite sure if it was the SD Card or the Phone.

    I did do a hard reset just to see if that would change anything and it lasted about a day and then once I turned my phone off it went back to getting the generic Icons for all the apps I moved to the SD card.

    I hope they fix this soon because one gig is not enough when you consider the spider man app takes almost 100 MB and Plant vs. Zombies is around 78 MB. It will only take a couple of those to reach 1 GB.

    Has anyone contacted HTC about this?
  13. marctronixx

    marctronixx Moderator Moderator

    yes some have and if you have not, please do. they may be able to implement a patch in a forthcoming update... strength is in numbers here...
    EarlyMon likes this.
  14. 3D-Vex

    3D-Vex Member

    I have to throw in my 2 cents: I have the same problem. I didn't move my apps at all but one in particular (glow hockey) has the generic android icon which it didn't use to have. Will try to hunt down a solution eventually.
  15. Doomstang

    Doomstang Well-Known Member

    I've been battling this problem for days now....finally gave in and moved all my apps back to internal memory.
    marctronixx likes this.
  16. Recoil1

    Recoil1 Well-Known Member

    That is what I did and they work fine now.

    I did contact HTC support via their web site and they said they would get back with me.

    They also have a thread for the same problem with no permanent solution on HTCs support forum. Guess we will just have to wait for HTC to fix the problem.
  17. acipollo

    acipollo Well-Known Member

    That happened to me before. All I did was remove the icon and then go to my program screen and drag it back on again.
  18. cobalt

    cobalt Well-Known Member

    FYI, this is NOT restricted to cases where you've moved apps to the SD card. I've not moved any apps to my SD card, but ran into this with icons inside folders. They were fine for a few days, then for no apparent reason they're generic icons, and a reboot doesn't fix.

    (cuellarm mentioned folders a few posts up, but I wanted to make it clear I've never moved an app to the SD card but still hit this via folders.)
  19. Recoil1

    Recoil1 Well-Known Member

    Have you turned the phone off and back on and had the icons stay?
  20. Ed.

    Ed. Member


    I talked to HTC yesterday & they said their aware of this issue & they are working on fix that will come as a maintenance release but they have no timeline for this release..
    marctronixx likes this.
  21. jj14x

    jj14x Guides Guide

    Yep. I had the same problem on the 4G (only after upgrading to the stock Sprint GB ROM) - icons inside of folders would go to the generic icon. Switching the scene would solve it till the next reboot. Luckily, the 4G (or the 3D) don't need a reboot all that often.
  22. wase4711

    wase4711 Well-Known Member

    either restart sense, or, download an app call fastreboot; either way will bring your icons right back...
    ceabbott2, marctronixx and EarlyMon like this.
  23. Recoil1

    Recoil1 Well-Known Member

    HTC reps reply to my problem:

    Thank you for your reply. I reviewed your information with my team and it seems that Sense is losing track of where the icon file is located when you turn the phone off and then back on. Other users report that changing between skins or force closing HTC Sense from home>menu>settings>applications>running services will refresh the icon pointer.

    In the meantime, we will research the issue for inclusion in a maintenance release. Thank you for bringing this to our attention and I hope you have a great holiday!

    To send a reply to this message or let me know I have successfully answered your question log in to our ContactUs site using your email address and your ticket number
  24. SDRANGER619

    SDRANGER619 Member

    Hi all,

    So I put the Facebook app on my home screen for easy access. After a day or so the logo becomes what looks like the android market picture, except that it says Andoird on the top and is still named Facebook.

    If i delete the shortcut and re add it, it shows fine, then a day later it gets funky again. Weird. Anyone else experience this? Anyone know how to fix? Should I just uninstall the app and reinstall?
  25. wake69

    wake69 Well-Known Member

    did u move facebook to the sdcard? if so it is a bug in android, if not it may be related to the same bug
    SDRANGER619 likes this.

Share This Page