1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Iconia A500 cant browse through USB flash driveSupport


  1. headshok

    headshok New Member

    Hi guys,

    i just got myself an iconia a500.

    I installed Astro and File manager HD.

    but when i plug in my thumb drive, it cannot detect the thumb drive and this is driving me crazy.

    I have formatted my thumb drive to fat32 and it still wont detect it :(

    what is the problem.

    Thanks in advance.

    Cheers

    Advertisement
    :
  2. mplevy

    mplevy Well-Known Member

    IIRC, with the stock kernel you can only use the flash drive for media transport right now. You would use the Clear.fi app to access the media on the flash drive.
    b&wwaldo likes this.
  3. Myronbg

    Myronbg Well-Known Member

    Did you install the USB driver from Acer? If not you need to download from their site.
  4. mplevy

    mplevy Well-Known Member

    USB driver for what? We're not talking about connecting to a PC, we're talking about plugging a USB drive into the tablet.
  5. weirdo12

    weirdo12 New Member

    On the panel at the left tap Storage.

    On the panel at the top right press the Up arrow until the first directory entry is asec. Now scroll down through the directory and you should see usb_storage. Tap usb_storage and you should see your data.
    Sincity and Alex.Frenkel like this.
  6. weirdo12

    weirdo12 New Member

    Just to be very clear - the driver is to allow the A500 to been seen as a storage device for a Windows PC.
  7. Myronbg

    Myronbg Well-Known Member

    He wanted to hook up a thumb drive to a USB port not to a PC. Different port.
  8. weirdo12

    weirdo12 New Member

    On this point we agree. No additional drivers are required on the A500 for that to work.

    Yes indeed the micro USB port would be used to connect the A500 to a host device. If that host device is a Windows PC then you will (may) need the driver.

    Maybe that's more clear.
  9. Alex.Frenkel

    Alex.Frenkel New Member

    Comments from weirdo12 WORKS!!!!!!
    So, you need file manager HD, and follow the instructions.
    THANK YOU!!!!!!
  10. Alex.Frenkel

    Alex.Frenkel New Member

    Actually! You can use any file manager! Astro, etc.....
  11. dbldipp

    dbldipp Well-Known Member

    If you have ES File manager it's easy to access all your drives. Open it and you see the folders on your machine. In the tool bar at the top on the left side is an icon of a house. Click on it and you'll see your main files, click on the MNT folder and it gives you access you all your drives. Internal, external MSD and USB.
  12. Alex.Frenkel

    Alex.Frenkel New Member

    I actually found that some USB flash drives are not supported by Iconia...
  13. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Those flash drives are probably formatted with NTFS format. Android does not recognize that format. You can root and install Drive Mount. Or reformat the USB drives to FAT32. I already rooted my device, so I won't be reformatting my USB drives. But those that choose not to root will need to back up the data on the USB drive and format as FAT32.
  14. LJD

    LJD New Member

    Aparently the problem with reading NTFS thumb drives was resolved with the update to 3.1. I bought a 32 gig thumb drive online and loaded files on it and it worked great on the A500 without reformatting.:D
    Now I'm just waiting for my 32 gig SD card to come in and I'll be in Acer heaven!!!
  15. kristalsoldier

    kristalsoldier Well-Known Member

    What does MNT stand for? Is it an acronym for something?
  16. Dennis_Jock

    Dennis_Jock New Member

    USB drive support is available. Using Astro or another file management app visit /mnt/usb_storage
  17. SouthofOttawa

    SouthofOttawa Well-Known Member

  18. kristalsoldier

    kristalsoldier Well-Known Member

  19. teambrez

    teambrez New Member

    I can't seem to get the USB port to recognize my thumb drive it works in my friends a500 though I have looked for the files as mentioned above any suggestions?
  20. splatoid

    splatoid Well-Known Member

    Did you get a file manager?
  21. ShellyDamo

    ShellyDamo New Member

    thankyou for this thread. I had the same problem with accessing USB as well. All your advice is great!
  22. Muckr47

    Muckr47 Member

    Had the same problem here thanks for the help
  23. grootmokum

    grootmokum New Member

    Similar problem: 8gb Sandidk usb stick (fat32) is not recognized by my Acer Iconia.
    Camera's, a Verbatim 1gb stick and even a 32gb micro-sd in an adapter (all fat 32 as well): those all work fine. But not that Sandisk-stick. And this same stick is recognized by my desktop-win7(64) as well as laptop-xp. But on the Iconia... nothing, even with the help of ES-fileeplorer and/or Astro. So: are there incompatible usb-sticks?


    Update: the stick is recognized when I bootup th Iconia with the stick inserted.
    Remove the stick and put it back again and the thing is not recognized anymore.
    Weird?
  24. goodwindc

    goodwindc New Member

    have you tried remounting it by going to the storage tab in settings?
    Zoandroid likes this.
  25. grootmokum

    grootmokum New Member

    Hey, that 's a good idea! Works. Thanks.
Loading...

Share This Page