Iconia A500: Can't run files copied from computer to SD cardSupport


  1. damonkee21

    damonkee21 New Member

    I copied some files from my computer to a sd card using a card reader. Then inserted the 32gig sd card to the Acer Iconia A500. I can see the files using Astro but when I attempt to run them, I get the error can't open file:///mnt/external_sd/<file_name>

    If I hook up the Acer Iconia A500 to my computer and move the file over using the USB cable and run it on the A500, it works fine.

    It seems like running copied files using a card reader will give me this error only.

    Does anyone have this problem?
    Does anyone know a solution on how I can read copied files that was copied from a card reader?

    Advertisement
    :
  2. splatoid

    splatoid Well-Known Member

    I can install games and apps from my card. Some cards are a little touchy. I'm having good luck with most scandisks. There are some posts hear that address this and state which cards are best for the a500
    GTbrewer likes this.
  3. damonkee21

    damonkee21 New Member

    Thankyou Splatoid

    how did you move the files over to the sd card?
    Did you do it through a memory card reader or did you hooked the A500 directly to the computer?

    I am able to install games and apps from my SD card also but it is how I moved them over to the card is what is causing the problem. If i moved it by connecting the A500 with the USB cable that will work. If i used a memory card reader, the A500 will say it can't find the file I am trying to run.
  4. splatoid

    splatoid Well-Known Member

    Ive used both methods. Do you know haow to locate the sd card vs internal sd card.
    That alone took me a week to get it figured out. What I do when coping right from my computer is I just put what I want on the tablet in the download folder and then go to the download folder and move it where I want it.I have also used the card reader but it is easer the computer way.Some SD Cards dont work very well in the
    acer what is brand of card your using?
  5. damonkee21

    damonkee21 New Member

    thanks Splatoid

    I think you are right. I think it is a bad SD card. I tried it on an 8gig card and everything worked fine. I am getting a new 32gig SD card to try it out. Hopefully it will work this time...
  6. illusivexvii

    illusivexvii New Member

    hi, i'm currently facing roughly the same problem. My problem is my iconia tab couldnt detect my sd card. what is the format of your memory card? is it ntfs? fat32? do they have a specific sd card which i can use for iconia a500? thanks..
  7. AntimonyER

    AntimonyER AF Addict VIP Member

    Mine is a little finicky, sometimes it sees everything, sometimes it doesn't. I have a couple movies on there, and its hit or miss if it sees both of them on there.
  8. splatoid

    splatoid Well-Known Member

    Fat 32 should be the format.
  9. dbldipp

    dbldipp Well-Known Member

    With the new 3.2 update the USB supports NTFS external hard drives now. You should get a file explorer app to be able to access your internal and external devices. Makes it alot easier.
  10. ivanempire

    ivanempire Member

    Have you tried copying the file from the SD card to the Tablet's own storage using a file manage and running it from there? It might help....
  11. JamesR913

    JamesR913 Active Member

    What type of files are you trying to open? Do you have the appropiate app to open said files? For instance if you are trying to open a .doc file and dont have something like quick office or google docs it wont be able to do anything with the file. Dont just immediately assume that its a bad SD card.
  12. DARKSUN

    DARKSUN Member

    For me, I can copy using an external reader but it warns me some of the files may not be read!?

    I can see all my movies on the eternal 32gb micro sd (kingston) but all, i mean ALL players have cant play it. Some can see the picture of the file on th icon screen but once i click, it crashes the app or does not read.

    Help. (oh i just bought my Gateway A60... or Acer A500 3 days ago)

    thank you
  13. Zoandroid

    Zoandroid Well-Known Member

    When I connect my A500 by USB to my Win7 PC, it sees "some" of the folders on the A500's external SD card (/mnt/external_sd?), but even in folders it sees, it doesn't see the files I pasted into those folders using the tablet!

    And if I create a new folder in that location using the tablet, the PC won't see it. If I create a new folder there from the PC, then the tablet sees it, and the PC sees it. But the PC can't see the files INSIDE that folder. The tablet sees them fine. ???????

    I used this same PC when rooting the A500, so I don't think it is a connection issue. The folder structure in this tablet is like a maze! Multiple copies of "SD" trees in internal storage AND external storage. Some of them seem to mirror other locations. It's really crazy!
  14. splatoid

    splatoid Well-Known Member

    Well i just tried what you were talking about. I made a test folder and it wouldn't show up on my computer.I then copied a zip file into the folder and it showed up. Then I deleted the zip file out of the folder and it still shows up. I tried to change permissions it wouldn't let me. I noticed that the permissions are blank for user.Kind of weird.
  15. Zoandroid

    Zoandroid Well-Known Member

    Yea, it told me permissions can't be changed for files on the SD card.

    I also don't understand the crazy amount of references to "SD" in the tablet's folder tree.

    In the root (/) level there is "sdcard", and in it I see all the folders and files on internal storage.

    in /mnt there is external_sd which shows the files I actually have on the card,

    AND sdcard, where AGAIN, it shows all the files in internal storage. There is also a folder named "usb_storage" which shows as empty.
  16. MrWareWolf

    MrWareWolf Member

    try mirage player from market to play the files.. and es file explorer to 'see' the files off your sd cards/network..
  17. Zoandroid

    Zoandroid Well-Known Member

    One thing I have learned since the above conversation is that it helps to un-mount, then re-mount external storage (in Settings) when the tablet is connected by USB to a PC. Doing so will then show all the files in the Tablet's Internal Storage and SD Card from Windows Explorer.
  18. Zoandroid

    Zoandroid Well-Known Member

    I like ES File Explorer's LAN access feature. But for some reason it won't find my LAN connected PCs using its Scan option on this A500 tablet like it does on my Droid X. I have to manually enter their DHCP assigned IP addresses from the tablet for it to find each PC, and then it accesses them just fine. Might be something to do with the ROM I'm using.
Loading...

Share This Page