ICS 4.0.3, Computer won't recognize SD card


  1. ilchi

    ilchi New Member

    Hey, guys. I hope I'm at the right place.
    I have a question I can't seem to find the solution for. Usually I would spend good 2-3 hours on google, but I couldn't come up with anything. So I decided to ask.

    I recently updated my Galaxy s2 to ICS. I did so while my sd card was inside and I guess that messed it up a bit. When I go to the file manager and click on "sd card" it opens the internal storage of the phone. In order to access the sd card I need to click on "emmc" and then "mnt". And voila - I'm in the sd card and can access files no problem. So I thought, it's not a big deal, just different path.
    However when I connect the phone to my computer via USB, the phone recognizes that, I tap on connect usb as mass storage and on my PC a window pops up with the internal memory of the phone. And no SD card whatsoever. Before I updated, there used to be 2 windows popping up. one for the internal memory and one for the sd card. But now no matter what I do, I can't seem to access my SD card from my computer.

    Anything would be helpful. Thanks.

    Advertisement
    :
  2. MSUgEEk

    MSUgEEk Well-Known Member

    Try going to the Storage menu under Settings. At the bottom, there should be a menu button (3 vertical dots). When you click that it should give you a menu for "USB Computer connection". Try changing the settings under there. Seems like I had to change some things when I got my Nexus with ICS.
  3. Unforgiven

    Unforgiven What does this button do? Moderator

    ilchi,
    Which version of the S2 do you have? We can get this moved to that device forum so folks with your phone can help you out. Those forums are very active so its a pretty good guess someone has had the same problem.
  4. ilchi

    ilchi New Member

    Thanks, pupkact. I would appreciate it. I'm sorry I put it here then. But I didn't know there's a designated S2 section. I'm with the i9100.
  5. ilchi

    ilchi New Member

    Thanks for your help as well, svt. I couldn't find that options menu though (the three dots). All i have in. The storage menu is the option to unmount sd and some info about how much space i got.
  6. Unforgiven

    Unforgiven What does this button do? Moderator

    Your thread happily resides in its new home.:)
  7. Slug

    Slug Check six! Moderator

    Sounds like you've 'updated' to a custom AOSP-based firmware such as CyanogenMod 9. Can you confirm, as if so this would be better moved to All Things Root?

    edit: I see you've also posted in ATR so I've merged the threads.
  8. ilchi

    ilchi New Member

    thanks, yeah. I figured I should try there, but I didn't know how to merge them.
  9. techker

    techker Well-Known Member

    did you get it to work??cause i can't..when the usb is connected i go in the settings -usb utilities en press connect to pc..it says to disconnect usb cable..

    and i put it to debug mode..even off still can't ..pc try's to install mpt device?

    ok got it..lol

    Bring up Settings.
    Click More… (under Wireless and network).
    Then select USB utilities ~ Set USB cable connection mode.
    Select Connect storage to PC then.
    Connect USB cable from phone to PC.
    Select Turn on USB storage.
    That’s all.

    http://www.jayceooi.com/2012/03/14/...storage-on-android-4-0-ics-samsung-galaxy-s2/
Loading...

Share This Page