General ICS cannot access external storage


  1. jobewan

    jobewan New Member

    Hello!

    Iam writing this post on an ASUS Transformer Prime. I am using a keyboard with it. The combination of the two cost me fairly dearly, for what is basically some plastic chiclets and a piece of glass. Sure, it's more than that, but is it?

    ICS DOESN'T ALLOW APPS TO SEE/WRITE/READ TO/FROM EXTERNAL STORAGE?

    Why isn't this one of the biggest issues in the Android community? Why all the whimpering, hopeful, nonsensically polite, expressed hopes that Google will ALLOW access to external storage?

    And since the fix is apparently a one line command statement to Android's "registry", WHY AREN'T MANUFACTURER'S ENABLING ACCESS?

    Whose money is being spent here anyway? Mine, Yours. Ours. That's who.

    I would not have purchased an Android tablet, had I known. If I buy a memory slot and fill it, I EXPECT TO BE ABLE TO USE IT. Not the crippled, pathetic use that is current the "State of the Art" (Ah HAHAHAHAHAHAHAHAHAHA - state of the art!), but proper use of the physical resource.

    So I didn't know, that's my excuse. What's yours?

    More importantly, what are you going to do about it?

    I am going to ask ASUS to give me my money back, which of course, they won't do. I am then going to see about having one of my attorney clients or masters class members to write up a nice letter of protest. Something, ANYTHING. To show that I don't have to take this kind of corralling into using someone's cloud nonsense, if I don't want to.

    That's where I am going to start. Where are you going to start?

    Advertisement
  2. mplevy

    mplevy Well-Known Member

    Odd, media apps (MoboPlayer, the stock music app) can read the media on the SD card in my Acer A500 just fine, on ICS.

    Or are you complaining that you can't move an app to the SD card? If so, you're a bit late to the party, HC (Honeycomb, Android 3.0) couldn't either. I've had my A500 for a year and have no issues with the amount of internal space, and I only have the 16 GB version.
  3. jobewan

    jobewan New Member

    In my case, none of the apps I am using, whether installed after the fact or default to the Transformer Prime, seem to be able to access the external card. The File Manager seems just barely able acknowledge its existence and list out its contents. The card works ok, as I can use it on any of several laptops with impunity.

    I am not usually so dramatic, but the disappointment is so very bitter indeed. I NEED the functionality for which I paid, or so thought. Had I not needed it, and given the comparatively primitive interface profile of the Android environment, and extraordinarily primitive profile of the office automation apps, why would I have bothered. I would have purchased an iPad, and painted pretty flowers on my Retina display, marveling at the subtle beauty and operation of the overall IOS interface.

    If you check around as I have, you may also find that a very great many folks can't seem to 'see' their external memory using their Android apps under ICS, or the incarnation just before it.

    FEATURE REGRESSION. I suppose that's progress in Google's book??
  4. Hrethgir

    Hrethgir Well-Known Member

    What apps, exactly, do you have that "need" to access the memory card but can't? I've never had this problem. Music player, video player, document editors, camera, file manager, lots of my apps have no problem seeing/reading/writing to the SD Card. But if it really bothers you, just go get an iPad, although I'd love to hear how well it interfaces with an external memory card, lol!
  5. jobewan

    jobewan New Member

    Thanks for the 'constructive' reply. I already spent nearly a grand on this thing and a tea cozy, etc., and have earned the privilege of putting it on a pedestal, or under one. What I should have been smarter about is purchasing a device over which the manufacturer has no demonstrable control whatsoever regarding the OS feature set. It would have been better to borrow or rent (if possible) before plunking down so much cash. My bad.

    QuickOffice Pro HD, for which I paid twenty bucks, can't see the external storage, sort of. I can select a .docx file for instance from the File Manager and select QOffice to open it which it does. When I try to save it back, the app crashes. The app's file management doesn't show the external memory, as is the case with Dropbox. Other apps I quickly checked seem to have an issue 'seeing' the external storage.

    The internal storage, as is the case with the root/boot stuff, is encrypted using the onboard function for doing so. That doesn't seem to stop access to internally stored . . anything.

    If anyone with a PRIME has had better 'luck', let me know. For the rest, I don't wonder if it's not a matter of apples and oranges. Perhaps not.

    Again, if one Googles, Yahoos, Dogpiles or otherwise searches the InterWeb, one sees a variety of similar issues on a variety of similar platforms.
  6. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Moved to ASUS Eee Pad Transformer Prime section. :)
  7. peterc10

    peterc10 Well-Known Member

    I have a tf300, which should be pretty much the same as yours. I used to run ICS on it but now have JB.

    I have a micro SD permanently in the tablet and have used full SD card and USB stick in the keyboard slots. As the other poster says I have no problem with apps finding all of this external memory. Asus's own File Manager finds them all and displays them. The latest Astro lists the Micro SD under "local storage 3". With the previous version it was listed under /removable/MicroSD.

    I don't know about Quickoffice but the bundled Polaris office app finds it. All I do is hit "My Folders" on the top left of the home screen and an option box drops down which lists MicroSD. Was the same when I had the full SD and USB stick in, they were all listed.

    I have all my music on the MicroSD card and both Mixzing and the bundled music player finds and plays it all as well. However I have never tried saving any apps to the external storage; I find the 32GB on board is more than enough for that.
  8. cxs6957

    cxs6957 Well-Known Member

    I went from the EVO to the GS2 to the GS3 and as a person who has a LOT of apps and whose app choices seem to always be the bigger sized ones, I was not amused when I got the GS3 (although I do love it other than that). I'm with the OP on this one, it's incredibly annoying of Google to take away the ability to transfer apps to the SD card, my phones always worked better with as many apps on the SD card as possible, although at times I'd still have a ton of apps that I'd have to force myself to get rid of for space's sake, and for a device so freaking expensive it's annoying to know you have to go out your way to root it to get back a function that never should have been taken away.
  9. peterc10

    peterc10 Well-Known Member

    That is not what the OP was complaining about as far as I can see. His/her complaint was that ICS does not "allow apps to see/write/read to/from external storage". That is simply not correct. And he repeats that complaint in his second post when he says "none of the apps I am using, whether installed after the fact or default to the Transformer Prime, seem to be able to access the external card" Again most of us do not have that problem.

    He/she did not complain about apps not being installed on the external storage. In fact that should be no problem at all with a tablet that has 32GB of internal storage.
  10. cxs6957

    cxs6957 Well-Known Member

    I filled up my 16GB GS3 within three days of buying that and then just upgraded to a 32GB SD card and am going to have to buy a 64 GB now so I highly highly highly disagree with you.
  11. peterc10

    peterc10 Well-Known Member

    You did not fill those cards up with apps did you? Because, as you have already said, you can't put apps on external storage. You filled them up with the data for apps, which you can store on the cards.

    Have another read of my post and the OP's posts. I only made 2 points in my last post. Firstly that the OP's complaint is NOT about not being able to install apps on the external storage, its about his apps (presumably on the internal storage) not being able to access data on the external storage. Secondly that with 32GB of internal storage available for the storage of apps alone (nearly all their data can go on external storage) it should not be too much of a problem, bearing in mind that the Asus tablets (which is what we are referring to here) have the ability to access almost unlimited storage for app data through its USB capabilities. Now, which of those do you "highly highly disagree with"?
  12. rdalcanto

    rdalcanto Well-Known Member

    My son has filled up his 32GB Asus with apps/games. Did I understand someone's reply that we can't move them to the microSD card? He needs more storage space! Thanks.

Share This Page