ICS: Error message: Network coverage is currently poorSupport


  1. ebookof

    ebookof Member

    I have had lots of problems with the ICS update. I did a pinhole reset: no impact. Now, I have made a factory reset, but already I have one issue that remains:

    When I ask the tablet to check for an update, the following error message appears: "Network coverage is currently poor. Please move to a location with better coverage to continue".

    I am just by the wireless router and the tablet itself indicates that the signal is strong. Internet on the tablet works fine.

    Did anyone manage to solve this issue. If I am not able to solve it, I won't be able to get the update that will solve all the issues I have. I have probably no choice but to return the tablet to Acer.

    Advertisement
  2. WHP

    WHP New Member

    Same here. No idea how to get around this. Hope someone has a suggestion.
  3. p1r4te

    p1r4te Active Member

    I have just started having the same problem, I'm still on honeycomb, and I think its got to do with that acer driver updater program that allows ics to be downloaded (iconia tab update enhancer).
    why I'm saiing that is because I didn't have that problem before, and I still havnt received ics.
    Paranoid but possible side comment: Acer is probably screwing with your tablets.

    the few things I tried are:
    un install re install and clear data for the updater. no effect.
    deleted and installed new network connection on the tab. no effect.
    installed a new wifi router on my network and configured it correctly. no effect.
    checked using wifi tethering using my ph.... your device is up to date.

    at all times my signal was good to excellent.
    at every test I went to various websites including market ect....

    I will keep watching this thread to see if a fix is found.

    I hope this helps.
  4. billat

    billat New Member

    I have the ics update and now I'm seeing this too. In addition to my accelerometer going out after ics was installed... Not good!
  5. p1r4te

    p1r4te Active Member

    I'm at my inlaws house at the moment, and said "your device is up to date".
    it may be isp related....... everything else works, just the automatic update that`s playing up.
    still on honeycomb.
  6. p1r4te

    p1r4te Active Member

    back home, now both my phone wifi tether and the home wifi are saying network coverage is bad when I try to update.
    I hope that this info is helping someone with a bit more experience figure out what could be the problem.

    still honeycomb.
  7. kristalsoldier

    kristalsoldier Well-Known Member

    Exactly the same problem. Still on HC.
  8. denilson

    denilson Member

    Same here in Belgium, tried on several locations and wifi access points, but no luck... very strange...:hmpf:
  9. jimburn69

    jimburn69 Well-Known Member

    My daughter is having same problem in California. Acer should do something about this. It must be a widespread problem.
  10. Green1

    Green1 Active Member

    It does seem to be widespread, but I wonder if they even know about it? has anyone asked?

    EDIT: Well I tried contacting Acer... not sure why I ever bother trying to contact any customer service centre... they're hopeless. At least they didn't drag it out... All I got was to call their "2nd level support" mon-fri 8am-7pm Central Time.
  11. ebookof

    ebookof Member

    Acer says to wait for an update. However, since the system update no longer works, I am not sure how we will get it. It was suggested we might have to get it through Acer support. However, no idea as to how long this might take.
  12. ciphan

    ciphan Member

    The "Network coverage is currently poor. Please move to a location with better coverage to continue" has nothing to do with your Wi-Fi connection. What it really means is that your tablet cannot resolve the DNS name checkin.acer.futuredial.com. This is the address that your tablet looks up to determine if there is an update available or not. For me at least, this address is currently unresolvable, or more specifically, it says that it is non-existent, which isn't exactly correct, but it is how my ISP's DNS server sees it.

    You can check how your computer (and by extension any other device on your network, like your tablet) resolves this name by opening a command prompt/terminal and typing "nslookup checkin.acer.futuredial.com", without the quotes. If the address is resolvable, you will get a Non-authoritative answer with a list of one or more IP addresses, if, like for me right now, it is not, you will get an error stating such.

    My guess is, to lighten the load on their servers, Acer has somehow geo fenced this address and will probably be opening it up on a regional basis.
    p1r4te likes this.
  13. denilson

    denilson Member

    If so, why don't they change the "poor network coverage..." into something specific explaining/describing the problem, now it's a bit misleading :)

    I did what you proposed and I got this in my cmd :
    non authorative answer :
    checking.acer.futuredial.com.home
    address:67.215.77.132

    so what does this mean, that the update can be done for me ?
  14. ciphan

    ciphan Member

    Normally, yes. In your case unfortunately, no. It means that you are using OpenDNS as your dns server and you have their "Domain Typos" feature turned on (it is by default, you would have to specifically disable it if you didn't want it). If you visit http://67.215.77.132 in your browser you will get an OpenDNS Guide search page.

    I completely agree that this error text is misleading. Right now Google is assuming that any error in accessing that address is related to the network connection. It would be much more informative if they parsed the actual error they are receiving and displayed an appropriate in-plain-english error message to the user. Unfortunately, this is not how it currently works.
  15. ciphan

    ciphan Member

    I also just noticed that the address you looked up is incorrect. It is checkin.acer... not checking.acer....

    Maybe the proper address will resolve for you?
  16. denilson

    denilson Member

    I use open DNS indeed because of Belgian restrictions for Piratebay etc...
    the "checking" was "checkin" in the cmd prompt, just an error in typing here on the forum, i did not copy-paste so... :)
    So that means just wait for Belgian release-opening the gates ...

    Edit: just now update message , installed ICS and working smoothly!
  17. ciphan

    ciphan Member

    Just wondering, now that your window seems to be open, if you do the "nslookup checkin.acer.futuredial.com" does it resolve to something now? Other than the OpenDNS Guide address of course. If so, what?
  18. dutri1406

    dutri1406 New Member

    I have been receiving that message all day except a couple of minutes ago message now says "your device is up to date" I have 3.21 kernel 2.6.36.3
  19. shadowhunter32

    shadowhunter32 New Member

    I had the same problem until about 5 today. I walked into my backyard and it prompted me to download it, walked inside and downloaded it. ICS is incredible(I'm typing this on my A500 right now.), better battery, so many cool new features, and everything wrong with 3.2.1 is fixed. It is 1000x smoother than HC! Don't know if everyone got it yet, but try walking into your yard. Lol!

    BTW, I have a Gen2. And it is not rooted.
  20. p1r4te

    p1r4te Active Member

    thank you guys for explaining the checkin.acer.futuredial.com issue.

    so basically, I have no acess to that site.
    now I'm wondering if its isp related because I assume i was able to get through, since when I used the cellphone and my inlaws internet connection it told me I was up to date, and with my wifi it still says no network coverage.....

    in saying that, it may have been a coincidence, but the fact remains that I still have no ics. :(

    now my cellphone tether sais no network coverage as well.

    if someone could put the update.zip in a server on the net, and post the link that would be awesome. :)
  21. p1r4te

    p1r4te Active Member

    strangely enough, now its just stuck on please wait when I tried to check the update......
  22. denilson

    denilson Member

    in the cmd, i still get the same ip adress as before...
    and in my browser it says that the website does not exist and i get the open dns search page
  23. dutri1406

    dutri1406 New Member

    this AM I had an awful time to turn on my 100...then said system up to update a couple of times. Now a half hour later I am back to the connection error...
  24. ciphan

    ciphan Member

    It looks like your window has already closed. It would seem that it does not stay open for very long.

    I did however figure out that checkin.acer.futuredial.com is a CNAME or alias DNS record that when live, at least for me, points to acerfota-1361777979.ap-southeast-1.elb.amazonaws.com. My window opened up and my tablet connected long enough to tell me that it was already up to date. Obviously there is some other factor here as well like the SNID of the tablet or something else that controls if you can get the update or not. It definitely does send the SNID and the IMEI of the tablet whenever it contacts that server.

    Someone over at XDA has already posted an update.zip for the ICS OTA download. It is however for a GEN2 device and I have a GEN1. Now it seems that the only obvious difference between the GEN2 update and the GEN1 update is that the GNE2 is missing an update to the EC firmware that is in the GEN1 update. The Embedded Controller firmware controls some of the low level functions to do with how the OS interfaces with the hardware, but the details of what this particular EC update does is currently unknown. There are a few reports of people successfully flashing this update.zip onto a GEN1 device without any problems, but I think I'll wait at least until the end of the week to see if Acer's plans pan out for me.
  25. p1r4te

    p1r4te Active Member

    I got gen1 as well. I looked at that page on xda, but I'm waiting for someone to put the gen 1update just in case it matters later on since I'm still under warranty.
    today it told me that I'm up to date. 8:28 nz

    and still up to date again... 22:32 nz

    02/may/12 18:57 and still no icecream.
    I think ill root and put some custom recovery once the warranty runs out. :p

Share This Page