ICS + Google Play + Voice Search = Black Screen!General


Last Updated:

  1. Xerses

    Xerses Well-Known Member

    Can others who have updated to ICS please let me know if they are experiencing the same bug as I am?

    Open Google Play, press the search icon at the top of the screen, but use the voice option and speak your query. Search for anything it does not make a difference.

    When I do it the screen goes black after a second and freezes there. The home button only gives haptic feedback, the back key does nothing, and eventually I get to dumped to the home screen with a message that Google Play has crashed.

    If I perform the same search by typing text instead, it works perfectly.

    Advertisement
  2. Descendant X

    Descendant X Member

    I tried searching for Angry Birds and it brought up the results without issue. Maybe try giving your phone the old on/off?
  3. Xerses

    Xerses Well-Known Member

    I had rebooted a few times since yesterday and the result was the same, but just to prove me wrong, my phone decided that the problem should go away after I posted my question!

    I had turned off my phone for the night (like I always do), so I just turned it back on to try the voice search again (tried Angry Birds since that is what you did) and lo and behold, it works!

    Don't get me wrong, I am happy, but it was weird that 3 or 4 reboots, including a shut down overnight, did not fix it before!

    At least the problem is gone!
  4. Xerses

    Xerses Well-Known Member

    And of course, since I posted that it was fixed, it is not.

    Please try a second search after your first is successful. It just crashed again. The exact message I get at the home screen is "Unfortunately, Google Play Store has stopped." and then I get another message (new to me) that says "TwLauncher is not responding. Would you like to close it?"

    EDIT: After a few verifications, it would seem that a reboot lets me voice search Google Play Store once, but a second search will crash the store.
  5. Descendant X

    Descendant X Member

    Interesting, I'm having the same problem now as well. The funny thing is, this is something I never would have discovered on my own as I never use voice on this thing. Not accustomed to it, I suppose.

    It's a good thing I don't use voice that often, but I can imagine that for someone who uses voice more regularly it would be an annoyance.

    Let us know if you find anything out, Xerxes.
    Xerses likes this.
  6. Xerses

    Xerses Well-Known Member

    I will contact Telus and Samsung about this, now that you have confirmed that it is not just my phone, but a bug in ICS for the SIIX.

    The interesting thing is that the voice Web search works perfectly well (better than with Gingerbread) and Voice Talk for calling, texting, etc, works perfectly well also.

    I don't often use voice to search the Play Store, so it is no big deal, but it is disappointing that such a glaring issue would get released to public. It's not like there was a spelling error in a sub menu, it is an in your face feature that people are going to use (or not ;)).

    Thanks for the confirmation!

Share This Page