Root ICS update rooted

Discussion in 'Android Devices' started by Sjoerd1234, Mar 23, 2012.

  1. Sjoerd1234

    Sjoerd1234 Member
    5

    Dec 2, 2011
    5
    0
    5
    Hello everybody,


    I've got a question. I looked everywhere but every answer seems different so I decided to ask myself.

    I have a rooted asus transformer firmware 3.2.1, and I want to upgrade to ICS. I read that you absolutely can not do that. They said your device will be bricked. Other people said no problem, only your root will be gone. It doesn't matter to me if the root is gone.
    So wich one is right. Can I just update my tablet or do I have to unroot?

    thanks in advance
     

    Advertisement
  2. drowe

    drowe Well-Known Member
    53

    Dec 18, 2009
    185
    49
    53
    Male
    North Carolina
    On xda there is are a few threads about flashable upgrades. This is the one I used [ROM] ICS - CWM flashable - xda-developers, option B when I upgraded. I just saw some other threads there with other flashable, rooted, ICS files but I can't comment on them. I had root before, flashed in CWM, had root and CWM after. I did have to copy su from /system/bin to /system/xbin so everything saw root.

    Good Luck!
    David
     
  3. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    2,943

    Jan 3, 2011
    30,965
    22,057
    2,943
    Scotland
    I have root and I updated to ICS.

    What I did was download an app called OTA Rootkeeper, took an SU Backup, unrooted using the app, updated and restored the SU backup on ICS.

    Your experience may differ, but it worked flawlessly for me.
     
  4. Sjoerd1234

    Sjoerd1234 Member
    5

    Dec 2, 2011
    5
    0
    5
    Hey, I tried your way. OTA Rootkeeper did his job well. but when I update, the device turns itself off (wich is normal), then i get a loading bar. Around the middle of the bar it goes away and I get a Android green guy with a big triangle with an ! inside it. This doesn't look good. I can restart the device. When I do so, it is just same as always. Any idea???
     
  5. Podivin

    Podivin VIP Member
    VIP Member
    213

    Nov 29, 2009
    3,679
    881
    213
    Jacksonville, Fl
    It's sounds like you're trying to install the OTA download, I could never get that to work on mine either, most likely because I (we) had made some change to the system that causes the OTA to fail (such as freezing or removing bloatware).
    I had to flash the ROM drowe mentioned above, that worked for me.
     
  6. superstretch

    superstretch Well-Known Member
    43

    Sep 1, 2010
    131
    27
    43
    Rochester, NY
    Why not flash a 4.x-based ROM? I'm running Android Revolution HD on mine and it has been a fantastic experience
     

Share This Page

Loading...