ICS update run: Now I can't connect to my PC..??Support


  1. browningrage

    browningrage New Member

    I ran the stupid 4.0.4 ICS update yesterday, now I no longer have the ability to connect to my PC as Mass Storage Device loike I did previously. This was essential to my isyncr app allowing me to put my itunes playlists and such on my GS2... Any word on how to do this..?? My computer recognizes the connection in "Camera" mode, but isyncr tells me I need to select "Mass Storage" or "Connect to PC"... I hate this OS..!!

    Advertisement
  2. csg94010

    csg94010 New Member

    I have the same problem. Cannot update apps manually or download attachments from email.... still finding problems...
  3. twilighter

    twilighter Well-Known Member

    I'm also having this problem. I really need to connect my phone to my pc and it won't connect since ICS. Someone help!!!
  4. funky_muzic

    funky_muzic Active Member

    This same thing is happening to me. Actually, my computer will find my phone, but during while I am transferring files, it will lose the connection. Has anyone found a solution for this, or is this one of the glitches of ICS?
  5. Sylerxen

    Sylerxen Well-Known Member

    My only solution for you guys is to root and aquire a custom ROM that has its own USB storage method. Like Blazer or something. I used Blazer and it allowed me to connect to USB storage and my SD card.
  6. Vulcan Rider

    Vulcan Rider Member

    Mine did the same thing on the ICS update. Very frustrating and there appears to be no fix. Anyway, I installed the WiFi File Transfer Pro app on my phone and it works pretty good. Does just what it says. You can move files back and forth between your phone and PC wirelessly. You do have to have your phone and PC on the same WiFi signal, but that's not a big deal. It's not as slick as a cable connection because you can't drag and drop whole folders, but it's the best alternative I've found so far.
  7. Hawaiian_Geek

    Hawaiian_Geek Active Member

    on your pc download the Samsung Kies software and install on it on your pc.....i had this same problem with one of my XP pc's last night.....installing Samsung Kies software on pc solved the problem.....Kies will automatically install the USB drivers....then reboot your pc.....make sure you don't have the USB cable installed when rebooting....then open up Kies.....then insert usb cable to pc.....some have said enabling USB Debugging on phone then switching off would also work after Samsung USB drivers are installed....
  8. twilighter

    twilighter Well-Known Member

    I really needed to connect my phone to the pc...I had to do a factory reset and then go into settings, developer options, and make sure usb debugging and allow mock locations was checked. Now I am able to connect. Also, I'm not on Ice cream sandwich anymore, now on Jellybean. Maybe that makes a difference.

Share This Page