Idiots Guide To Rooting Kindle Fire HD 7" 7.2.3


  1. Rollout

    Rollout Active Member

    One small correction that will fail if not done right. In that section you have
    "Now open RunMe.bat as administrator and see if that works"

    Yes, and no. You need to not right click it to open cmd, it will not work that way.

    Open cmd from the start menu, navigate to the folder, then run it.
  2. Delusionalhelp

    Delusionalhelp New Member

    I got a new Kindle Fire HD 7.2.3 for Christmas right?

    Well, I followed these instructions down to code and it rooted my kindle. Problem is. Screens gone black, nothing will show up and everything is lagging! is their anyways to undo this? I tried unroot but it wouldn't work....
  3. Delusionalhelp

    Delusionalhelp New Member

    NVM. If anyone runs across my error just redo the steps again, it will work and give you super user. I suppose sometimes you've got to run the program twice or more to work it.

    Thanks Inksaver :D

    Ok, Well when I go to the googleplay app it tells me to input my google account. I do so, then it says "Can't establish a reliable data connection to the server. _______________________
    This could be a temporary problem or your phone may not be provisioned for data services. If it continues, call customer care."

    It's not a phone.. It's a kindle fire HD connected to wifi. Pretty high quality wifi as well.
  4. xeth

    xeth New Member

  5. timaestro

    timaestro New Member

    u asked how i improvised .. . .... i simply restored my device to factory settings, downloaded java on my pc and reinstalled the adb drivers .. . ...this time i after installing the drivers i did not get a message saying 'drivers nit installed properly please install manually ' it went smoothly ... i also found out how to get go launcher ex working in my kindle fire hd
    poe510 likes this.
  6. timaestro

    timaestro New Member

    for all who wants to know how to get go launcher ex working on the kindle fire hd .. . ..
  7. Inksaver

    Inksaver Well-Known Member

    @Rollout

    Thanks for the Heads-Up. Original post edited to relect this I am wondering whether as the SDK is not "Installed" in true windows fashion, i.e. new .dll files added to System32 and registered with regsvr32, and no additional registry changes, it would be easier to simply copy the platform-tools folder into C:\, rename it as "root", add bin4ry's tool, modify RunMe.bat and proceed.
    If this did not tread on any copyright/licencing etc. issues then this could be made available as a pre-modified tool of 33MB size to be attached here?

    @Delusionalhelp

    It is important to install GooglePlay in a two step process.
    On your Kindle Tap apps on the text menu home screen
    Long Press Google Play Store and "Remove From Device"
    Now re-install "Market" following the guide Section 4, and sign-in first!
    Only if that works is it safe to over-write with GooglePlay

    @xeth

    It looks like you have the same problems as Rollout from post#8 onwards. The guide has been modified with his help to get over this situation. There is now a new Section 3.5 - "Permission Denied" and other errors during Root process. Please give it a try and let us know how you get on.


    @timaestro

    Did you use the Jave JRE (Runtime Environment) or the full development kit?
    Sidenote: Please be careful putting your email on a forum. Spambots love it. Either request using PM (Private Messaging) or diguise the address e.g. MyName[AT]MyDomain[DOT]com
  8. tsevard

    tsevard New Member

    This was awesome. I couldn't get anything else to work. Thanks for taking the time to give a step by step for the not so tech savvy people.
  9. DGS75028

    DGS75028 Member

    i used alternate usb drivers to get rooted. had same issues. my KFHD popped up screen regarding usb drivers. after installing amazon adb drivers, went back in devices and updated with usb driver. everything worked after that. spent probably 12 hours over several days pulling hair out, but got rooted on last attempt. hope this helps. using win 7 ultimate 64 bit.
  10. DGS75028

    DGS75028 Member

    Thanks for this thread. used same methods, but under some other forums. this is by far the best explaination i have read or followed. wish i had discovered earlier. thanks again for sharing your knowledge.
  11. DGS75028

    DGS75028 Member

    type adb kill-server
    then type adb devices
    should show device # if drivers are correct
    then continue from there
  12. gilbequick

    gilbequick Well-Known Member

    Thanks for the guide!

    Now for my problem. I have Windows XP. Is there ANY WAY to do this with Windows XP????? If not I'm pretty screwed :(
  13. gilbequick

    gilbequick Well-Known Member

    Also, is there a way to side load my apps that I've paid for in the Play Site without using Appmonster? I'm rooted on my current android device, where do I navigate to in the file explorer (I use Root Explorer) to find the . apk?
  14. Inksaver

    Inksaver Well-Known Member

    I have had a play with an old Netbook with Windows XP. It looks like you can still do it, but you need to Install the 32bit version of the SDK first as Section 3.5 above, run Eclipse, then plug in your Kindle. After a while Device Manager shows Kindle>-adb composite device, but the MTP device has a yellow warning triangle.
    You will not see the Kindle as a removeable drive, but the adb.exe found in Bin4ry's rooting tool will discover it after you add the adb_usb.ini file and typing adb devices in a command prompt will give you access to the device.

    I will add an update to the original post later, but carry out the steps above allowing for the differences in Users / Documents and Settings etc. between Win7 and XP.

    If you look in \system\app on your rooted device you should find the .apk's there and copy them over. Any paid apps would need you to be signed in to your GooglePlay account in order to verify you are licenced to use them, otherwise they may not run.
  15. bottemann

    bottemann New Member

    Thanks, Inksaver, for an excellent tutorial, the best I've seen. Few have the ability to write -leaving nothing out- in a way that noobs can follow.

    Anyway, I tried out a couple of other "methods" I found on other forums, and couldn't get past the "permission denied" problem(s).

    I encountered only a couple of problems using your instructions, but found clues after reading the forum replies:

    1) After the reboot following running RunMe.bat, my kindle was extremely slow and wouldn't even finish drawing the screens, just as Delusionalhelp described in post #27. After reading his post, I ran the RunMe.bat again and rebooted again, and voila, it came up working like a charm.

    2) Also I found that I couldn't reach the google server to log in, again just as Delusionalhelp described in post #28. After a half dozen tries, I finally logged in successfully, and then proceeded with installation of google play.


    I also got rid of the lock screen ads, and (hopefully) prevented automatic OTA (over-the-air) Kindle firmware updates by installing and using DroidWall's blacklist. Time will tell.


    Kindle Fire HD 7' version 7.2.3 out of the box.

    Registered just to say thanks.
  16. Inksaver

    Inksaver Well-Known Member

    Thanks for giving your feedback. I can now emphasise the two issues you mention by editing the original post.

    This reply has been typed in Chrome browser on my Kindle fire which I installed a couple of minutes ago from apktop.com after GooglePlaystore informed me it is not compatible!
  17. killakey

    killakey New Member

    First off, Thank you Inksaver for such a great guide! I followed all of your directions precisely and everything has been great.....except, I'm having the same problem that Delusionalhelp had as far as trying to sign in to the "Market". I installed the market in two steps just as you instructed, but when I try to sign on and still keeps giving me the "Can't establish a reliable data connection to the server. _______________________
    This could be a temporary problem or your phone may not be provisioned for data services. If it continues, call customer care." message. I tried to just keep signing in, but it stills keep giving me this message :( Please help
  18. Inksaver

    Inksaver Well-Known Member

    @killakey
    Not too sure about this one, but give this a try:
    Settings (More...)>-Wireless>-WiFi
    Tap the connection you are currently on>- Forget
    Re-Boot
    Settings (More...)>-Wireless>-WiFi>- Add Network
    Re-Establish a connection to your WiFi
    Try Market again

    I have found this to work on phones before.
    Dobieg likes this.
  19. killakey

    killakey New Member

    Hi Inksaver
    I tried what you suggested and it worked like a charm :) Thank you again for all of your help :) I'm so excited to use my Kindle now!
  20. JMPunk883

    JMPunk883 New Member

    Okay I've got all the files downloaded, and in the right folders. I have the adb_usb.ini file renamed to just that, but there was no warning of any kind about the file type. I go through the Command Prompt and it shows nothing for Connected Devices. I ran it anyway, and it sits there after I select Normal. Nothing further. If ANYONE can help, I'd appreciate it. Thanks!

    Running on 7.2.3 as this guide says it is for.

    Further explanation as to where I am:

    I don't get anything after I type "adb devices" and press Enter. This, I do NOT get:

    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached
    D025A0A024360KLP device
  21. thexfactord22

    thexfactord22 New Member

    Im having an issue installing the google app store, I got the kindle rooted and when i go to root settings and check the root explorer box i get the warning "When SU request dialog popup, please select always allow or make system remember your allow choice. I hit yes then i get "sorry, test failed. This feature cannot run on your phone". Anyone encounter this problem? I tried re-rooting the kindle and i got the same message again.
  22. Inksaver

    Inksaver Well-Known Member

    @ JMPunk883

    Looks like your Kindle is not recognised by your PC
    Check:
    1) Device Manager on your PC for:
    a) Portable devices - click on it to reveal "Kindle Fire" (Windows 7 only)
    b) Kindle Fire - click on it to reveal "android composite ADB Interface"

    2) Ensure your Kindle is set up to allow USB debugging:
    a) Set "Allow Installation of Applications" to On
    b) Set "Enable ADB" to On

    @ thexfactord22

    If you are rooted, then you should have SuperSu listed in your apps list
    Tap to start it then go to Settings on the menu bar (apps|Logs|Settings)
    Ensure Enable Superuser is ticked
  23. thexfactord22

    thexfactord22 New Member

    I dont see it on my app list, does that mean im not rooted? I followed the instructions and wen through all the reboot and start up everything happened like you described, even said i was rooted at the end so i dont know what i did wrong....
  24. RandomxD

    RandomxD Member

    Thank you very much, Inksaver!

    This is the first guide that actually works :p

    I might add that signing in with Google only worked for me after a restart (not just after half a dozen tries ^^)
  25. Inksaver

    Inksaver Well-Known Member

    @thexfactord22

    Looks like you are definitely not rooted.
    Maybe do a Factory Reset and try again?
    If that still does not work, and you used the simpler method (without installing the Android SDK) it might be worth trying the SDK (use Section 3.5)

Share This Page