Idiots Guide To Rooting Kindle Fire HD 7" 7.2.3


  1. jessica689

    jessica689 New Member

    i am having the same problem! i have the abd_usb.ini file and everything! please help!
  2. thexfactord22

    thexfactord22 New Member

    Ok, I reset the kindle and downloaded the sdk files AND..IT WORKED!! Thank you this was by far the easiest guide out there and i tried three other ones and got errors. After three days i finaly got it!! Thank YOU!
  3. jessica689

    jessica689 New Member

    another issue im having is the device drivers, the compostie n my device manager has the RED signal which is not good, how do i fix that? ive uninstalled and reinstalled multiple times, please help!!
  4. Milkman128

    Milkman128 New Member

    I tried to skim through and google but dont see a resolution to the issue I'm having.

    My kindle fire HD isn't showing up in My computer. (I've gone through view and allowed it to show hidden files and icons)
    I see it in device manager as its self kindle fire
    BUT i dont see a portable devices listing in device manager.

    using window 7 ultimate 64, kindle OS 7.2.3

    I've tried rebooting the kindle, my pc, switching USB ports etc.

    i see it at the bottom right (task bar) where you can eject a device and when viewing devices & printers it's displayed as unspecified.


    Thanks for your time.
  5. TurkeySandwich

    TurkeySandwich New Member

    Would it be safe to attempt the root through Windows 8 with this guide?
  6. Macadoucious

    Macadoucious New Member

    i have followed all the directions (2wice) and in my device managers i have the Kindle Fire but it only reads "Android ADB Interface" no composite. Plus in the command window when i type in ">stuff\adb devices" it doesnt list anything!!!! i have tried to do ">adb kill-server" to stop the servers and tried "stuff\adb devices" again but its not working.....Please someone help i am drowning here :mad::mad::mad::mad::mad::mad::confused::confused::confused::confused::confused::confused::confused::confused::confused::dontknow::dontknow::dontknow::dontknow::dontknow::dontknow::dontknow:

    kindle fire hd with 7.2.3 installed factory on Windows XP


    oh and yes i did do a factory reset and enabled the adb and the use of apps
  7. Inksaver

    Inksaver Well-Known Member

    @jessica689

    Your problem is definitely the drivers. You do not say which version of Windows you are running, but I am guessing WindowsXP. Have you tried installing Java and the Android SDK, as in section 3.5. This can give better results on either Win7 or XP

    @thexfactord22

    Well done. Your persistence has paid off!

    @Milkman128

    I am not sure why it is not showing up as a Portable Device, but for the purposes of rooting, as long as you have in device manger:
    Kindle Fire - click on it to reveal "android composite ADB Interface"
    That is all you need to proceed with the rooting. If it still does not show up as a Portable Device, then your only problem is copying the Playstore apk's over, which is also the same with WindowsXP users. Use the ES Explorer/LAN option for this

    @TurkeySandwich

    I do not have Windows8, but in principle it should be perfectly OK. As long as you can still get a Command Prompt running

    @Macadoucious

    On WindowsXP you will only have one entry in Device Manager, so that is correct.
    Have you installed Java and the Android SDK?
  8. ygw

    ygw New Member

    This is a great tutorial!

    My experience:

    1. Reset to factory setting first helps.
    2. When logging in to Google, restart helps.

    BTW, mine is bought as pre-order. The os was auto updated to 7.2.3 by Amazon.

    Thanks again!
  9. Macadoucious

    Macadoucious New Member

    @inksaver i do have java and android adk downloaded but still not saying in device manager android "composite" its just saying android adb drivers and also in the command window its not listing the device when i get to the step for adb devices it says the stuff about damion but nothing under devices
  10. Inksaver

    Inksaver Well-Known Member

    @Macadoucious

    I have had a poke around with my WinXP netbook. With the Kindle plugged in I get:

    [​IMG]

    You will note the MTP has a yellow triangle which can be ignored.
    In my C:\Documents and Settings\<User Name>\.android\ directory I have:

    [​IMG]

    The folder "avd" and files adbkey,adbkey.pub and ddms.cfg were installed by the SDK
    You should have added the adb_usb.ini file yourself.
    With this folder as seen and running adb devices in a command prompt I get:

    [​IMG]

    If I delete or rename adb_usb.ini I get:

    [​IMG]

    Could you please check your PC to see if everything ties in?. I suspect it is the .ini file causing problems.
  11. DGS75028

    DGS75028 Member

    rooted my with this method. came 7.2.3 out of the box. used alternate usb drivers to get it to work.
  12. no1tufgrl

    no1tufgrl New Member

    i did everything and when i click on play store a little pop up comes up and says play store has stopped can you tell me what the problem is thanks
  13. Withinmyself

    Withinmyself New Member

    I've been an computer tech for 10 years and have hacked and unlocked many a device....when I bought the kindle fire and realized the limitations I was severly disapointed....your guide on rooting and adding the google store is probably the most comprehencive and easy to follow guide Ive ever read....and kudos for adding WinXP instructions as well...well done my friend, well done!!
    PRallday168 likes this.
  14. zorak16

    zorak16 Member

    Hey this is a great guide. I had no problems following your instructions, but I still cannot get my device recognized. By that I mean when in cmd I type "stuff\adb devices" there is nothing showing for listed devices. Obviously this leads to me to the "connect usb cable message" after RunMe when I select 1 for rooting. Tried doing a little research, but none of the posts fixed my problem.

    Here is what I have done/have (Windows 7)
    Tried factory reset, same results
    Turned on ADB setting
    Turned on allow app install
    Root files folder with the Qemu, the Bin4ry files (stuff has 16 files)
    I installed Java +Andriod SDK
    I have a root folder with Runme.bat, Runme.sh, and the stuff folder with 16 files (C:\root)
    I have under my username folder a .android folder with a .ini file made to your exact specifications.
    In Device Manager I have no problem seeing the device, Shows Kindle Fire and then in a subset it shows "Composite ADb" or whatever is suppose to be there.
    I have cmd as adminI have the Up root setting enabled from the ES explorer section of your instructions.

    Any other troubleshooting you could suggest? This has been a stress free experience besides my device not being found; indication of a well written guide.

    Thanks in advance,
    Zorak16
  15. Inksaver

    Inksaver Well-Known Member

    There is a different version of adb.exe in the SDK than there is in Bin4ry's root tool
    Could you use a cmd window and use the version of adb found in the SDK

    [HIGH]cd C:\<location of sdk>\adt-bundle-windows-x86_64\sdk\platform-tools\
    Enter
    adb devices
    Enter[/HIGH]

    To see if the kindle is recognised?
  16. zorak16

    zorak16 Member

    @Inksaver

    Hey tried it and it said.
    "adb server is out of date. killing...
    *daemon started successfully*
    List of Devices attached."
    _____ (nothing)

    My files are located C:\Program Files x86\adt-bundle-windows-x86_64\adt-bundle-windows-x86_64\sdk\platform-tools

    *I understand there is a folder in a folder, but that was just an error on my part. I am sure that wouldnt have any effect on it.

    Any other suggestions. I appreciate the quick reply.
  17. Inksaver

    Inksaver Well-Known Member

    @zorak16

    I am sure this is a drivers issue.
    Does your device manager look something like this (Windows 7):

    [​IMG]

    I am about to wipe/re-install a netbook so can run some tests to see if I can replicate your situation.
    1) What exact version of windows are you using?
    2) Did you use any alternate drivers obtained from other forums, etc?
    3) Did you plug in your Kindle before installing any drivers. (I did before I knew anything about rooting, and it was recognised automatically.)
  18. zorak16

    zorak16 Member

    Wow I had this whole thing typed out, but I have made good progress.
    I did another factory reset, went through all the steps again and now my device is recognized in cmd.

    I continue to proceed and i get to the Full restore screen on my kindle. I press "restore my data" in the bottom right and now i am at the "running...." part of the cmd process.

    QUestions1
    1. Do I need a device encryption? I assume not otherwise you would have said.
    2. My kindle I believe was on sleep (locked whatever you wanna call it) when I hit "1" in cmd. Could that interrupt the process?

    I have it still running and I will continue b/c I feel like disconnecting or aborting the operation would be malevolent to my kindle.
    **update* i closed the cmd and exited out of screen on kindle b4 while it was "running...." I went through the process again and now Im back at "running..." and both do not restore and restore my data are faded. SHould I just wait until cmd tells me otherwise? The text in cmd leads me to believe this is a quick installation.

    ***i noticed in cmd after hitting 1 and it says the line "please connect device..." i get two lines that say

    system\app\backup-restore.apk does not exit
    system\bin\ric does not exist

    Thanks in advance,
    Zorak 16
  19. Inksaver

    Inksaver Well-Known Member

    This is looking better. At least you are getting to the device being recognised.
    Are you using the Bin4ry rooting tool as-is, or have you used the modified RunMe.bat inside the SDK platform-tools directory?
  20. zorak16

    zorak16 Member

    Using the normal tool. The one that is located in the root folder after following the instructions.
  21. Inksaver

    Inksaver Well-Known Member

    1) Not sure what a device encryption is. Where did you see that mentioned?
    2) I would make sure the screen is unlocked before starting. If necessary change the settings so the screen stays on for a couple of minutes or more, so it does not lock during the process.

    The rooting process is fairly quick, but you need to keep an eye on the cmd window if it gives instructions such as press any key, etc.

    If you look in the locations described on your Kindle you will see that /system/app/ has the file backup-restoreConfirmation.apk, but not the one reported as missing. Also system/bin/ does not have a file ric in it, so these errors are normal.

    If you are not getting any further here, the Section 3.5 describes how to alter the runMe.bat file, put it in the SDK\platform-tools folder, along with the "stuff" folder and run it from there.
  22. zorak16

    zorak16 Member

    Alright got it to work. I unrooted it then rooted it again. Thanks for the help! I am currently trying to log into the google market but I remember reading that it can take a lot of tries to work.
  23. Inksaver

    Inksaver Well-Known Member

    Reboot after installing market.
    If you can't log on to the market go to settings and forget your wifi connection, then set up wifi again
  24. zorak16

    zorak16 Member

    good to go thanks!
  25. Tirtband

    Tirtband New Member

    Hi Inksaver,
    Many thanks for sharing such an excellent guide for rooting the KFHD. I could root my device following the guide, but having a few issues. Those are:

    1) The Google Play Store app is getting installed but not opening. Upon tapping on the icon, it returns an error message "Google Play Store has stopped".
    The SuperUser app is installed and "Enable Superuser" is checked (selected).

    2) Initially I could not find any Setting folder under ES File Explorer. After rooting exercise is done I found it under Menu and checked the "Up to Root". But as this was done after the rooting, should I try to root the device once again ?
    Should I also check the Root Explorer (found under Root Setting)?

    3) My PC used to detect the device for as a storage device earlier. But off late it neither show the device under "Devices with Removable Storage" nor as a Media Device while double clicking on My Computer. I am using Windows XP.
    Following Amazon's troubleshooting guide, I installed the Windows Media Player V11, and the device was detected as a Media Device under Other Section of My Computer, but it again went off after few minutes.
    Although, the PC is recognizing the device as under Device Manager, there is a Node as Kindle Fire > Android Composite ADB Devices.
    I also tried your guide to set my PC as Server by putting my ip Address, but the device is giving an error message as "Server not found"

    It will be great if you provide some insight to resolve the above issues.
Loading...

Share This Page