If your bluetooth audio cuts out a lot..Tips

Last Updated:

  1. eazyd

    eazyd Member

    ... it is probably due to WiFi being turned on.

    In my Jeep, I connect my phone via bluetooth to my Sony BT-3700U to listen to music, podcasts, etc. If WiFi is turned on in the Captivate, the audio cuts out often. When I turn WiFi off, it's really smooth and uninterrupted.

    It might be due to the phone trying to search for WiFi connections on the road... it's just faster to turn WiFi off altogether.

    mnemonicj, jcdouglas and jackrock like this.
  2. Podivin

    Podivin VIP Member VIP Member

    Thanks, that's a good tip. I'll try that next time I'm podcasting in my car to see if also applies to my HTC Eris, because it definitely cuts out at regular intervals - wifi searching would make sense.
  3. jackrock

    jackrock Active Member

    And I thought I was just going crazy. I knew I had tried out an audiobook over the bluetooth connection in the car and it worked. Then when I was traveling and wanted to use it, I could control the unit but the sound would only come out of the phone, not the car speakers. It turns out the wifi was still on. Turn that off and sound comes from the car speakers once again.
  4. jcdouglas

    jcdouglas Member

    Thanks for the solution and I wanted to confirm this.

    I listen to a lot of podcasts using a bluetooth connection with my hearing aids, which was cutting in and out. After reading this, I turned off wifi and it fixed the problem.

    However, when I am home or work with wifi connected, it does not cut in and out.
  5. ewingr

    ewingr Well-Known Member

    I have a lot of problems using BT when navigating. The voice turn commands always miss the first 2-3 words. So instead of hearing:

    "Turn left on 6th st"

    I'll hear

    "on 6th st"

    It seems to me that the BT is not actually connected until it speaks, and it misses the first words while connecting up. Does it on all my BT devices.

    Wifi is not on.
  6. JayFReaZy

    JayFReaZy Active Member

    I have the same problem. I have my bluetooth sony ericson mw600 headphones and it seems as if every other song, there tends to be a little hiccup. The track may cut out momentarily for about a second. I had wifi on but I was at home, so it wasn't like it was constantly searching for a hot spot while moving. I then saw this thread and decided to turn off wifi and just have 3G; however, I had the same results.

    This is already my 2nd captivate, the first one I returned due to random shut downs. This is only my 2nd day with my new phone, but do a lot of people experience problems using bluetooth headphones and the captivate?
  7. fldude99

    fldude99 Well-Known Member

    I don't have a problem with my moto S9s when listening to music. But in a conversation with my jawbone, after a few mins it's so garbled I have to switch to phone speaker then back to BT if I haven't lost the call by then. Only really have noticed it in the car so I'm gonna try turning off wifi a see what happens
  8. mnemonicj

    mnemonicj Well-Known Member

    I wanted to post a new reply on this thread because it is relevant rather than starting a new thread.

    I have been having intermittent issues with Bluetooth audio cutting out while I am on a phone call over Bluetooth. I believe the problem stems from Samsung's inability to do anything right and their implementation of Bluetooth 3.0. A new feature of Bluetooth 3.0 is the ability for a Bluetooth connection to transfer data over Wifi if both Bluetooth devices support 3.0 and have compatible Wifi chips. Samsung implemented this poorly, not a real surprise, and now Wifi is causing the Bluetooth data transfers to be spotty causing streaming data, voice calls or audio streaming, to to be adversely affected.

    I was able to finally narrow down the problem thanks to the OP. I received a phone call yesterday on my cell phone and I picked up the call on my Bluetooth enabled home phone. The call sounded horrible, noise and the other caller was cutting out, but not enough that I couldn't understand the other person, so I continued the call. The person on the other end did not seem to have any idea that the call sounded so badly, so it seemed to be something limited to my end. During the call, I went over to my Captivate and turned off Wifi. Instantly, the call cleared up and the quality was good to excellent.

    I use Wifi all of the time especially at home, so I wasn't going to be turning off Wifi all of the time, so I needed a workaround. Using an App called Setting Profiles, I am able to have Wifi automatically turn off anytime I am on a call and then when the call is completed it turns Wifi back on. What's even better is that the app will note the state of Wifi before a call, so if Wifi is already off before a call, it will not turn Wifi on when the call is ended. The Tasker app will allow you to do the same thing, so if you already have Tasker you won't need Setting Profiles.
    Frisco likes this.
  9. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Thanks for that, mnemonicj.
  10. yofa

    yofa Member

    makes sense. they're both on the 2.4-ghz band.
  11. vaickiballs

    vaickiballs Member

    Thank you for the info...I was searching a solution for it
  12. shavald

    shavald Member

    This seems to be my problem exactly. I dowloaded the "lite" version of settings profiles. However, I am stuck as to how I can use the program to do what you describe above.

    For us newbies, could you describe, step-by-step how you can use the settings profile program to do what you have done?

  13. Rubberdude88

    Rubberdude88 Member

    Thank you eazyd... bit of a pain in the a$$ (Wi-fi on/off every time I go out) but my music now streams to my T505 and through the car deck without any problems at all. Going to have a look at the "setting profiles" app to see if I can apply mnemonic's way.
  14. mnemonicj

    mnemonicj Well-Known Member

    Sorry for the late reply. I am not sure if it matters to you anymore but here is what I did.
    1. Open Settings Profile Lite in the applications menu.
    2. In Profiles press the Menu button on your phone and press New Profile.
    3. Name the new profile Wifi Off, press OK, then under the profile settings uncheck Wifi, and then press Back on your phone.
    4. Now under Profiles there should be a Wifi Off profile and it should have "Wi-Fi: Off" in the profile.
    5. At the top select Rules.
    6. Press the Menu button on your phone and press New rule.
    7. Under conditions, add a new condition, Active Call, and when the prompt comes up select OK without selecting the inverse condition.
    8. Under actions, add a new action, Activate Profile, leave priority Normal, select your Wifi Off profile, and press OK.
    9. Press back on your phone a couple time to get back to the application screen and test it out. Your Wifi icon should disappear whenever you answer or make a phone call.

Share This Page