i'll help find a root method if...


Last Updated: 2015-04-14 21:20:26
  1. stayboogy

    stayboogy Well-Known Member

    this means it's the update-binary then

    here, try these:

    they probably won't work, but it's worth a shot. just rename and try to install

    valet-root-4

    valet-root-5
    bummpr likes this.
  2. mainefungi

    mainefungi Well-Known Member



    Well, you were correct, this didn't work. I wish there was a OEM update we could peek at.
    bummpr likes this.
  3. bummpr

    bummpr Active Member

    I want to thank mainefungi and stayboogie for their efforts in trying to crack this device...hope you can figure this out!!!!
  4. stayboogy

    stayboogy Well-Known Member

    i remember having this same trouble back when i created the merit root update zip file. i was getting a no stdout error when the updater-script files were saved as txt style files without the extension in notepad++

    so here are a couple previous attempts remade with the correct file type for updater-script.

    vr7

    vr8


    rename them and try to install them.

    give me the error if any.



    ***haven't given up hope for a simple solution yet, but i'm slowing running out of ideas; ive been all through the google code and there's no reason this can't work as long as the package is verified and the mount command works, which one will no doubt it just has to make it that far in the install process***
  5. mainefungi

    mainefungi Well-Known Member

    No change, it is still aborting. This has been a fun one.
  6. bummpr

    bummpr Active Member

    Hope you are not giving up yet!!! :)

    You guys are our BEST hope!!!
  7. mainefungi

    mainefungi Well-Known Member


    If you are lumping me into the BEST hope category we are really in trouble, LOL.

    I am not giving up yet, I am too stubborn. :D
  8. stayboogy

    stayboogy Well-Known Member

    i need the output of

    cat /proc/cpuinfo

    please

    also, and i'm sure this won't work either, but on the off chance, try to install this and tell me what happens:

    update
  9. mainefungi

    mainefungi Well-Known Member

    Here is the output you requested... I will try the update in a moment and get back to you...

    shell@android:/ $ cat /proc/cpuinfo
    cat /proc/cpuinfo
    Processor : ARMv7 Processor rev 1 (v7l)
    processor : 0
    BogoMIPS : 159.25

    Features : swp half thumb fastmult vfp edsp thumbee neon vfpv3 tls vfpv4
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xc05
    CPU revision : 1

    Hardware : seanplus
    Revision : 0000
    Serial : 0000000000000000
    shell@android:/ $

    EDIT: That update.zip ran the same as all the others. Installation aborted.
  10. mainefungi

    mainefungi Well-Known Member

  11. stayboogy

    stayboogy Well-Known Member

    Cydia Impactor

    try using this to root. its possible the system has been patched against this but it could work
  12. mainefungi

    mainefungi Well-Known Member



    Yeah, I had tried Cydia Impactor before... Here is a screenshot of where it fails.


    [​IMG]
  13. bummpr

    bummpr Active Member

    I just tried Cydia Impactor and got a different error message:

    /data/local/tmp/impactor-5[3]: can't create /system/xbin/su: I/O error
  14. mainefungi

    mainefungi Well-Known Member

    Yes, I have seen that one too... I think it depends on of you have done a fresh reboot or what other root method you tried right before it. Or maybe even whether you are in a USB 2.0 or USB 3.0 port.

    Either way, both errors are the result of a read only system... aka not rooted.



    UPDATE: after a reboot I get this same error.
  15. mrshootdss

    mrshootdss New Member

    I dont know if it will help or not but since i just got this phone and there is no root available, I sent an email to ZTE support with a bogus story about wanting a copy of the stock firmware because even factory reset didnt fix whatever problem. If they actually provide me with it and if it would be of any use to anyone ill upload it someplace for you.
  16. mainefungi

    mainefungi Well-Known Member

    If they provide it in a working update zip it would be a big help. Even if the provided it in a disk img file and flash software, we can work with it. And root it prior to flashing it.

    Unfortunately, given the length of time the phone has been on the market with tracfone/straight talk, they are all still in warranty. Unless they are real numb, they will likely ask you to return the device for a warranty swap or repair.

    Would be interested to see what they respond.
  17. mrshootdss

    mrshootdss New Member

    Just figured i would update. So far they havent even bothered with the standard "thank you for using our product we will answer your question shortly" email.
  18. mainefungi

    mainefungi Well-Known Member


    I am not overly surprised. Though it would be nice.
  19. stayboogy

    stayboogy Well-Known Member

    zte is notorious for not complying with the open source license

    it's unlikely we'll see a kernel source for at least a year;

    and we'll probably never see an update package for it.



    would be nice to be proved wrong though
  20. bummpr

    bummpr Active Member

    Good to see you haven't abandoned us on this thread...we hope you are percolating some new ideas on how to crack this phone. ;)
  21. mainefungi

    mainefungi Well-Known Member

    bummpr, you took the words out of my mouth.
  22. stayboogy

    stayboogy Well-Known Member


    well, i'm at a wall unfortunately.

    i have the source code to all major versions of android, which includes the recovery. an older version of <3e> is stock on the avail/merit which i have. not much has changed in regards to how packages are installed, and i've read through this code hundreds of times from building my own recovery from the cm source...n

    and i can't for the life of me understand why none of the updates i've made have not installed, with a no stdout error message or code

    beyond this, there's not much i can do. it'll take someone more technical to find another vulnerability.

    might could ask jcase, but i'm not sure if he works on jb devices or not???

    there is a possibility that zte signed using their own key, but i doubt this. they're not known for tinkering too much with the standard build code
  23. mainefungi

    mainefungi Well-Known Member

    This guy over here is offering to root it for $45 over a remote connection. Says he already rooted one.

    I wonder if it would be worth letting him do it, and recording the session... I just don't really have $45 right now. lol
  24. bummpr

    bummpr Active Member

    Anyone brave enough to try the Kingo Android Root?

    Can't figure out why XDA shut down the thread which seems to have stopped discussion about safety and effectiveness of the application.
  25. mainefungi

    mainefungi Well-Known Member

    I have not been brave enough... Something about sending IMEI info to a server in china has me a bit hesitant.

    EDIT: I decided to say the heck with it and gave it a shot... No dice...

    [​IMG]
    bummpr likes this.

Share This Page