I'm giving up on flashing JB....


  1. RyanSupertramp

    RyanSupertramp Well-Known Member

    First phone? Bricked it. Second phone? Can't for the life of me get CWM Recovery to work! I've tried different img's from different sources and the closest I got was getting into recovery, but when I choose any option it just gives me the little black tophat and yellow circle arrow and sits there. I can hit the power button as many times as I want and it just switches between the menu and that picture.
    The first phone I had seemed to go through the whole process but on the final boot it just goes to the HTC development build screen and didn't go any further. I had to go into fastboot just to shut the phone off otherwise it would just turn on again to the white screen.
    I feel like I've tried everything and its just become more of a hassle. When I had my Galaxy Nexus, I did it all in one shot and it was my first time every doing anything like that. What gives guys? I followed the instructions to a T...

    Advertisement
    :
  2. riggerman0421

    riggerman0421 Well-Known Member

    Try the TWRP recovery.
    benslgdroid likes this.
  3. RyanSupertramp

    RyanSupertramp Well-Known Member

    I'll give that a whirl right now and see if I can get recovery to work. If not, I'll just leave my phone alone. No reason to poke the bear haha.
  4. RyanSupertramp

    RyanSupertramp Well-Known Member

    I did as suggested and it got me further than I had before. But It was stuck on the "Initializing Swagger" screen. I went back in, wiped and re-flashed, still stuck on that screen. Gave up. Restored. Did more research to find a possible working ROM, found one and now I have JB running on my phone. YAY! :)

    [ROM][JB]CodenameAndroid jellybean[PRIMOC][CDMA] <---That's the name of the ROM I used. Not putting a link because I don't know if it's allowed. Cheers! :)

    Edit: Spoke too soon. After getting everything up and running I went back into recovery to install SuperUser, rebooted and it got stuck on the "Android is upgrading: Starting apps". I rebooted and then it just gets stuck on the Jelly Bean boot screen. This phone is the most frustrating phone ever haha.

    WiFi worked the first time I flashed. I flashed for a second time with the same rom, it now boots but I can't connect to Wifi. It just saves the password but doesn't let me on the network. Ugh..
  5. riggerman0421

    riggerman0421 Well-Known Member

    Which kernel are you using? You may have to flash the kernel zip in recovery, then flash the boot.img in fastboot.
  6. RyanSupertramp

    RyanSupertramp Well-Known Member

    I have the JB ROM installed right now and in the settings it says I'm using 3.0.30simonsimons42_1.0+simonssimons34@gooy #1

    Honestly, I don't even know what that is or what it does haha.
  7. benslgdroid

    benslgdroid rockstar Guide

    The kernel has to be flashed separately through adb for a non ics rom to work.
  8. lilrob1213

    lilrob1213 Well-Known Member

  9. RyanSupertramp

    RyanSupertramp Well-Known Member

    I found out the issue. It was the boot.img that wasn't working. The only one that I've found that works for me is Jellyboot5. I'm running CM10 overclocked at 1900. Wifi doesn't work though which is kind of a pain.
  10. riggerman0421

    riggerman0421 Well-Known Member

    You need to flash the jellyboot5.zip in recovery to get the Wi-Fi working. This will add the needed lib files and modules.
    benslgdroid likes this.
  11. ODGeek

    ODGeek Well-Known Member

    Why, oh why does *EVERY* custom kernel I've tried cause my phone to boot-loop? Why does *EVERY* custom ROM I've tried cause WIFI to stop working with stock kernel?

    What am I doing wrong?

    What is different about my phone?

    Steps:
    1) wipe data, cache, dalvik cache, system
    2) flash ROM (most recently PACMAN) (yes, md5sum matches)
    3) flash gapps (yes, md5sum matches)
    4) reboot to bootloader (fastboot USB)
    5) fastboot flash boot boot.img (extracted from <custom_kernel>.zip or from PACMAN ROM--same result (makes no difference if I'm on PC, MAC or Linux box to flash--all indicate flash was successful)
    6) reboot to recovery
    7) flash kernel.zip (most recently JellyBoot5.zip)
    8) wipe cache & dalvik
    9) reboot to system
    10) phone now is in boot loop...is usable for 30-60 seconds between spontaneous reboots.
    11) reboot to recovery & clear cache / dalvik--phone continues to boot loop.

    Only thing that prevents phone from boot looping is restoring stock boot & restoring stock ROM.


    What am I doing wrong????? What is different about my phone that is causing this?????

    What further info can I provide to help troubleshoot this?
    Narcissic likes this.
  12. benslgdroid

    benslgdroid rockstar Guide

    Do not clear cache and dalvik that last time and see if that works
  13. MasterControl

    MasterControl Member

    I'm having the exact same issue: 30-60 second bootloop on all JB kernels (Jellyboot 5, all sick kernels including the latest (2.0.0?), JMZ, etc. etc.), and I've only found 3 things that work:

    1) stock kernel + stock rom
    2) stock kernel + semi-old version of CM9 (wifi, bluetooth and gps broken)
    3) stock kernel + sicksense (wifi broken)

    CM10, AOKP, etc. don't like the stock kernel (unsurprisingly), but nothing works with any custom kernel so far, and I've tried about 25 of em. I'm not sure if this is relevant, but here's the Hboot screen (I saw someone else having the same problem with the same version):

    PRIMOC PVT SHIP S-ON RL
    HBOOT-1.53.0000
    RADIO-1.00.00.0928
    eMMC-boot
    May 14 2012,20:27:38

    ODGeek likes this.
  14. ODGeek

    ODGeek Well-Known Member

    Those version #'s match mine exactly!

    Thank you! Finally some evidence that I'm not the only one!

    I went back and restored mine with the RUU to "factory stock" and re-unlocked my bootloader, re-rooted, etc. -- thinking I had missed a step somewhere...No dice...Phone behaves exactly the same...

    <Edit> I even tried using CWM recovery instead of TWRP...No difference...Phone behaved the same.

    I've asked and pleaded for help with diagnosing this problem (I'm a linux user going back to 1991, and was a software engineer for 12+ years...No lack of technical expertise on my part, just Android specifics...) All I've gotten in reply is "That shouldn't happen"...

    The only thing I can figure is I bought mine at Wal*Mart, so that is to blame??? <Obvious Sarcasm> :rolleyes:

    With the Galaxy SII 4G released today, I'm thinking I'll give my One V to my wife & move on, since nothing other than "stock" seems to work with my One V...
  15. MasterControl

    MasterControl Member

    I'm thinking the baseband firmware was borked during an OTA (prob an anti-tethering "feature"), or maybe it shipped this way. I did find another (stock) kernel that works:
    Directory listing of http://www.htcruu.com/Primo

    It's in the OTA zip, the boot.img is inside another archive called firmware.zip. It doesn't seem to help with anything, but it's 600k smaller and it doesn't invoke the red-letter-screen-of-death. I'm intrigued by the radio.img (which I can't flash prob. due to S-ON); I see other people have the same HBOOT but an earlier Radio (e.g., RADIO-1.00.00.0521_2) so I'm wondering if there's a way to locate+install that version (the stock RUU on the link above claims to be 0521_2, but it sounds like you didn't have any luck there...)

  16. ODGeek

    ODGeek Well-Known Member

    What I haven't tried yet is re-doing the RUU, and flashing the custom kernels *WITHOUT* doing the OTA UPDATE that fixes the battery, or whatever it purports to fix...May give that a shot this week-end...

    ???
  17. MasterControl

    MasterControl Member

    My hunch was correct, the .0928 Radio was causing the bootloop... I managed to flash the 521_2 radio, and now the Sick kernel is working and AOKP JB runs great.

    Steps (on windoze):

    1) Download this RUU
    2) Run the .exe, wait for it to open the first wizard screen.
    3) Open a file explorer in c:\users\yourname\AppData\Local\Temp\New_Directory_With_Some_Hexadecimal_name
    4) Locate `rom.zip`, copy to the root directory of your sd card, and rename it to PK76IMG.zip
    5) Reboot to bootloader, connect usb, and `fastboot oem lock` in cmd shell, at which point it'll reboot
    6) Get back to HBOOT, wait for it to notice PK76IMG, confirm, make a pot of coffee, check back in 5-10 minutes.
    7) After reboot, phone should now show a 1.00.00.521_2 radio... re-unlock the bootloader in fastboot, re-flash TWRP or whatever, and you should be good to go.

    Lemme know if you get it working...
    TheWineLover, Narcissic and ODGeek like this.
  18. ODGeek

    ODGeek Well-Known Member

    The last time I restored the RUU file, I went ahead and saved a copy of the OTA upgrade file before the phone loaded it. I looked at the contents of that zip file...It contains a "firmware.zip" file, which, in turn contains a "radio.img" file. That OTA upgrade to "fix the battery meter" is what is flashing the updated radio...

    <Edit>Looks like you found the same thing...I should really read more than the first few sentences before I post...

    <Edit> Radios in OTA:/firmware.zip and RUU:rom.zip are different:
    $ md5 -r OTA_radio.img radio.img
    40521da7690e2202481a55b71faab333 radio.img (from OTA upgrade, firmware.zip file)
    95846bdccebe50fa83b583c808ab2646 radio.img (from rom.zip, "recovered" from RUU)

    I don't have time to try it now--But given what you're saying, looks like you've solved this dilemma! Nice work! :)
  19. ODGeek

    ODGeek Well-Known Member

    Worked like a charm!
  20. jefferson3045

    jefferson3045 New Member

    Hey everyone, my first ever post here. I have spent around 10 hours trying to get this to work on my phone but I have got to the stage where CM10 is booting up, giving me 20 seconds or so of time and then restarting on a loop. I am working from a mac and Im determined to get this to work! If anyone could give me a little help that would be great. Iv closely followed instruction lists all over the web and none of them is working and I keep come up against this rebooting problem.

    If anyone has suggestions on how to do this from a mac please let me know. FYI my android/programming knowledge is not very good but i can learn on the fly

    Thanks in advance
  21. ODGeek

    ODGeek Well-Known Member

    You need to check the version of the Radio (seen on the bootloader screen) on your phone. Most of the custom kernels will boot-loop with the one ending in -0928. (The OTA upgrade that "fixes" the battery issue installs this radio). In this case, you need to follow the instructions to reset your phone with the RUU, and *NOT* have it check for upgrades before re-unlocking your phone, installing recovery, flashing new ROM, etc....

    I was able to get mine working using a Mac (you only need a windows box to run the RUU, CD to %TEMP% and recover the "rom.zip" file...If you're having problems with that, PM me and I'll send you a link to download the rom.zip...
  22. jefferson3045

    jefferson3045 New Member

    I am at work right now but will check the version of the Radio and type the output out here so you can take a look.

    I tried to download the RUU before and it was not downloading so if you have the zip file and can send it that would be great.

    Just to check - how am i meant to install the RUU? by flashing it or placing it on the SD card. I know the order of how you do things are very important so if you could let me know what order to do things in correctly ie kernels etc that woudl be great. I can also send you the list of versions of kernals/CM10/boot.img I am using so I am not leaving anything out. Will do so when i get home as well.

    Thanks again for your help - if I get this all sorted out it would be great!
  23. Narcissic

    Narcissic New Member

    I have been working on this problem for the last 30 hours with only about 4 hours of sleep (1 in class). I was beginning to wonder if it was the new update or not. You just saved me another day of testing. Nevertheless, even my nandroid backup was not working. So I used an RUU to completely redo my phone back to the way it was. First thing I noticed was the different radio. However, even though I went back and redid the installation of sick kernel, TWRP, and PacMan, I get stuck on the boot screen of PacMan.
  24. ODGeek

    ODGeek Well-Known Member

    You *MUST* use the RUU to restore the old version of the Radio. Unless someone has figured out how to S-OFF this phone, that our only way (RUU) to "downgrade" the Radio...

    Then, after you RUU restore, you *MUST NOT* allow the OTA upgrade to install (that is what upgrades the Radio & in my case, causes bootlooping with custom kernels)...
  25. Narcissic

    Narcissic New Member

    Sorry for the accidental double post...
Loading...

Share This Page