1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

IMAP settings


  1. rick12

    rick12 Active Member

    I'm having a problem with where my email program on my Eris puts Sent email.

    I just set up a non-Gmail IMAP account on my Eris (Android 2.1). I set it up under the Mail tab where I already had a couple of POP3 accounts.

    In Outlook on my computer, it shows the Sent, Drafts, and Deleted folders as under Inbox (I'm told that's because an IMAP server cannot have other folders on it). I had to specify that Sent folder to hold sent email in the options box (until I did that, it completely disappeared).

    On my phone, however, the account was set up with two sets of folders: one with just the names of the folders (Trash, Sent, Outbox, etc.), the other with INBOX: in front of each name (e.g. INBOX:Sent).

    The problem comes when I send mail from my phone. If I send it on the computer, the sent mail goes to the Sent folder under Inbox. On my phone, however, it gets sent to the Sent folder, not the INBOX:Sent folder. That means that, while I can see that mail if I go to the Sent folder on my phone, it does not show up on my computer in the Sent folder under Inbox. It's nowhere to be found.

    So, how do I get the phone to put the sent email in INBOX:Sent so I can also see it on my computer?

    Advertisement
  2. akozman1979

    akozman1979 New Member

    I've got the same issue on my Incredible using a non-gmail IMAP account....any help out there on this? I've even tried moving from the phone's "sent" folder to the "IMAP Sent" folder but it still doesn't show up in Thunderbird for me.
  3. rick12

    rick12 Active Member

    I did some searching and found that this is a Google problem that they don't seem interested in fixing. See the posts on this site:Issue 1811 - android - Email app doesn't handle IMAP folder prefixes properly - Project Hosting on Google Code . The posts on it run from Jan. '09 to Aug. '10. One of them directed people to K-9 mail (open source; K9 Mail Android App Review by AndroidTapp.com | Android Tapp. Android App Reviews). There's a matrix code on that site that'll take you directly to the program in the Market. Or you can just look in the market for K-9 Mail by K-9 Dog Walkers.

    I set it up on my phone and tested it and it works. It set up the folders Drafts (Drafts), Outbox (Outbox), Sent (Sent), etc. I sent mail from my phone and it deposited it in the Sent (Sent) folder. I checked on my computer, and the sent mail was in the Inbox/Sent folder where I want it.

    This is a highly configurable program. If I like it enough, I might try setting up my Google Apps account on it, too.
  4. Samvega

    Samvega New Member

    I have this same issue. It's lame that google isn't trying to fix it because IMAP is a popular protocol that they should be concerned about working properly!
  5. akozman1979

    akozman1979 New Member

    k-9 is the answer to the problem, works perfectly now...just be sure to assign what you want the sent, drafts folder to be before you send an email out.

Share This Page