IMEI 0049.. causing no network?Support


  1. Threwit

    Threwit New Member

    Hello,

    I really searched about my issue all over internet and tried everything, include ARIZA patch, 9 steps recovery and etc.. Please, someone help me.


    So here's the deal. I bought my SGS3 from second hand, everything worked perfect. One day I noticed a little lag when you unlock phone (i mean press lock button on the side). It took about one sec to phone response. I thought it was old firmware fault, so I wanted to make an update. Phone was rooted, so I couldn't make it through Kies or android. I was a noob at these things, so I googled and saw that I could make an update via Odin. So I did. I downloaded official firmware from sammobile.com, flashing went good, phone turned on and everything worked. BUT! I couldn't acces my network, 3G, make calls and sms etc. (and everything what is accesed via sim card). After hours of googling, I came with conclusion, that my IMEI is not original. unfortunately I haven't made an EFS backup. Then, I spent about week trying to work it out. I tried, i think, all tutorials on the net.

    Could someone try to help me?

    Now IMEI starts with 0049..
    and SERIAL NUMBER is all zeros 0000000

    Advertisement
    :
  2. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Welcome Trewit!!
    Sorry about your issues here and I don't know if I can be much help, but what carrier are you on?
    And are you sure that you flashed the correct firmware?

    I would assume that after the firmware flash, you are now unrooted?
    funkylogik likes this.
  3. funkylogik

    funkylogik share the love peeps ;) VIP Member

    Man im hearing a lot about this new baseband causing this. Wish i knew a solution. If i hear of one ill get back :thumbup:
    Mikestony likes this.
  4. Threwit

    Threwit New Member

    Thanks for replies guys. I use TELE2 carrier, I'm from Lithuania. I think I am sure, that firmware is correct. I downloaded SEB (Baltic) region. Currently now, Im rooted again, because I tried some tutorials.
  5. heat57

    heat57 Well-Known Member

    I am sorry to hear this but I'm afraid you may have an insurmountable problem without and EFS backup. There may be a remote chance that the phone was previously equipped with a custom ROM that made an EFS backup prior to flashing - have a look on your internal SD partition, look for efs_backup folder or something similar (if you haven't already got a file explorer get one of the free ones from Play Store to find the folder).

    Other than that I think it's going to be impossible to get the IMEI back. One minute hope that may be lurking around springs to mind; over at XDA developer forum I think I've read about someone manually changing a database (xml) record in the system partition manually with the phones' relevant IMEI data (presumably from under the battery). Sorry that I can't offer any more help - good luck!
    funkylogik likes this.
  6. CDPlant

    CDPlant Guides Guide

    Do you remember what ROM you were using before you went back to the official firmware?
  7. funkylogik

    funkylogik share the love peeps ;) VIP Member

    I have EFS backed up but id have no idea how to restore it if anything went wrong. Anyone got a guide?
  8. heat57

    heat57 Well-Known Member

    Since you're on an S3 K-tool from the Play Store will work fine. Just run an initial backup with and save it to your external SD. If necessary, you can restore from that in the future. The alternative is efs backup pro, which you can pick up over at XDA forum and which is really simple to use in Windows. You don't even have to go into download mode to run it - just connect your device and wait for it to be recognised, then run the executable (*.exe) and follow the on-screen instructions.

    P.S. just found this which is a definitive guide and easy to follow (works pretty much for all recent Samsung Galaxy devices - http://www.droidviews.com/how-to-ba...imei-on-samsung-galaxy-devices-did-you-do-it/ - courtesy of Droidviews.
    Droidviews and funkylogik like this.
  9. funkylogik

    funkylogik share the love peeps ;) VIP Member

    nice one thanks mate :beer::beer:
  10. Threwit

    Threwit New Member

    Hey, thanks for a good advice, I appreciate that! Although, I just came with compromise and sent it to nearest phone repair company. They fixed it after 2 hours, so they obviously did it with z3x or octopus box. They charged me for about 15 euros. thanks anyway ;)

    I bought it with official firmware, as I said, from second hand
    heat57 and funkylogik like this.
  11. heat57

    heat57 Well-Known Member

    Just remember, next time you flash any ROM ... backup EFS!!!
    funkylogik likes this.
  12. RaynardAchim

    RaynardAchim New Member

    Have identical problem. Does anyone not have a EFS backup that can be used and then I can maybe edit it and change to my own IMEI number? Is this possible?
  13. funkylogik

    funkylogik share the love peeps ;) VIP Member

    Have u tried odin flashing back to stock?
    BynoUK and dmcjr22 like this.
  14. BynoUK

    BynoUK Well-Known Member

    This is a good idea and worth trying first, had the same issues with a Note 2 after an official FW update, only rolling it back sorted it.

    Weird thing was the Note 2 was fully stock, either O2 or Samsung (I'm guessing O2) dropped a bollock on that one.
    funkylogik likes this.
Loading...

Share This Page