1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Import Pictures and Videos to my ComputerSupport


  1. godsdragon

    godsdragon VIP Member VIP Member

    I installed the driver for Samsung moment in my computer but it still does not read it... Do I have a setting on the phone like blackberries do for mass storage? is it windows 7? Please help. How do I sync or at least import those pics and videos?

    Advertisement
  2. meangene

    meangene Well-Known Member

    You should be able to plug the USB cable in and then, when prompted by your phone, mount the SD card. There will be a notification in the top left corner of the phone screen, drag it down and mount the drive for windows to see it.
    godsdragon likes this.
  3. godsdragon

    godsdragon VIP Member VIP Member

    I have tried to mount the phone when i plugged in the usb port with the cable but the only option I have in my phone is to unmount the card... the rest of the options are grayed out...:confused:
    robgonecrazy likes this.
  4. Thefoodman52

    Thefoodman52 Well-Known Member

    If it's only giving you the 'unmount' option... that means somehow it's trying to automatically mount.... have you tried to put pictures onto the phone? Try the standard options: turn USB debugging off or on. Menu>Settings>Applications>Development>USB degbugging

    Thing to note: I run windos 7 64-bit. I have to have USB debugging off on my computer for it to recognize.
    godsdragon likes this.
  5. godsdragon

    godsdragon VIP Member VIP Member

    NO I have not tried to put pics on the phone...
    Still unrecognizable...:confused:
    Thanks for the help!
  6. chibucks

    chibucks Well-Known Member

    question... is the unmount card option on your COMPUTER or on your PHONE. typically, if the drive is grayed out, you have to click the USB notification on your PHONE (in the upper bar) - drag it down to open up the notifications, click on the USB and click mount. let me know if that helps...
    godsdragon likes this.
  7. godsdragon

    godsdragon VIP Member VIP Member

    It's in the phone...I,ll see if there is such notification....

    Thanks!
  8. AlkiDweller

    AlkiDweller Well-Known Member

    Can see the USB icon on the notification bar? If you do, when you pull down the notification bar and tap USB Connected you should see an option to mount.
    godsdragon likes this.
  9. AlkiDweller

    AlkiDweller Well-Known Member

    Can you see the USB icon on the notification bar? If you do, when you pull down the notification bar and tap USB Connected you should see an option to mount.
    godsdragon likes this.
  10. godsdragon

    godsdragon VIP Member VIP Member

    I plugged the phone to the computer but did not see the USB connected notification...
    I also do not show the phone as a newly found device in my computer, even though I know for a fact that the driver is installed and working well in the computer...:confused:
  11. AlkiDweller

    AlkiDweller Well-Known Member

    Every once and a while the notification bar doesn't show the USB symbol when I plug mine in. I have to shut the phone down and restart it and I usually leave it plugged in. If you're sure the drivers are installed correctly you may only need to restart the phone.
    godsdragon likes this.
  12. godsdragon

    godsdragon VIP Member VIP Member

    I tried to reply from google but I guess that did not work... Anyway I wanted to let you know that I plugged in my phone tonight and it worked! I was able to mount and transfer pics from the phone to my computer! woo hoo!

    Thanks again for all your help!:)

Share This Page