Improved AT&T Fusion Stock Rom


Last Updated: 2014-04-07 17:33:27
  1. Lebo

    Lebo Well-Known Member

    For those U8652 owners who enjoy the stock rom but not the limited space I present this simple rom.

    Stock AT&T Rom with:

    Root
    Apps2sd
    Busybox
    Busybox RunParts
    Custom boot animation allowed
    Bash shell support
    Many AT&T apps removed
    ONLY 28 MB storage used!:eek:

    ATTPlain.zip

    Working on a blue themed version which will be released when I stop banging my head against the framework-res.apk (That is giving me fits after I mod the images)

    Edit: Themed version completed with a softer blue color scheme! http://www.mediafire.com/?agagbwsagapj3sl

    Advertisement
  2. Armadillo7

    Armadillo7 Member

    If my Fusion keeps acting up I might use that. Nice phone, but buggy and slow sometimes.
  3. james59802

    james59802 New Member

    Wipe and install shows nodifference and included apps not present. Wiped cache etc. Att apps still present. Is that correct file?
  4. Lebo

    Lebo Well-Known Member

    I figured I may have uploaded the wrong file so I did the following:

    Downloaded the ATTPlain directly from mediafire to the phone
    rebooted recovery into clockwork mod
    backed up current rom
    wiped data
    wiped cache
    wiped dalvik
    installed from zip
    reboot

    Result was what I intended to upload.
    Rooted/superuser
    aps2sd
    at&T moble care, software update, hotspots reamining. ( I use these so they were kept )
    frozen to phone apps layar, facebook, twitter, uno, documents to go, etc gone.
    Internal storage down from 74mb used 86mb free to 28mb used 132mb free
    Installed my favorite terminal app and found it working on busybox fine.

    Not sure what happened for you. Make sure your using clockwork mod to install from recovery.
    Phillips0724 likes this.
  5. u8652 rooted

    u8652 rooted Member

    I just did this following the steps you listed, I still see uno docs2go layar twitter and the cursed yp

    my internal storage is 36/124

    I sure am glad to see someone working with this phone, I really want to try some roms and tweak it, thanks for you efforts :)

    after going to android market it updated some of the apps intended to be removed and i am at 55/105
  6. Lebo

    Lebo Well-Known Member

    wow interesting! Those apps are not in the rom so they must be on the phone and clockwork is not deleting them. Originally I force deleted them with ROMToolbox before I started learning how to cook roms.

    I have tried many roms and change mine regularly as I continue to theme (apk by apk) the AT&T to my liking. So those apps should be long gone from internal memory.

    First idea is to see if you have tried one of the many alternative roms available on that phone. Zad's 1.5 (in a forum post here) for instance. The thought being that perhaps internal memory is not being completely overwritten if you are coming from original stock to the altered stock I have presented here.

    EDIT: Looking I see the links are dead on the post with zad's roms. I'll see if I have them both to reupload to another service.

    EDIT2: Uploaded and linked Zad's 1.5, a random CM7 and the CWR mod in that thread.
    u8652 rooted likes this.
  7. u8652 rooted

    u8652 rooted Member

    Do you know if the stock rom is available anywhere?

    I'd like to go back to original and then step through the root rom process again, would also like to have the stock rom "just in case" :)
  8. u8652 rooted

    u8652 rooted Member

    I just installed cyanogenMod7.2-1.0.zip and O M G :eek: it is incredible, its like a different phone!
  9. JustMyLuck

    JustMyLuck New Member

    u8652,

    I'm a little new to android phones (but have run CM7 on my nook for a while now via the microSD card), and I'm wondering how you did this?

    I went ahead as was able to root my phone, but chickened out on running clockworkmod for the first time as I did not know if a suitable recovery image existed. What did you use? Where did you get a copy of CM7 for the Fusion?

    Any help is greatly appreciated!
  10. Lebo

    Lebo Well-Known Member

    The only stock rom not readily available is the U.S. AT&T version. If that is what you own and have not altered the phone yet with the exception of rooting then if you could send me a couple of fils from your backup(after installing clockworkmod and backing up your system) then I can create a base version for everyone. Which none of us here have atm.

    If you are using a U8650 Sonic then your stock rom is easily obtainable if you google it or just let me know your carrier.

    As far as CM7 goes I have linked a version in another post here about Zad's roms. If you would prefer one that looks like ICS or just another version post here and I'll upload to mediafire the version I use currently or one of many availble if you are willing to sift through the web in languages other than english.
  11. charliedrums

    charliedrums Member

    Hi, I
  12. Lebo

    Lebo Well-Known Member

    Charlie,

    In the original post of this thread: http://androidforums.com/huawei-son...nmod-7-2-zad-rom-v-1-5huawei-u8650-sonic.html you will find instructions to install clockwork recovery. in the last post you will see an alternate link to the custom clockwork mod made by Zad specifically for our phones. (links in the original post are dead)

    What I would need to make a stock recovery for us would be the Boot.img and System.img from your backup folder. Nothing else. These two files would give me what I need without putting ANY of your personal data at risk.
  13. charliedrums

    charliedrums Member

    Lebo,

    OK it’s done. Got my back up and I’m currently uploading the System and Boot to dropbox. When it’s up I’ll post the download link so you can download them. It might take a while because although the boot file is 5mb the system file is 186mb, but when it’s up I’ll be sure to post the link.


    Edit:
    Here are the files. Let me know how it goes
    boot.img> https://www.dropbox.com/sh/tk5m18dd7iohxhe/hMuGEgiNMM/boot.img
    system.img> https://www.dropbox.com/sh/1rnemcw67r9oqy9/Ax_QlzynM8/system.img
    Lebo likes this.
  14. u8652 agrivatd

    u8652 agrivatd New Member

    grrrr i just wiped my fusion cuz ive accumulated to many failded attempts to root..... so i have a fresh canvas. can sumone help me step by step i just want it rooted an clockworkmod on i can take it from there it just wont cooperate...
  15. charliedrums

    charliedrums Member

    Here is what I did: (this tutorial was done by sd_james over at xda developers)
    1. You need to install the latest Android SDK (search google for latest version)

    2. download SuperOneClick v2.3.3

    3. Follow the instructions and make sure that you have set your Settings > Development > USB Debugging box checked. I also set Unknown sources checkbox on.

    4. Type in the following code on the phone keypad

    *#*# 2846579 #*#*

    This will open up the Service Mode
    Go to Project Menu > Background Settings > Log Settings
    Turn on Log Switch and set Log Level Settings to Verbose

    go back one screen

    Go to Dump and Log and place a check in all log settings.

    Reboot the phone

    After reboot use superoneclick2.3.3
    In superoneclick on the general tab click the root button and wait for it.

    This is what worked for me.
    avapepper likes this.
  16. Lebo

    Lebo Well-Known Member

    Just a quick status update on rebuilding the stock configuration. First iteration is stable but lacks the power widget in notifications. Second iteration has said widget but is unstable. Appearently the widget (toolbox rewrite) gets removed from the system UI when almost anything is done to it. So yea, still working on it.
  17. u8652 rooted

    u8652 rooted Member

    What program can I use to explore these .img files?

    I tried a demo of isobuster, it listed the files and their icons with file sizes but renamed them all to recovered file, also since it was a demo I couldnt extract any of the files.

    it appears that the boot.img contains 1 file with a .gz (gzip?) extension with a file size of 1.97mb 2,068,480kb

    the system.img has many files including 1 .mov file, also saw a bunch of .ogg (sound?) files
  18. charliedrums

    charliedrums Member

    Lebo,
    If I can help you in anything else let me know.
    I installed your ATTplain zip and it went down to 28 or so mb but I noticed that the android version is 2.3.4 and on the factory I had 2.3.5. My question is am I losing out on the minor improvements of the latter over the other?
    I searched around and these are the differences:

    v2.3.4
    Version 2.3.4 introduced support for voice or video chat using Google Talk.
    v2.3.5
    Released on 25 July 2011, Android 2.3.5 included a number of system enhancements:
    Improved network performance for the Nexus S 4G, among other fixes and improvements
    Fixed Bluetooth bug on Samsung Galaxy S
    Improved Gmail application
    Shadow animations for list scrolling
    Camera software enhancements
    Improved battery efficiency
  19. Lebo

    Lebo Well-Known Member

    charliedrums,

    Other than the power widget in the Notification area 2.3.4 is stable and useable. This is from my stock which was 2.3.4.

    The boot image above is not working properly with the system image. To get around it I will try to substitute another 2.3.5 boot image. If that fails I may have to ask you for the entire backup folder. I would rather have the newer version available to everyone, but hesitate to have you expose any data that doesn't need to be floating around the internet.

    I'm going to call AT&T in the moring and see if they can send me the 2.3.5 firmware.

    EDIT: sub boot image worked. Next is to rewrite the notification widget apk then see about converting 2.3.5 backup to a standard rom.
  20. sgjava

    sgjava Member

    I was able to root and install clockwork recovery and cyanogenmod as instructed, but I cannot browse the web. My APN appears blank and will not save data (I also tried restoring default). I can use the phone and text, but no data over the network. I'm on AT&T in the US. Also cannot login to google account.
  21. Lebo

    Lebo Well-Known Member


    At&t requires you to buy a separate data plan to access Moble internet when using a smartphone. This includes go phones. Not to be a jerk about it but it clearly states such on the packing and the website. Most of us use wifi only.
  22. sgjava

    sgjava Member

    I already have a data plan. The APN was blank and didn't pull it from the SIM (even with restore default). You have to manually plug in the APN data and reboot the phone. This is in case some other sucker gets stuck without mobile data. I too will be using this as a wifi only device now. I just bought this in case I broke my Captivate. The power button stopped working and I had to take it apart and replace it.
  23. Lebo

    Lebo Well-Known Member

    A bit of comedy but it appears (after many phone calls) that neither AT&T nor Huawei have a stock rom for the U8652. Also Huawei tech support tells me there is no way to reattach toolbox.apk to the notification bar once it drops off (This may sound wrong to you but I have been playing with the coding for the rom and it doesn't suprise me at all). So....yea. I'll keep working on it in spare time. Hope of rescue is gone.:eek:

    Irony for me is I can't see myself going back to stock anyway, but you guys are right, a stock fusion recovery would be helpfull for everyone.:rolleyes:
  24. sgjava

    sgjava Member

    I made a backup of the stock ROM after installing recovery. Once you do a factory wipe it goes through the initialisation process just like new. I also did this with CM7 because it gets stuck in a reboot loop until you go into recovery, wipe everything and fix permissions.
  25. Lebo

    Lebo Well-Known Member

    Well done. Charliedrums has his own backup also but I'd not advise releasing that CWM backup into the wild as it may have personal info. If you have it completly bare of personal data by all means upload it for the folks who are looking for one.

Share This Page