In a pickle with my Droid... help is MUCH appreciated!


  1. chops61636

    chops61636 Member

    I wanted to root and install the 2.1 Sholes mod yesterday, and am a complete noob. I had just heard from people that Sholes automatically backed up the Droid, but I wanted to be sure, so I followed a guide on rootyourdroid.info to install a custom recovery image before working with Sholes. The guide had me use "update.zip" to root, which seemed to go fine, then my command prompt to push two files: "flash_image" and "recovery-0.99.2b.img" onto my Droid. Now, I tried to use SetCPU and it said I don't have root access. I also tried to run the Sholes SMUpdater.apk and it ran into an error and couldn't continue.

    I had no idea what I was doing and have never used the cmd prompt before aside from basic computer tasks, so I need some advice before I mess anything up more. If I reboot in recovery mode now, my screen says "E:Can't open /cache/recovery/command" and the only options I have are "reboot system now", "apply sdcard:update.zip", "wipe data/factory reset", and "wipe cache partition". If I remember correctly, right after I rooted I had more options than this (I know I had one that gave me the option to install a custom ROM), but after I pushed flash_image and recovery-0.99.2b.img I was only left with this screen.

    If I absolutely have to, I'm okay with doing a factory reset and losing all my data, but I don't even know if that would make a difference since it seems like I replaced my factory recovery files by pushing those files onto my droid thorugh the cmd prompt.

    Any help is very much appreciated!

    Advertisement
    :
  2. alostpacket

    alostpacket Over Macho Grande? VIP Member

    Doesn't sound like you properly flashed the SPRecovery image. I'd say go back and redo the steps from rootyourdroid.info and push those files again. When you are doing that there is a point at which you droid will ask you if you want to grant superuser permissions to something (the adb shell) it can be easy to miss if you are looking at your screen typing in the commands to flash SPRecovery. make sure you tick "Allow" and "remember"
  3. chops61636

    chops61636 Member

    Sounds good, I will give that a shot. Thank you for the response. Should I run that update.zip again before I try to flash the SPRecovery image?
  4. Barkleyfan

    Barkleyfan Well-Known Member

    Run the recovery image before the update.zip. Recovery image is your actual O/S. Update.zip is just patches to the O/S. Or at least that's how it was explained to me.
  5. shademar

    shademar Well-Known Member

    Do you have 'superuser permissions' (and an icon that looks like a little ninja) in your apps list? If not, you're probably not rooted and need to go back to the update.zip step.
  6. Redflea

    Redflea Well-Known Member

    It sounds like the custom recovery image never got installed - the recovery menu options you describe sound like the standard recover menu items. If you don't see a Droid Robot

    Do you have a "Superuser Permission" icon in your app tray?

    <Edit> Oops...looks like others already covered it while I let my post window sit open (Olympics distracting me). :)
  7. chops61636

    chops61636 Member

    I don't have Superuser Permissions in my app tray. I tried to just run update.zip again, but nothing seemed to change.
  8. Needsdecaf

    Needsdecaf Well-Known Member

    Not to be mean, but you're all out of sorts.

    Sounds like you don't have the ADB (Android Developer Bridge) installed. If you don't have that, you can't do anything with the command prompt.

    If you don't have the superuser icon, you haven't rooted properly.

    The update.zip is a ROM. You can't load the ROM until you've gotten everything going.

    My advice would be to do a reset and use the Sholes SMUpdater to root. Either that or go to rootyourdroid.info and read all the instructions and the links. Essentially you need to:

    1. Root. This ONLY gives you superuser access NOTHING else.
    2. Install the SPRecovery image from sholes.
    3. Install ADB on your computer so you can control your phone.
    4. Then install ROM's etc.

    Do some research on sholes and rootyourdroid.info and understand what all that means before you proceed forward. I don't mean to sound harsh, but that's the only way you're going to be able to move forward smoothly. Spend a lot of time on rootyourdroid.info. That should help you out tremendously. Hit the "new users start here" icon on the top right, you can't miss it.
  9. Redflea

    Redflea Well-Known Member

    I'd reboot your phone (power on/off).

    Then reconnect to your PC via USB, and copy the update.zip file over again to the root of your SD card.

    Heck - if it was me I'd re-download the update.zip file again just to be absolutely sure you have the right file.

    Then reboot into recovery again and try the update.zip again. It should work...from there, as noted above you can complete the other steps.
  10. chops61636

    chops61636 Member

    Thanks for the response. By "do a reset" do you mean a factory reset? I'm fine with doing that, but I was wondering if I needed to fix this problem with the files I pushed onto recovery with the cmd prompt first, in case those replaced some factory files.
  11. alostpacket

    alostpacket Over Macho Grande? VIP Member


    Excellent advice, imo.
  12. gnmitchell

    gnmitchell Active Member

    I would make sure you read the how to advice from earlier post's to get a better understanding of how to root and what that does for you.

    And since you don't seem to have root on your phone, I would recommend going to the market and download the sholesmod or go to sholes.info and run it. It will backup your phone then root it for you and install SPRecovery for you
Loading...

Share This Page