In recovery...so close...but signature verification failed


Last Updated: 2012-09-07 04:59:18
  1. computerpro3

    computerpro3 Well-Known Member

    No matter what I do, how slow or fast I hit enter for the adb push payload-update.zip /sdcard/update/zip my phone gives me the signature verification falied installation aborted message.

    I don't understand how some of you are saying that you can hit it "too fast" - it gives me this message in well under a second after I hit the power button to apply the sdcard.update.zip.

    Any ideas? I don't want to reboot my phone out of fear that I can't get back into recovery mode!

    Advertisement
  2. JBlox

    JBlox New Member

    I had the same problem you had. I don't know if you were doing this, but I was using 2 hands
    (one to press the power button on the phone and the other to press enter on the keyboard)
    and the first time I used 1 hand to do both steps it worked.
  3. ejlax

    ejlax Well-Known Member

    the number of times that i have gotten the payload to work was when i waited for the green bar at the bottom of the screen to start loading, then hit enter on the keyboard to copy the payloard...this has ALWAYS worked for me. You may be doing it too soon.
  4. lgldrgdlr

    lgldrgdlr Well-Known Member

    ^^^what he said^^^

    As soon as you see the green loading bar at the bottom, hit enter
  5. computerpro3

    computerpro3 Well-Known Member

    IT already says installation aborted by the time the green button appears
  6. computerpro3

    computerpro3 Well-Known Member

    Hah never mind I got it on the 200th try. Very strange. Thanks for the help
  7. rfurman24

    rfurman24 Member

    If the .zip does not take the first time you must re push the other items and then re push the payload .zip. When you push the payload .zip you hit the power button as soon as the green bar appears.
  8. computerpro3

    computerpro3 Well-Known Member

    Thats what finally did it - I wasn't aware I had to repush everything before I tried it again. Nobody said that in any of the instructions.
  9. DirtDiver

    DirtDiver Member

    Thanks for the info guys. Ive been struggling with this exact same thing. No problem with with getting into recovery drivers are yood. Just pushing the load. I didnt know you had to re push it all if you didnt time it right.
    :)
  10. e30kid

    e30kid Member

    Yeah, you can't try to install the payload directly and expect it to install. It's not ever going to verify that way. You have to start loading the legit one and then push the payload to get it to install.
  11. Mean Sixteen

    Mean Sixteen Active Member

    Ok so I am having the same problem as described above.
    I am in recovery, I have pushed busybox, ota.zip, and Superuser.apk as described in "The PRS complete rooting guide" thread.

    I cannot get the "adb push payload-update.zip /sdcard/update.zip" to take.

    As read I am re pushing all when I try each and every time.

    I have tried timing it as many different times as I can think of. Before the green bar. Just as it appears and after. Nothing seems to work.

    Any help would be greatly appreciated.

    Thank you in advance!
  12. gbenj

    gbenj Well-Known Member

    Try following the 10 minute guide.

    Isnt there a step right before it to give the bootloader the signed update.zip then replace with ours after its verified?

    if you missed the timing the first time, could you be missing the step where you replace the one you put in with original?

    another way of saying it: It looks for "A" then we push "B" after it sees "A". If we miss the first time, "B" is still sitting there as we try to push "B" again and again. After a miss, we'd need to put back the original "A" so it verifies it at which point we swap in "B"

    Hopefully I didnt confuse anyone further.

    Good luck as always.

    (also, someone let me know if I'm right or wrong, im just basing it on my understanding of how it worked, I could be way off)
  13. Mean Sixteen

    Mean Sixteen Active Member

    OK so here is what I am seeing.

    Most times it just seems I am missing the timing and I see this on my screen after "Verifying update package..."

    Usually it's
    "E:signature verification failed
    Installation aborted."

    when I see above it comes up right away which makes me think I am missing the timing.
    However sometimes it pauses as if it's doing something and I get the following instead

    "E:failed to verify whole-file signature
    E:signature verification failed
    Installation aborted"

    So does anyone know why I am getting "E:failed to verify whole-file signature" ?

    Thanks again
  14. Mean Sixteen

    Mean Sixteen Active Member

    Thanks for your input.

    I have followed the guide but the PRS guide got into recovery

    Also the vid does a 1.bat loop and the PRS has me edit the loop and running that to get into recovery.

    I am using the Unrevoked package so if you know of a way I can adapt the two methods to help me out that would be great.

    P.S. I have never done this before so I am definitely a noob
  15. necosino

    necosino Well-Known Member

    Just remember that you're pulling the old switcheroo. Push the original update.zip onto the SD card. Let it verify, and then push the new update, which it will then install.

    If it fails, you have to put the original back in order to pasa the verify step of the update.

    Sent from my HTC Incredible using Tapatalk Pro.
  16. gbenj

    gbenj Well-Known Member

    Try starting from the beginning with the 10 minute video, his steps are pretty simple and they cover everything. He has a commands.txt file which has all the things you need to input which simplified things for me.
  17. criDikal

    criDikal Well-Known Member

    If you're having trouble with this, it's because you already had a version of update.zip on your SD card. It's not being overwritten when you push all the files to the card; that's why the verification fails immediately.

    Before you start the root process verify that you DO NOT have a update.zip on your SD card. The proper one(s) will be pushed if you follow the 10 minute/unrevoked process.
  18. zhangMarquez

    zhangMarquez New Member

    Hi! Im a newbie here.. I would just like to ask, how to solve the same problem.. i've tried everything that i've had read in tutorials and forums. I always get a signature verification failed.. im using Samsung S Advance GT i9070..

    I have rooted my phone but my current binary is still samsung official.. also I cannot update my superuser, one step closer and i always got "failed".. i hope you could help me..
  19. iowabowtech

    iowabowtech root@android:/ #

    Hi there and welcome to Android Forums. I'm afraid you may not get much help in this particular thread because we are in the HTC Incredible forum and this is referencing a VERY old issue on this phone back when it was first rooted. So I don't think many people will have a recollection of the events since we pretty much don't use update.zips anymore. You might want to post your query in the S Advance forum here:

    Samsung Galaxy S Advance - Android Forums

    Cheers,
    IBT

Share This Page