Incomplete buildprop


Last Updated: 2011-06-26 06:40:29
  1. piar1963

    piar1963 Member

    Hi all,
    I bought a legitimate DISCO tablet (2.2, 2.6.32.9, FRF858), I tested various TIM's ROMS, but now I have checked that my build.prop is incomplete, many lines are missing (i.e. the screen density line).
    Possibly related to this, I also have a problem with the sizing of the screen, for example the icons on the bottom row have the names out of the screen.
    If I rotate the FT from landscape to portrait, the same problem affects the left or right sides of the screen.
    Even if I flash back to the original fimware there is no way to rollback to the correct layout.
    What can I do?
    It looks like the build.prop isn't correctly updated when flashing.

    By the way, the screen is not defective, because with the stock firmware the pad came with, the sizing was correct.

    Any idea to fix the problem?

    Advertisement
  2. kenewto

    kenewto Well-Known Member

    Assuming you applied 4e. It says to carefully read the directions.

    "If you have a x576 screen you will see an "offset" for your screen, simply launch the GScript application, scroll at the bottom and click on the 1024x576 fix. then reboot."

    I personally just applied Tims 4e ROM and other than my apps would not restore from Titanium, all of the functionality seems to be there.
  3. piar1963

    piar1963 Member

    Done that, the PAD simply doesn't boot anymore. Not a big problem, I will flash again TIM 4E.
    Several Info apps show the screen as 1024x600.
  4. kenewto

    kenewto Well-Known Member

    Let us know how it turns out. Not booting isn't the best of results...
  5. piar1963

    piar1963 Member

    No changes, can you send me your build.prop for further checks?
  6. kenewto

    kenewto Well-Known Member

  7. makadrake

    makadrake New Member

    please Help, after flashing my flytouch with tim 4e, my battery gets stucked at 88% while charging, i switched to tim 4d2 to see if it will be corrected but its gets stucked at 57%.i've calibrated my battery but still getting the same result. Any help will be appreciated.
  8. kenewto

    kenewto Well-Known Member

    I just answered in the other thread. I hope it helps. Battery was a pretty easy thing to over come on both of my devices.
  9. piar1963

    piar1963 Member

    Thanks a lot, but that's not the way to go, editing the density string in the build.prop has an effect opposite to the desired.

    My problem is not a matter of DPI or screen resolution (1024x576 or 600), it's the image which doesn't fit the available screen area, either in landscape (the bottom area) or portrait mode( the side area).

    Even with the original firmware I cannot rollback to the original state which was OK.

    Maybe I accidentally broke the bootloader?
  10. dart16

    dart16 Well-Known Member

    Perhaps you should read post #71 here Screen Position

    There is also a link to the 576 bootloader on that page, and an explanation of some of the results of having the wrong bootloader installed.

    If you want the 600 screen bootloader you will find it packaged with the v4.9 Official firmware for 600 screens here New official Superpad2 Flytouch3 firmware available for testing V4.90 (3_28)

    Incidentally, if you do have the wrong bootloader installed the screen size reporting apps cannot be trusted to give you the correct information about your screen size (apparently!)

    Good luck!
    piar1963 likes this.
  11. piar1963

    piar1963 Member

    Thanks a lot DART16, the problem has been fixed at last.
    I flashed the original 576 firmware and the screen position was fine.
    Then, I upgraded to TIM's last 4E, and the problem reappeared, but at that time I ran the dedicated script under GScript Lite and things were fixed for good.

    Sorry it took so long to have the issue fixed, but I missed to follow carefully the thread for a long time.

Share This Page