Incorrect TimezoneSupport


  1. pkrboo

    pkrboo Active Member

    Hi everyone, I have been lurking for a few months now but have finally registered as i have an issue i just cant figure out.

    Me and the wife both have a Desire.

    When the time is set to automatically update from the network it keeps changing to GMT -8 Las Vegas time. it even says Las Vegas in the current clock.(and i cant delete it)

    We have never manually changed the clock to Vegas time.

    The freaky thing is that we used to live in Las Vegas, BUT we didn't get our Desire's until moving back to the UK.

    I have made sure all my router, modem and PC settings are all GMT UK Time.

    the only thing that i can think is it is Gmail doing it as we made our Gmail account whilst in Las Vegas.

    its very annoying as when it changes to Vegas time obviously all our alarms and calender entries go "pete tong".

    Also if i set the clock to manual it loses time pretty quickly as i left the wifes on auto and mine manual and within a few days mine had dropped 2 or 3 mins.

    We have the same gmail account synced to both phones.

    we also use Launcher Pro

    I thnk that is all the info i have for now.

    Any ideas?

    Advertisement
    :
  2. bfksc

    bfksc Well-Known Member

    Your location in GMail will only affect it if the phone can't determine your location at all. That may explain the Las Vegas location. I'm in Canada with a US GMail location, and my Desire updates just fine with the proper settings. Check to make sure you have Location settings enabled...you must have Use wireless networks enabled or the phone won't properly update your general location for weather and clock updates. Press Menu, Settings, Location, Use wireless networks and enable it.

    If that doesn't work, then you may have to do a factory reset.
    If you don't mind loosing texts and downloaded apps, you can do a factory reset on both phones to wipe them clean and remove all settings and memory, and then it will reboot on it's own and run through the set up on each one again. That should fix it as by default Location settings are enabled (unless you disable them during the initial setup screens).

    Note that yes you can have the same Google account on multiple phones without issue.
  3. pkrboo

    pkrboo Active Member

    yeah both phones have the same google account perfectly fine.

    I also have location settings enabled and always have done.
  4. pkrboo

    pkrboo Active Member

    Anyone else had this problem or have any idea how to stop it happening?
  5. nx1977

    nx1977 Well-Known Member

    Disable auto time update. It causes too many issues to be useful, unless you travel lots and cross timezones.
  6. pkrboo

    pkrboo Active Member

    How do I turn that off?
  7. nx1977

    nx1977 Well-Known Member

    Settings>date & time>untick auto update from network.
  8. pkrboo

    pkrboo Active Member

    Oh yeah i have do that, problem is the phone then starts to lose time. Guess I will just have to live with that.
  9. Da Prof

    Da Prof New Member

    I and my partner have been plagued by this every time we pop over to Europe.

    We have Samsung Galaxy S phones and a Samsung Galaxy Tab. Both exhibit the same behaviour, *and* Google.com comes on in Dutch..

    To fix:
    Go to Menu/Settings/Date_and_time/

    *Untick* the Automatic check box
    Set your correct time zone.
    Return to Home screen using back key.

    Power off your phone (i.e. full power off not just screen off)

    Wait 5 secs.

    Restart your phone

    Go again to Menu/Settings/Date_and_time/
    *Tick* the Automatic check box.
    Return to home screen

    All fixed. :cool:
Loading...

Share This Page