Increase Internal storage to 233MB + additional 1+GB for apps


Last Updated:

  1. vaidyasr

    vaidyasr Well-Known Member

    The following are the steps I have followed to flash the ROM with Mito scatter file, so I got 233MB. But still this is not enough for me, so I modded the int2ext script, so upon reboot, the script will move all system related dalvik-cache to internal storage for speed.

    Pre-requisites:
    1. SD card partitioned. I got 3GB, it is your choice.
    2. Micromax A75 :)

    I have installed 104 apps and still stable. But make sure that you have rebooted after installing 10-20 apps, so that the dalvik-cache will be linked to the external card for user apps. Otherwise, it will eat the internal storage.

    Steps:
    1. Download this package and flash with SP_Flash_Tool_exe_v2.1121.01 which will give you 233MB internal storage. This may be good, but some of the apps missing as I would like to include everything which was in JetModv3.0. So, proceed to step 2.
    a. in SP tool, don't tick the 'PRELOADER'.
    b. Click 'Download'
    c. Connect your switched-off mobile via USB.
    d. Wait for few minutes till it get flashed.

    2. Download this zip file and keep it in your SD card.

    3. Power off your mobile, and wait for few seconds, and press volume-up and power button.

    4. Using CWM recovery select install zip from sd card option and select the above zip file and wait for few seconds.

    5. Select reboot in CWM recovery. That's it.

    Advertisement
  2. shahabazas

    shahabazas ~*~ Android Addict ~*~

    Good buddy hay can you try it on Blue Terror and see if it works as if i am using it right now so wanna use it with this stuff.
  3. vaidyasr

    vaidyasr Well-Known Member

    It should work with any ROM's. I have tried many combinations with GIONEE rom, but nothing works. So, once I flashed with this ROM, it works without any issue. I have reflashed 2 times and reboot several times, still works without any issue.
  4. kumarlucky7

    kumarlucky7 Active Member

    but what packag we download plz provide full details dear
  5. vaidyasr

    vaidyasr Well-Known Member

    As I have mentioned on the bottom of the 1st post, am still uploading...
    kumarlucky7 likes this.
  6. shahabazas

    shahabazas ~*~ Android Addict ~*~

    So first we need to flash all files you are providing and then we can flash Blue Terror correct???
  7. vaidyasr

    vaidyasr Well-Known Member

    Yes, you can even skip step 2, as it was optional to have Micromax original ROM apks. Make sure that the BlueTerror doesn't have the boot.img included. If included, delete the same and flash it.
  8. vaidyasr

    vaidyasr Well-Known Member

    Download link added on 1st post.
  9. kumarlucky7

    kumarlucky7 Active Member

    but afater flash with sp flash tool i am boot loop and included package have two android scatter file ???? wich i have choose buddy???
  10. shahabazas

    shahabazas ~*~ Android Addict ~*~

    So what we need to do now if this happens???
  11. shahabazas

    shahabazas ~*~ Android Addict ~*~

    Have u included the MODDED Boot img in the package and also the CWM recovery in the package as if after flashing with SP Flash tool we wont be having CWM???
  12. vkrajuu

    vkrajuu Well-Known Member

    I have bricked my phone after following this step. Nothing is happening and also the format + download option is not working. The system is not recognizing that the phone is connected into the port?

    Any solution?
  13. shahabazas

    shahabazas ~*~ Android Addict ~*~

    Remove the battery and connect your phone to the comp and then select format+download but haan this time use the MMX NEW VER folder so that the phone can have the Stock ROM and once when the timer is started the put the battery in yhe phone while letting the phone connected and onec ur phone is on then we can see what is the problem in the steps and what we need to follow. So try what i said and try this untill the SP Flash ool flashes and haan if u fail dont just leave try repeatdly as if people had said that they had to try plenty of times and last they had got success by this method. Hope ur phone gets Flashed.

    Edit:

    Hurray by this post i became the SENIOR MEMBER at Android Forums. Praying for ur to get flashed buddy.
  14. vkrajuu

    vkrajuu Well-Known Member

    I have been trying this from the first attempt, the phone is connected to the PC without the battery and trying to do format + download but nothing happens.
  15. shahabazas

    shahabazas ~*~ Android Addict ~*~

    Aare once the SP flash tool starts searching for the phone then insert battery did u??? and haan tick all of the preloader too.
  16. vkrajuu

    vkrajuu Well-Known Member

    yes, the error is BROM ERROR: S_COM_PORT_OPEN_FAIL (1012)

    [COM] Failed to open COM 21
    [HINT]:
  17. shahabazas

    shahabazas ~*~ Android Addict ~*~

    Buddy try again it should work so try few more times :(
  18. vaidyasr

    vaidyasr Well-Known Member

    Yes, the ROM includes the unsecured boot.img created my mastermind and recovery.img posted on this thread. The step 2 is optional, where as the usage of 2nd partition will be done and replacing some of the system apps with the Original Micromax apks. I can post only the script you need to copy under /etc directory to do the movement of /data to sd card.
  19. vaidyasr

    vaidyasr Well-Known Member

    Select the one started with Mito****.txt
  20. Vijayan

    Vijayan Well-Known Member

    @ shahabazas
    "Hurray by this post i became the SENIOR MEMBER at Android Forums. "

    Sirji, Congrats & do keep up the good spirits .......
    shahabazas likes this.
  21. kumar abhishek

    kumar abhishek Well-Known Member


    Which window are u using?
  22. mastermind1024

    mastermind1024 Well-Known Member

    Try that on Windows XP...reported to work on that..
  23. darbhadinesh

    darbhadinesh Well-Known Member

    is there any other reports working or not
  24. vkrajuu

    vkrajuu Well-Known Member

    Its not working in win xp. I am able to hear the sound (beep sound, like when a new device is added) when i put the battery back and nothing happens.

    I have reinstalled the xp drivers plenty of time and been trying this all this while.

    Any other opitions please?
  25. saivignesh

    saivignesh Well-Known Member

    remove your battery for 5 mins then put it back
    now connect ur phone to the cable after clicking on format+download

    dont connect ur phone without the battery

    this worked for me many times!

    :)

Share This Page