Incredible Repeated SD Card Corruption?Support


Last Updated:

  1. bobalay

    bobalay New Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    1
    Likes Received:
    0
    I've been using my Incredible since day one and my 8GB SD card had become corrupt 2 times. 1st time it became corrupt I read that it should be formatted via the phone not PC so maybe that was why it happened. Well I formatted it via the phone and have been using it since and now it's corrupt again?

    Although I can still use it take and save pics read and write to it when connected via usb or if I take it out and put it in a pc everything seems fine.

    My issue is the photos when you view photos almost all photos on the card show up as if they are corrupt the thumbnails are all snowy but if I press on them the picture shows up fine, go back to thumbnail view and they are all snowy again. I've already rebooted the phone, removed the battery and SD card, put it all back together but the thumbnail view still shows pics as snowy.
     

    Advertisement
  2. jtuscano

    jtuscano New Member

    Joined:
    Mar 31, 2010
    Messages:
    4
    Likes Received:
    4
    I am having the same exact same issue you are. Except I am using a 16gb card. For me it's all the pics and video. On the phone everything looks ok but once I hook up my incredible to my PC via usb connection those pictures and video appear corrupted.(not all of them but a majority) I am not able to transfer them or view them on my pc. Thinking it was my pc I tried a 3-4 pc's just to make sure. Same problem through out.

    I know I formatted my card via my phone so I am not sure what is going on. Maybe a bad card?

    Anyone else have any info on this it will be greatly appreciated.
     
  3. slackfumasta

    slackfumasta Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    100
    Likes Received:
    31
    Twice, I've had an issue with my card where the phone simply stops seeing it - if I try to play the music on it it tells me that the SD card is not found and then only displays the stock music that comes on the phone.

    Both times, removing and reinserting the SD card while the phone was on resolved the issue.

    The card is a Class 2 card, some generic brand.
     
  4. dibs ODDJOB

    dibs ODDJOB Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    416
    Likes Received:
    107
    I've had this happen twice with a Sandisk 8GB card. I just replaced it with a new card and so far so good.
     
  5. TheWhiteBandito

    TheWhiteBandito Well-Known Member

    Joined:
    May 2, 2010
    Messages:
    295
    Likes Received:
    48
    Not revive an old thread, but I just got this problem after restoring a Nandroid backup. Here is a screenshot:
    [​IMG]

    Any way to fix this? Is there a way to rebuild the thumbnail database?
     
  6. JohnDaddyo

    JohnDaddyo Member

    Joined:
    May 7, 2010
    Messages:
    22
    Likes Received:
    0
    same problem. I kept getting the "damaged SD..." msg.
    I could not see any photos or videos from the card, nothing.
    I connected the ph to my pc and opened the SD card folder. PC could see everything. I simply copied everything to my Desktop and then dragged it back to the card. Now, I can see all my photos and videos but, when I go to Astro, it only shows a few folders, none of them pics or videos.
    I am not getting the "damaged SD..." msg but obviously all is not right.
     
  7. Gump47371

    Gump47371 New Member

    Joined:
    Mar 3, 2010
    Messages:
    1
    Likes Received:
    0
    Just got this message also, third time in a week. Anyone have a solution yet? I am at a loss.
     
  8. JohnDaddyo

    JohnDaddyo Member

    Joined:
    May 7, 2010
    Messages:
    22
    Likes Received:
    0
    Can't say why but, all is OK with my card again. Doubtful it's the fault of the phone. These cards seem to be finicky.
     

Share This Page

Loading...