Infuse wi-fi connectivity problem. PLEASE HELP MESupport


  1. ames122

    ames122 New Member

    Hi,

    I used my Infuse in the US for like 8 months and I had to come home (Guatemala) this week. I unlocked it and rooted my phone with 2.3.6 Gingerbread UCLB3 / Kerner ver. 2.6.35.7-I997RUXKG3-CL366622

    Everything is working fine except the Wi-fi.
    It connects to my house's wifi, works for like 1 min, it disconnects, scans, reconnects, works for a min, disconnects, scans, and so on.

    I don't know what is the problem. I searched for so many threads;
    I read bunch of threads saying that if I change my DHCP lease time, it will work just fine but my router is given from the carrier and I can't seem to do that. :confused:

    I also read that if I re-root, it might work as well. So I finished re-rooting but nothing fixed the problem.

    Is my phone permanently damaged? why is the wi-fi is being like this?

    can anybody help me please?

    Advertisement
    :
  2. AtomicCEO

    AtomicCEO Well-Known Member

    I'm having this same issue all of a sudden with my phone.

    In the past I've dealt with the phone losing connections when it sleeps, or not jumping from network to network when I change locations... those could be fixed with one of the Wifi Fixer apps in the market. But this one is different. The connection dies while I'm actively using it, and the market apps do nothing except maybe make it reconnect in 30 seconds, but maybe not.

    What changed in my environment was the wifi router at my house. I got a new Actiontec C1000A from CenturyLink/Qwest DSL. I can still connect fine to the wireless at work with no dropoffs.

    I upgraded from the Infused Gingerbread ROM to Paranoid Android Jelly Bean after the problem started, and despite new kernel and OS, the problem persists.

    It's got to be some incompatibility with the wifi router at this point, despite the fact that all my other laptops, phones and tablets connect fine. Tonight I'm going to mess with some settings on the router... turning off 802.11n mode, maybe experiment with WPS which I disabled when I installed the modem.

    If all else fails, I have a D-Link wifi router which I'll try switching to. I'll update when I find something that works.
  3. AtomicCEO

    AtomicCEO Well-Known Member

    Yeah, couldn't figure it out. I tried switching to b and g mode only... I tried extending DHCP lease to 365 days... I tried a bunch of settings changes. No dice.

    It works perfectly on an old D-Link wireless router. No disconnects.

    I don't know what you're using, but in my case... the Actiontec C1000A modem just doesn't work with the Samsung Infuse 4G wifi hardware for some reason.
Loading...

Share This Page