"Insert SIM card to access network services" - please help!Support


  1. TribalSpaceman

    TribalSpaceman New Member

    Hope somebody can help me.

    A few hours ago (about 10pm UK time) my GS2 suddenly lost all signal. I tried going into Settings > Wireless and Network > Mobile Networks but I just got the message "Insert SIM card to access network services".

    I am with Three UK and have tried both my SIM cards, but neither work. They will work in another phone though.

    I tried resetting it but that's made no difference, and now I wish I hadn't done it as I've just noticed that half my contacts are lost! They aren't showing up in my gmail account for some reason. It used to sync them automatically. :(

    There's definitely a problem with the phone itself anyway. When I try to access the IMEI by dialing *#06# it comes up blank, and under Settings > About Phone > Status many things come up as "Unknown".

    Is there anything I can do? I can't think what brought it on. The only thing I've changed on the phone recently is update the firmware, and that was an official version, and several days ago anyway.

    Thank you.

    Advertisement
    :
  2. haithamkhader

    haithamkhader New Member

    the problem is that efc files is misssing or damaged, the solution is as follow :
    * find the modem file of ur exact firmware.
    * be sure that there is a defference between I9100 and I9100G, so determin what firmware is already installed in ur device.
    *use odin to istall the modem file.
    *how to install as follow ( open odin, on phone bar add modem file , make sure re-partition is not marked, prepare ur device to download mode by pressing together volume dwn , power, ok. after that it will ask u to insure ur option to dowload press up volume key to continue , attach the device to pc the bar of COM3 will flash yellow color, then press start to initiate, after finishing detach the device and make deep rooting by pressing up volume , power and ok key together and stimulately. and perform re-rooting. problem solved
    qwerty875 likes this.
  3. IEEBY

    IEEBY New Member

    Hello, Newbie here :eek:
    I've got exactly the same problem as you described. I've not rooted or made any mods to my phone though.
    Did the solution above work for in the end ?
  4. mufcazza

    mufcazza New Member

    Hi guys while your phone is turned on, remove the battery then the sim card then put them back switch the phone on ;)
    Hope this helps make sure tho u leave the phone on while removing the battery :)
  5. pentor

    pentor New Member

    The above removal of battery then sim card worked instantly for me. I was suffering this SIM error and have not modded my phone or flashed it ever.

    Thanks for that.
  6. seangalaxy

    seangalaxy New Member

    Hello,

    I really hope someone can help me fix this, don't know what to do:-(

    I am having the exact same problem as described by 'TribalSpaceman' but on my Galaxy S3 and non of the usual tricks (restarting, removing sim/battery & factory reset) worked. I am not extremely technically minded so I am not sure what a missing efc file means and can't quite follow the instructions given to fix. Is there another solution? Can someone help me further or in more detail please. Thank you!
Loading...

Share This Page