Inspire 4G on prepaid plans... help!!!Support


Last Updated: 2012-04-30 03:25:48
  1. Abby1018

    Abby1018 Member

    Hi I'm from Mexico and I have a factory unlocked Inspire 4G which I use in my country and works perfectly fine. I will be going to the states for a couple of months so my plan is to get a prepaid sim card to be able to use my phone... I really really want a "voice,text,web" unlimited plan, so my biggest concerns are:

    1 which carrier is the best to get my unlimited plan?
    2 will I be able to use the data from that plan (I've seen others posts and apparently ATT gophone doesn't let you use data whit this kind of smartphone?)
    3 I've been searching and found that t-mobile has monthly 4G plans
    I'm willing to get the $70 monthly 4G plan as long as I know for sure I will be getting 4G speeds and not simply 2G
    4 if I get the monthly 4G will I be ableto use my phone as a WiFi hot spot?

    I'm determined to be able to use my phone while I'm in the states or should I just buy a prepaid phone (which I really want to avoid)

    So please any advice will be really appreciated :)
    Thanks in advance for taking the time!

    Advertisement
  2. djsampsondjsam

    djsampsondjsam New Member

    Walmart has basicly a prepaid plan that runs on AT@T's backbone. Can't for the life of me remember what its called right now. Ill look around and see if I can find the info. But its like $40 a month for unlimited text talk and web.

    Edit: I found it its called family talk. Its what I wanna switch too when I get off this God awful at&t plan.
    Abby1018 likes this.
  3. Abby1018

    Abby1018 Member

    Thanks for the tip I'll look into that and see what is best for me
  4. andrews317

    andrews317 Well-Known Member

    I believe you won't be able to have 4G on the Inspire with a T-mobile data plan because they work on different frequencies. If you want 3G/4G you will have to use AT&T.

    For the hotspot, I'm not sure because I use my Inspire out of the US as you do (in Honduras), so I just rooted the phone and flashed a ROM that lets me use Hotspot. If you do this procedure you will surely have wifi hotspot. I believe that if you do not root you would have to pay some extra money to AT&T so they can enable you this option.
    Abby1018 likes this.
  5. Abby1018

    Abby1018 Member

    THanks andrews317...

    So if understood... I believe that I won't have a problem about the hotspot since my phone is already unlocked cause I already I'm able to use that option in my country...

    I think I will get prepaid AT&T then just to get 3G/4G
  6. andrews317

    andrews317 Well-Known Member

    I am not 100% sure about the hotspot. Did you purchased your phone on the internet (like eBay or Amazon) or did you get it from a company in Mexico? The fact that the phone is unlocked doesn
  7. Abby1018

    Abby1018 Member

  8. andrews317

    andrews317 Well-Known Member

    Another option would be to sell your Inspire and get an Amaze 4G, which supports both T-Mobile and AT&T 3G frequencies. That way you will be able to get 3G on your prepaid T-mobile sim and on your carrier back in Mexico. But that would need some budget. Just saying.
  9. dannyboy52

    dannyboy52 Member

    just so you know, my inspire doesnt run on 4g in many places, i live in carolina and at&t told me we dont have 4g in my area, so it may be your phone wot work anyway
  10. calebd22

    calebd22 Member

    Okay I'm currently running the inspire 4G on at&t gophone plan and everything works fine. If you want it to work make sure that you register the sim card with your phone that you plan on using in the states. The only problem with the data is on prepaid it can't run on 4g which really doesn't matter since there is o.ly 4G in the big states right now. In order for the data plan to work though you need to configure your APN settings.
    To do this you got to settings> wireless networks> mobile network> access point names> then click menu and new APN.
    For the data plan to work put these settings in
    Name: ATT
    APN: wap.cingular
    Proxy: wireless.cingular.com
    Port:80
    Username: WAP@CINGULARGPRS.COM
    Password: CINGULAR1
    MMSC: http://mmsc.cingular.com
    MMS proxy: 66.209.11.32

    (if I didn't mention something in the APN settings leave it as is :) )
    After entering that in it should work for you just select it and reboot. I hope i was able to answer your question :)

Share This Page