1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Install Any App on Kindle FireTips


  1. smankins

    smankins Well-Known Member

    I second that recommendation. I have been using that on my phone and immediately installed it on my KF when I got it. Ease to move files between my PC, Phone, and KF.
  2. Charis5

    Charis5 New Member

    Wonder why the manufacturers of these devices do not just have the devices with this functionality from the beginning. There are too many smart people out there to limit what users can access.
    Great info on the Kindle Fire app installation.
  3. andywhoa

    andywhoa Well-Known Member

    I set my Kindle Fire to accept apps from unknown sources and then downloaded an app I wrote.

    The install screen simply says "App not installed."

    Any idea why?

    My best guess is my app uses the Google APIs to show maps. I wonder if the Kindle Fire doesn't contain them?

    Any help would be appreciated. I'd love to use my own app on my device.
    GalaxyNexus likes this.
  4. peskypesky

    peskypesky New Member

    AWESOME! Thank you. :)
  5. webslinger283

    webslinger283 Member

    For some reason i hit backup in es file manager after downloading a program i want on the fire. It backs it up no problems. It looks like an APK, has the apk extension...but when i move that file over to my fire it says "there is a problem parsing the package" and for some reason any apk that i install this way instead of finding the apk directly online shows up as a funny looking icon on the fire with an sd card picture and a stack of books with a ribbon around them. I am downloading the programs using my Galaxy Nexus (ICS) is there somthing i am doing wrong when i transfer or somthing? Thanks!!
    GalaxyNexus likes this.
  6. greywing56

    greywing56 Member

    Okay, please be patient with me as I'm not all that technical, but I can follow instructions. I've had my KF for 2 days and since I'm not in the US I cannot purchase or install any apps. So I've done some reading on how to sideload .apk files from my PC, which I have done, but there's no way to install them because I don't have the ES File Explorer. Next I downloaded ES File Explorer and copied it onto my KF (put it in the "Downloads" folder). But how do I install that? I tried emailing it to my KF through the "send to Kindle Fire" email address, but it's not showing up anywhere on my KF. Can anyone help? Once I install the ES File Explorer, I can begin sideloading apps and get (some of) the functionality I have paid for. (for those of you in the US who don't already know, non-US customers have NO access to movies, tv or apps at all unless you have a US credit card.)
    GalaxyNexus likes this.
  7. czervik

    czervik Member

    Aren't you concerned with viruses/malware using this site? It doesn't matter if you trust the app name you are downloading if you have no way to know if the app has been modified.
  8. grvthang

    grvthang Well-Known Member

    If you transferred the apk for ES File Explorer from your computer to the Doan;loads folder on the Fire, you have no way of installing it yet because you need a file explorer to locate it on the Fire (talk about a Catch 22!).

    I think your best bet would be to install ANY file manager right now, just so you can locate your "Downloads" folder. Try this: Go to 4shared.com on the browser, and search for "ES File Explorer apk". Follow the instructions to download it. When the download is complete, it will show up in your Notifications (click on the upper left-hand corner of the Fire). Then, when you click on the ES File Explorer apk you just downloaded, it will give you the option to install.
    Once you have the file explorer installed, you'll have no trouble finding and installing future apk's.

    I hope I explained that well.
  9. balimedianet

    balimedianet New Member

    how to instal android market on kindle fire can you help me?
  10. grvthang

    grvthang Well-Known Member

    For that, you need to root the device. Read the posts up on top having to do with root. I haven't rooted mine - I don't see anough advantage to it for me; I've installed everything I need the Fire to do. I get my Android Market apps on my Android phone and transfer them to the Fire.
  11. AndroidNomad99

    AndroidNomad99 New Member

    I tried using File Expert to copy Vending.apk form the sdcard to /system/app, and it kept failing (yes, I used Mount in rw). Ultimately, this is what I did that worked:

    adb push Vending.apk /data/local
    adb shell chmod 777 /data/local/Vending.apk
    adb shell
    # mount -o remount,rw /dev/null /system
    # cat /data/local/Vending.apk > /system/app/Vending.apk
    # chmod 777 /system/app/Vending.apk
    CTRL-C

    (the hash marks aren't typed, they're the shell prompt)

    At this point, I used File Expert to install the Vending.apk (3.3.12). After installation, take this opportunity to click the "Open" button and hook it to your account.

    I didn't see the app anywhere on the Apps page, and I was concerned that I'd have to keep installing it so I could access it (very funny Amazon, very funny). A little bit of googling solved that problem too. Simply google for this:

    "Kindle Fire – Market Opener"

    That will take you to munday.ws and a little app that installs and does show up in the apps list. ;)

    As of this writing, I've downloaded and installed Google Docs and am happily using it.

    Thanks to all for the hints and help.

    Marc
  12. I think that they discontinued filos. I'm not completely 100% sure on that one but my friend was trying to get it onto his Kindle and couldn't find it anymore. I'll do some more research and see if I can find anything on it.
  13. I've been using getjar a whole lot more than 4shared. Its easier to use and more efficient imo. 4shared just seems to be way to overdone in my opinion.
  14. It doesn't really matter if the app has a virus. If your a droid user, like everyone her, then you would know that there is a built-in malware/anti-virus/whatever else kind of virus protector built into it. So there isn't really a risk. To doing it this way.
  15. My guess from what you just now posted is that you do not have your Kindle rooted. Am I right? Because if you don't then you will not be able to get the Google API on to it without it being rooted. For instructions on rooting your device a guy by the name of Jcase made an easy to use way of rooting it, it only took me like 3:30-5 minutes to do the whole process. First and only Kindle root, and since he did not know of a method to adb mode I found the easiest way here.
    If you do have it rooted then you can download and unzip Google apk files that were in the rooting instructions and then unzip them using WinRar or whatever program you use to unzip files. Then load them onto your kindle from there. You should have the API after all that. If not drop me a PM on here and I'll look more into that. I got mine running the Google API through those instructions and works perfectly. I have to root the one I'm on again, since I had to send the old one in for a replacemant cuz the damn touch screen sensor was being a biatch and not responding.
    When I went throught the process of rooting it the first time and loaded up the Google apps up onto it, the API pack did come with it. If not however, go to a site like 4shared or getjar. I don't know if these carry the Google API anymore but they use to back when I was rooting phones and other tablets.
    Before doing that you need your Kindle to allow third party apps. I'll refresh your memory if you don't remember how to do this:
    1.Push the little gear next to the wifi and the battery icon in the top right corner, then select more.
    2. When you're at the list of all your settings scroll down to "Device"
    3. Scroll down to where it says "Allow installation of third party applications" and turn it on.
    Once doing those steps your now able to go to one of those sites search for whatever app you want on your stock kindle :) If its rooted, all I have to say is this, "Why the heck do you not have the Droid Market on your device already!?" :)
    Hoped this helped you out. If you have anymore questions or run into anymore problems then feel free to drop me a message through PM and I'll get back to you when I can :)

    Edited-Saw that my ******ed stock Kindle Fire screwed up a good amount of typing. Can't wait until I get my laptop back from the shop so I don't have to deal with this BS on my second KF device :)! It didn't recognize the spelling for Google, so in place it put Tootle,wtf!? Shouldn't they of already put "Google" in as a known word without me having to add it? I think that I went back and edited it no more then 30 seconds after posting this :p
  16. I think, I'm not quite sure about it yet though, that you have to download a certain apk file for the both of them. My friend was having that same exact problem too. He would video call someone, cool thing is is that even though the kindle doesn't have a built-in cam you can still see them and hear them. I honestly don't know if it was by luck or what. We did some searching through Google and weren't really able to figure out why a good amount of other audio/recording apps work and G-Talk and Skype don't. I'm still trying to figure that out, and once I do then I'll PM you about it.
  17. grvthang

    grvthang Well-Known Member


    I'd appreciate it. I have an android phone running both apps, so I'm not too worried about using them on the Fire. I would like to be able to use Google Voice Search, though. There are several threads on trying to use skype on the xda developers forum - no one's been able to get skype working where you can both hear and be heard.
  18. No problem. I really haven't had the time to look into it that much as of right now, but I've done some talking with my friends and they said that they have heard of some of their friends are able to run a full skype message with two-way voice working perfectly. The only problem was that it would crash the app after about 2 minutes into the call. I don't know what they did and my friends didn't how they did it. Ya I did loon on the XDA servers and there hasn't really been any type of update on that subject.
    The whole Google voice situation is that you should be able to use the API and it should be able to run a perfect Google Voice Call without any problems. Now if I read it right either on this thread or on another one that you weren't really into wanting to root your Fire, am I right? If so then there is a way for you to go in and download the API without having to do a full root on it. After that it should run Google Voice perfectly fine...
  19. grvthang

    grvthang Well-Known Member

    Yes, that's true - I'd rather not root if I don't have to. I didn't know you could install the API withoiut rooting. I'm so used to using the voice-to-text feature on my phone for entering text for searches, emails and text messages, that it feels weird typing everything in on the Fire.
  20. I know exactly how you feel. I have been that way still since I got my Fire on release day. Lol

    Sent from my Kindle Fire using Tapatalk
  21. SMK041

    SMK041 New Member

    Hi all,

    Looking to see if anyone is able to assist me here. Essentially I am trying to install the file explorer app on my Kindle Fire. My problem is that I am located in Australia, where the Fire is not sold. Anyway, I can't purchase any apps directly from the Amazon App store because I don't have an American credit card.

    Can anyone think of a way to get around this? I have a copy of the file explorer .apk file on my computer ready to send across to the Kindle, problem is that I can't navigate to where I put the .apk file without a file explorer (which I can't download, not even the free version).

    Any assistance is much appreciated!
  22. Airmaxx23

    Airmaxx23 Well-Known Member

    Once you get ADB running on your computer you can use it to install the app.

  23. Hamnat

    Hamnat Active Member

    I don't know what I am doing wrong but I cannot get the Nook app to work for my mom's Kindle Fire. We know how to convert epubs of course with Calibre etc. But, my Kindle I have the nook app working fine and linked to my B/N account I can sign in and read my epubs just fine.

    On hers When she tries to sign in I keep getting "Error failed to decrypt hash" so we cant get into the app past the sign in. Even if I try to put in my account info which I know works on my Kindle onto hers it still wont take it. Anyone have any clues why one would work and the other gets the login errors?
  24. biker99b

    biker99b Member

    I'll try out that browser. Yes, the browser on the Android is very slow.
Loading...

Share This Page