Install Apk's via Pc *4 Newbies*

Last Updated:

  1. suhel28

    suhel28 Well-Known Member

    ah.. as you all know the forum has been quite since the update cuz the root thing is not possible [for now] and we don't have much to do.. so just to kill time here is a guide to install applications on your android phone without copying them on your card and blah blah ....


    1. 1 SDK TOOLS
    2. 2 JAVA JDK & JRE

    STEP : 1 - "SDK"

    Download the SDK tools from here

    ---> FOR WINDOWS

    ---> FOR MAC

    ---> FOR LINUX

    STEP : 2 - JAVA

    Download Java tools from here

    Download Url

    Download JDK & JRE from that page.
    you'll need both of them

    STEP : 3 - Setting Up SDK

    after you've downloaded and installed java tools.

    extract the sdk archive files into any folder you like.

    now open SDK Manager.exe

    it will open and you'll see something like this


    just select any version (2.1,1.6,etc )and click on accept and install it will take some time and than you're done with the installation

    STEP : 4 - Test

    plug your phone
    make sure USB DEBUGGING is ON
    run cmd
    type adb devices in the dos window
    it will show something like this


    if it doesn't make sure you've installed everything correctly.

    STEP : 4 - Install


    the command for install is

    i would prefer if you don't complicate things.
    just keep your apk files in the c: or d: drive instead of any folder, you may also rename the apk file to simplify the task like 1.apk or something like that but remember no spaces

    example :


    you're done..


    Attached Files:

    ladyb_ and roninsenshi like this.
  2. Lupajz

    Lupajz Well-Known Member

    Or you can DL this small app for windows :
    You just need to find your adb.exe file and a app file you want to instal on your phone :)
    adb.exe file is in your sdk/tools/ directory :) Much easier to instal apps :)
    suhel28 likes this.
  3. suhel28

    suhel28 Well-Known Member

    true but to run sdk you need those java files
    raster03 likes this.
  4. Lupajz

    Lupajz Well-Known Member

    Well I don't remember downloading those java files o_O And even I didn't download all those android packs in sdk :) Just the 2.1 pack + usb drivers.
  5. suhel28

    suhel28 Well-Known Member

    edited my topic thnks for the add-on :)
  6. romzL

    romzL Member

    does the application Astro File Manager do the same as this tutorial does?
  7. Lupajz

    Lupajz Well-Known Member

    Yes it does :)
  8. Yarrr

    Yarrr New Member

    If adb cannot find your device even though you have enabled USB debugging on it, install PC Companion app first, which installs some USB driver for it. Then when connecting your device just in charge battery mode, it will be found.
  9. romzL

    romzL Member

    i can't seem to install any apk when i use the appsinstaller. i already installed all the drivers. i already selected the .exe file on my SDK and chose the apk that i want to install but i can't proceed further. i got stuck in choosing packages. i don't have any option to chose. please help
  10. coman_nick

    coman_nick Well-Known Member

    I use File Manager, which is almost the same as Astro. It's workin great. Just make shure you enable "install from unknown source" from settings->applications but it will prompt you to do it if you didn't. Also, make shure the apk you want to install is not corrupt. So basically no need for computer :). Maybe if you present us you situation in detail we can give you an alternative.
  11. romzL

    romzL Member

    whenever i type "adb devices" on command prompt, it says adb is not recognizable. i already installed everything that Suhel instructed above. what could be that im missing?
  12. romzL

    romzL Member

    i was now able to install root explorer on my phone using this at last! now my new problem is, im installing Xrecovery using root explorer but whenever I copy the 3 files given by Suhel, i can't seem to paste all of them. the only file that I was able to copy was the chargemon. i tried copying all of them but i can't find the busybox and xrecovery file to set permission. help!
  13. coman_nick

    coman_nick Well-Known Member

    What permissions? I don't remember that step, and it's not present in the tutorial. Try one file at a time. And don't worry, it will boot without a problem even if you don't get it right.
  14. romzL

    romzL Member

    this part of the tutorial where it says i need to set permissions on those 3 files.

    i also tried copying it one at a time but nothing happened. i even tried moving it. it dissapeared on the original xrecovery folder when moved but its still not on the system/bin folder. what could be the reason for this?
  15. coman_nick

    coman_nick Well-Known Member

    try search with root explorer (haerdware menu butt->search). See if it finds the files you have copied. Otherwise you could use adb push and chmod. But I really don't know the chmod command for "TICK ALL THE OPTIONS OVER THERE" (should be a number)
  16. romzL

    romzL Member

    i tried search and it didn't show its there on the system/bin directory. i really don't know how to use adb or chmod :(
  17. coman_nick

    coman_nick Well-Known Member

  18. romzL

    romzL Member

    i was able to make it work now! i installed busybox from market and i was able to copy those files in a snap! xrecovery works now :)
  19. ladyb_

    ladyb_ New Member

    i followed every instruction, but cmd keeps telling me, "abd is not recognised as an internal or external command, operable programs or batch file."

    what am i doing wrong? :/

Share This Page