1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Install CyanogenMod 7 (Gingerbread) in HD2 with everything working!!General


  1. Talderon

    Talderon Well-Known Member

    This information is now old. Please use this as a troubleshooting guide, but not be used as a FLASHING GUIDE.

    More complete guide for other ROM's is here:

    http://androidforums.com/htc-leo-hd2/273125-guide-android-your-hd2-start-finish.html

    My original guide posted HERE

    ================================================================================

    Ok, once and for all. I have the NAND build working, perfectly, no issues and I have followed these steps multiple times to make sure it works and has worked for me on EVERY flash. If you can't follow numbered instructions, you're going to mess it up.

    I am assuming you already know how to Flash NAND builds, have MAGLDR 1.11 installed and all ready to go, if not, start with other detailed and wonderful tutorials that others have written, then come back here.

    Best guide out there is Flashing Your First HD2 NAND Android Rom [For Newbs] - xda-developers

    1. Download the NAND build of the ROM HERE
    2. Extract it onto you Hard Drive somewhere you can get back to it (use 7zip)
    3. Download ClockworkMod Recovery from HERE
    4. Extract ClockworkMod zip onto your Hard Drive
    5. Copy the files in the copy_to_sd_root folder onto the ROOT of your SD Card
    6. Download GAPPS for GingerBread from HERE (this is the "26" version, do not use the "28" version as there are issues with it at this time)
    7. Copy the GAPPS zip file onto the ROOT of your SD Card
    8. Turn OFF your phone
    9. Power it on and keep holding the power button (this is the RED button that you used to turn it on). Do NOT let go until you are in the MAGLDR MENU screen
    10. Connect the USB Cable at this time if it is not already connected
    11. Using the volume down, goto Option 4: USB Flasher and press the 'Call' button
    12. RIGHT Click on the Installer in the ROM Folder you extracted in step 2 and click "Run as Administrator"
    13. Follow the on-screen prompts and flash the ROM
    14. Once it is done flashing, boot the phone fully into the ROM
    15. Once booted, reboot the phone allowing the ROM to fully load again
    16. Once it is fully booted, power OFF the phone
    17. Power it on and keep holding the power button (this is the RED button that you used to turn it on). Do NOT let go until you are in the MAGLDR MENU screen
    18. Select "Boot AD SD" and press the 'Call' button and recovery will load. THERE WILL BE ERRORS, BUT IGNORE THEM
    19. Using the Volume buttons, navigate to "install zip from sdcard" and press the 'Call' button
    20. Using the Volume buttons, navigate to "choose zip from sdcard" and press the 'Call' button
    21. Using the Volume buttons, navigate to "the GAPPS zip file you downloaded in step 6" and press the 'Call' button
    22. Using the Volume buttons, navigate to "Yes - Install {zip filename here}" and press the 'Call' button
    23. Once this is completed, navigate back to the main menu by pressing the power button (this is the RED button) to get back to the main menu.
    24. Select reboot system now and press the 'Call' button

    Oh, if you pressed the red button too many times and are now at a blank screen, just pull the battery and power up.

    Once you do all of this, then you are all set. Mine works like a charm. Wifi, GPS, Data, camera, camcorder, Calls work, Angry Birds work, Facebook, the whole ball of wax!! Sorry to the twitter folks, I don't use Twitter, however, the app does download from market but will not install, something about a missing shared library.

    If you get FC's on games, move them from SD to Phone storage and should work fine (Angry Birds for example).

    Hope this helps others out. :)

    Advertisement
    :
    RainSaeid and San Antone RR like this.
  2. lenoy68

    lenoy68 New Member

    Ok I have this installed on my HD2 and it is working perfectly but I am having problems using tether via USB.

    I am a NOOB and want to know what I have to do to get this to work or is this a lost cause?

    Any help would be appreciated and please be as specific as possible.

    Thank you.
  3. San Antone RR

    San Antone RR Well-Known Member

    OK. I did this and it works well. It's only been a couple of hours and the only issue I have so far is with SMS.
    I installed Handcent because I like the interface. The stock SMS still comes up as a popup when a SMS is received.
    Settings>messaging>and everything unchecked.

    Ideas?
  4. San Antone RR

    San Antone RR Well-Known Member

    No data/3G connection. My APN settings are correct in Settings>wireless>mobile networks>Access point names.
  5. San Antone RR

    San Antone RR Well-Known Member

    Still no data. All settings seem to be OK. Web APN has the green dot in front of it, but the MMS string setup has nothing where the dot appears on the web APN. I deleted the TMob APN altogether. it wasn't set as default, so I don't see how that could hurt it.

    I am banging my head against the wall. Input here?
  6. neosi

    neosi New Member

    i have a problem with this rom. i can make calls, you can hear me fine on the other end, but on my hd2 i sound metallic. and the dialler crashes.
    do i need to flash another radio?
  7. San Antone RR

    San Antone RR Well-Known Member

    I just reflashed and reinstalled from scratch. Problem solved.
  8. MrMcBill

    MrMcBill New Member

    Hey, I've heard 720p recording is just not possible with any android ROM. I've also heard the opposite. Does the camcorder in your ROM record in 720p with no lag? If not, would you, or anyone for that matter be able to shed some light on the 720p recording issue? Many thanks!
  9. Talderon

    Talderon Well-Known Member

    Last I have heard, there is no 720P yet for Android. I hope it comes soon though. :)
    San Antone RR likes this.
  10. vud911

    vud911 Well-Known Member

    Galaxy S series from Samsung have 720p camcorder recording and playback.

    Pretty sure there might be a hack for a few other phones that allows it too, like the Nexus S.
  11. San Antone RR

    San Antone RR Well-Known Member

    Another issue I have found:
    Not a big fan of the Gingerbread keyboard so I D/L'ed SwiftKey. I have used it in the past and like it. The keyboard itself works well, but when I tap the button for voice input, I get a warning that Google Voice Search must be installed. When I tap on the prompt to D/L, I get a warning that it could not be located.
    I have installed directly from the market, but Swiftkey still won't recognize the language module. I am currently using VLingo for voice and text entry. I dislike the keyboard, but am dealing with it.
  12. Talderon

    Talderon Well-Known Member

    With the newer CM7 builds out there, you no longer need to "flash" GApps to your device.

    Pretty much just Flash the ROM, boot into the ROM, open the Market app, log in, and it will auto launch a screen to install all of the GApps.

    Tip: Be sure that after you get everything installed and accounts to sync, reboot a couple times to "settle things in". Makes for a more stable ROM, at least it does for me. :)
  13. kingakoopa

    kingakoopa Active Member

    Hi there Talderon,
    first of all thanks for all that you have done for all of us here.
    we owe you big time pal !

    Right now i am trying to flash my nand with CM7/GB2.3.
    I get to your first step and try to download the nand build and i get with an error( posted at the bottom).
    Now i want to make sure i download the same exact thing as what you are talking about.

    Would you( or someone) be able to give me a download link to that exact same Mod so i can just download it and move on with the flashing of the nand?

    please please help Talderon/guys !
    gracias in advance amigos !

    -King

    =================================
    kingakoopa, you do not have permission to access this page. This could be due to one of several reasons:

    1. Please Read: New members (those with fewer than 10 posts) are not permitted to post to development-related forums. The developer forums are intended for experienced users and developers to discuss ways to improve technical aspects related to ROMs and Software. While you may be an expert, we ask ALL users to avoid posting questions about using or installing ROMs and software in the Development Forums. To encourage this new Users can read but not post in these forums.

    To ask Questions about developing your device, installing ROMs, software and themes you must go to the Q&A or General Forum.

    Remember, your question has very likely been asked already, so please search before posting.

    2. Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?

    3. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.
    =================================
  14. Talderon

    Talderon Well-Known Member

    XDA Changes their posting rules because people were posting question in the DEV for um and not in the Q&A forum or the thread for the ROM they had questions about.

    This was done earlier this year to keep the forums clean and I have found that it has been working really well. Especially since I take time to report posts to Mods if they are not in the right place and have them moved.

    People are getting the message.

    Ok, as for this post, it's pretty old now. You don't need to follow these steps as the ROM's have changed to the point where this post should be locked. This method was used back in the beginning of the NAND craze and before people figured things out.

    Another thing, if you post the link to the thread you want the download from, that will help a lot!

    Thanks!
  15. kingakoopa

    kingakoopa Active Member

  16. kingakoopa

    kingakoopa Active Member

    Thank you so much Talderon. !
  17. cpt.awesome

    cpt.awesome New Member

    sir anyone can help me with my problem..i installed the new Android Gingerbread CyanogenMod7 for HTC LEO...everythings working except the auto rotate...the settings are enabled but its acceronometer is not working...games with tilt functions are not working also...sorry noobs here...need help im new with android.
  18. AMcho

    AMcho New Member

    Just a thought, because I did the same thing with GingerBread, but is your "Orientation Lock" on? If so, cut it off by clicking on it. Maybe that'll help.
  19. leopheard

    leopheard Member

    Hi all,

    I'm after a custom ROM for my Android Starlight 2. I purchased this from lightinthebox.com in Nov and some internet searching has suggested it's an HTC HD7, possibly also an HTC HD2 as they run from the same hardware? (When I plug it into the USB it shows 'Media Tek MT65xx' & the settings on the device itself show and Android 2.2.1 with a 'Baseband version' MAUI.10A.W10.48.MP.V5.F1,2011/01/27 16:48 with Kernel: 22.6.32.9 and build: 10HX2.H7000.110601.AD22V1P41_EN.WVGAC.COM(AR1000FM _HI253)

    I can't find a custom ROM for the HD7 - is this because there's not one out there yet or because I'm looking for the wrong thing? Would it be suicide to try and flash a HD2 custom ROM?

    I've rooted the phone, fixed permissions, moved all the apps to the SD card etc. which has helped the speed, but it still does hang fairly regularly. Good phone, just needs to be a bit smoother.

    Any help at all would be greatly appreciated.

    Thanks

    P.S. Is lack of ROM above also the reason why I can't get SetCPU to work?
Loading...

Share This Page