Installed Pre-rooted GB, can't reboot into recovery


  1. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    I need some assistance from the experts! I recently installed the pre-rooted Gingerbread found here. It was a somewhat disastrous process, but I eventually got 4.5.573 up and running stable with ADW.Launcher.

    Now I want to back up my current ROM and experiment with some other ROMs, but I can't seem to reboot into Recovery mode. I am rooted, and certain apps have been granted superuser access (Titanium, Root Explorer, Droid X Bootstrapper, ROM Manager), but no dice on the recovery.

    For example, in ROM Manager there is an option for "Backup my current ROM". When I select that, it prompts me for a filename, then a message pops up that says ROM Manager has been granted superuser permissions, then it reboots normally. No backup, no terminal-like text with options for recovery, nothing. Same thing happens when I choose the "Reboot into Recovery" option.

    I also tried what had previously (on rooted Froyo) worked as a manual boot into recovery: holding the camera button while powering on the phone. Now that just gives me a normal boot, too.

    So...help! What's the problem, and how do I boot into recovery mode? Thanks in advance!

    Advertisement
    :
  2. mac16

    mac16 Well-Known Member

    Okay. First, you missed some pretty important rules when installing GB. Im not trying to sound like a nagging old lady or something, but please please make sure you have read everything before installing Gb as it is completely different then 2.3.340 (froyo) and the way we did things on froyo.

    First you have to use Droid 2 bootstrapper as droid x bootstrapper no longer works with GB. Although I just read today that some people had success with droid x bootstrap by having USB debugging DISabled. So you can give that a shot, but for most people Droid 2 bootsrapper is all you need. So that means none of your backups created on froyo are going to work. You can get the d2 bootsrapper for free if you look around, I have been looking for 10 min for you but can't seem to find the link right now :mad:

    Also if you go to GB the only way back to froyo is to SBF back to 2.3.340.
    thecarlsoncrew likes this.
  3. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    mac16 - hey, I'm a noob, so feel free to nag away! It's most likely justified. :)

    Yes, I used the D2 bootstrapper to perform the upgrade, but now that you mention it, it seems to have disappeared post-install. At the moment, my GB installation works great, no problems. What I can't do is boot into the ROM Manager recovery mode to create a backup of my current ROM or experiment with other ROMs. Are you saying that if I install it again on my GB and then the reboot into recovery will work properly?
  4. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    Success! I just reinstalled the D2 bootstrapper, gave it root permissions, and am now running a backup of the current ROM. Looks like that was the only key missing. Thanks for pointing me in the right direction!
Loading...

Share This Page