Installing apks through adb

Last Updated:

  1. itzmiandy

    itzmiandy Well-Known Member

    Hey Folks,

    I got a few requests from people who had deleted the Mi Launcher after rooting the phone and being stuck at a blank screen (I made the mistake too)

    Now for all of you who have done it, its easy to fix.

    If you are already connected to the internet on the phone, all you have to do is log into play store from your PC and install a new launcher.

    If you are not connected to the internet, then follow this method.

    1. Download the files from this link : platform-tools.rar

    2. Extract the downloaded file to a location of your choice

    for example - D:\SDK

    3. Download a launcher apk to the same location - D:\SDK.

    you can download holo launcher from here:

    Holo Launcher 1.2.4 - APKTOP

    4. Now go the folder, press the shift button and right click. You would see an option 'Open command prompt here' - click that to open command prompt.

    5. In command prompt type "adb.exe devices" without quotes and hit enter.

    6. you should see your device getting listed.

    7. Type "adb install *.apk " (replace * with the name of the apk file)

    8. Once get the success message, reboot the phone and you have the launcher installed.

    Hit the thanks button if the post helped.

  2. sooraj87

    sooraj87 Well-Known Member

    good post :)
    and here is the original launcher of A87 ..but i prefer go launcher!
    rahulbuddy likes this.
  3. dreambuddy

    dreambuddy New Member

    If i am not wrong for this the usb debugging should be enable in order to connect the device,but my problem is that i can not enable usb debugging because the screen is totally black. pls help me with another method where debugging is not necessary.
  4. ryshic12

    ryshic12 Well-Known Member

    try booting into recovery
    vol+ and powerbutton while booting
    and then connect your phone and do the above method
  5. sooraj87

    sooraj87 Well-Known Member

    i doubt stock recovery doesnot support adb..myt need cwm
  6. itzmiandy

    itzmiandy Well-Known Member

    Sooraj is right.

    You should be able to boot into fastboot mode.
    You can flash the CWM recovery through fastboot.
    ADB will work through CWM, so you can follow the method I have described above.
  7. Chandandeep

    Chandandeep New Member

    Please help..
    I rooted my A57...and by mistake deleted the Mlabs launcher....
    Now my homescreen is completely black...I can receive calls and sms...but can do nothing my homescreen disappeared..
    Moreover I unrooted it a hope to get the homescreen back but in vain..
    Also my USB debugging has been disabled...
    If I get to know a method of enabling USB debugging I can install launcher from pc easily...and get my screen back..
    Please do not give answers like... 'Go to Settings/Applications/Development/USB DEBUGGiNG...'
    I can not access my homescreen and hence settings..

    So I need serious help ....How can I enable USB debugging now..?any command or something..??
    Help me.....
  8. itzmiandy

    itzmiandy Well-Known Member

    Did you read the post that is just above yours?
  9. mscphysics2011

    mscphysics2011 New Member

    great post it really helped me
  10. debris

    debris New Member

    thanks bro for ur help. can u help me i'm getting problem in flashing cutom rom
  11. Hadron

    Hadron Well-Known Member Contributor

    Hi debris, and welcome to AF :)

    It will be easier for people to help you if you describe your problems. The more detail you can give the better.

    If it's not directly related to the subject of this thread it would be best to start a new thread for your problems - less confusing for other readers.

    Good luck :)
  12. mzee

    mzee New Member

    for me its stuck on flashing _ after using adb install launchername.apk nothing happening please help i tried many launchers even stock one
  13. pratim

    pratim New Member

    ERROR: Device not found :confused: Pls help somebody..:(
  14. jackoftrades

    jackoftrades New Member

    Hi..i have the same problem and i cant do the hard reset cos my volume button doesnt work and i dont think that usb debuggin is enabled in my mobile..i dont have the mlabs launcher and im stuck with a blank screen.i tried ur methid using adb but it doesn display the device name under the "List of devices" ..i still tried goin through with ur procedure and tried adb install appname.apk after which it runs a few lines further below with some commands but it doesnt give a success report.pls help with this.
  15. mcd123

    mcd123 New Member

    bro how will u install it from pc .. ??? i m also facing same problem.
  16. mcd123

    mcd123 New Member


    i tried above ur method .. after reboot it still shows blank screen ... plzz help

Share This Page