Installing Hero RomSupport


Last Updated:

  1. dynodroid

    dynodroid Well-Known Member

    Can anyway tell me why when I attempt to run busybox and copy the app_s folder over to the ext2 extension that it says its read-only file?

    I did su.
    I have root.
    I'm on JF 1.51 atm.
    I even tried to chmod the folder. Nothing seems to be working for me.

    I don't quite understand it. I've also tried very hard to use the ADB. But no success there either. On the laptop I have I can't even get the drivers installed, it's impossible. On my gfs computer though I have gotten the drivers installed and accessed adb. I've reached the shell and seen all the options. I attempted to push the apps with adb aswell and still nothing.

    I'm new to this whole terminal thing, so hopefully someone can help me out.

    Advertisement
  2. noonehereyet

    noonehereyet No One... VIP Member


    if your on jf's build it's not app_s that is for hero, if you want to move apps to sd run these commands...

    adb devices
    adb remount
    adb shell
    cp -a /data/app /system/sd
    cp -a /data/app-private /system/sd
    rm -r /data/app
    rm -r /data/app-private
    ln -s /system/sd/app /data/app
    ln -s /system/sd/app-private /data/app-private
    then just reboot the phone and your done...
  3. dynodroid

    dynodroid Well-Known Member

    No, not quite. That information is through the adb? Well, if you would've noticed that I mentioned I can't get ADB to run successful then all the code does me no good. Also, since I mentioned app_s and nothing about putting my apps on the sd card I figured you'd understand this is all in effort of installing hero.

    And last but not least, I would've thought you read the title of the thread before clicking on it.

    Anyone else want to give it a shot?
  4. noonehereyet

    noonehereyet No One... VIP Member


    well then i have to ask what os are you running that you can't get adb to work. I would also assume you are running on an older version of hero if you have to install app_s on the ext2 partition since most of the newer releases are compressed and do not need app_s on the sd to run not to mention they are using ext3 and if you do have a newer build the process of moving the app_s folder would be the same as moving apps to sd as well....

Share This Page