Insufficient space when i try to install any app?

Last Updated:

  1. francisco1

    francisco1 Member

    Ok well ive been looking around everywhere trying to find a solution but cant seem to find it so im posting it here.
    Recently i decided to start with a fresh rom. I am using mirage - cyanogenmod 7.2 or something like that. I installed all my apps that i needed etc. I also created an ext2 partition to use with link2sd. The partition is about 600mb.

    After a few dozen apps i started to get this error "insufficient space on the device"
    Everywhere i check they say to check if you have space on the sd card but i feel it has nothing to do with the sd card. In link2sd there is this partition called /cache/download which i think is where the play store downloads the apps before it installs them.
    Does anyone have a solution? Also i can post a screenshot of what i am talking about if i can.
    BTW im pretty new to this whole rooting thing..

  2. 350X

    350X Well-Known Member

    if you read the link2sd howto, it say you have to reboot sometimes to regain space when it does that.
  3. francisco1

    francisco1 Member

    I tried rebooting countless times it hasn't helped..
  4. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Check (Android) Settings > Storage. If it is using way too much space for apps, you'll have to wipe data/cache and reflash the ROM. I've had that happen to me on a few ROMs. It was due to me not flashing the ROM properly.

    If you have plenty of space, then you might just have to clear the data on the play store. Go to Settings > Apps > Management > All > Play Store > Clear data.

    Note that I don't have this device, so my directions may not be 100% correct with your device. But it'll be similar to that.
  5. MacFett

    MacFett Well-Known Member

    Check /etc/init.d/ for the file 01mvdalvik it is a script that moves your dalvik cache from your internal memory. This sometimes causes problems. If you do have this script rename it 01mvdalvik.bak or move it to /sdcard/ and reboot into recovery. Clear your cache and dalvik cache and then reboot device and go back to using Link2SD.
    francisco1 likes this.
  6. badblue1

    badblue1 * TRUCKS ARE BEAUTIFUL * VIP Member

    Since you are new to rooting i would suggest that you read the sticky^ "DO NOT FACTORY RESET YOUR ROOTED PHONE! "
  7. francisco1

    francisco1 Member

    I have tried deleting cache and dalvik in recovery. Still the same. I know it has nothing to do with my rom because i have seen people have the same problem even with the stock rom. I have enough space for internal memory, sd card and sd ext. They are pretty much only half filled. The only one that has 3mb left is called /cache/download. I believe it is in the phone and not the sd card. I have tried looking in cache but there is nothing in there.
    When i tried renaming the file 01dalvik i wasnt allowed to. I guess it is read-only.
  8. AndyOpie150

    AndyOpie150 <strong> <a href=" Contributor

    Try this from a terminal emulator:
    cd /cache
    mv download download.old
    mkdir -p /sdcard/cache/download
    ln -s /sdcard/cache/download download

    Note: The start of the last line is a small case L not an i. Make sure you get the spaces correct as well.

    This pretty much does what MacFett mentioned, just using a terminal.
  9. MacFett

    MacFett Well-Known Member

    What I posted and what Andy posted do the opposite thing actually. the 01mvdalvik moves the dalvik from the user partition to one of the system partitions. This causes the Play Store to think that there isn't enough space for a download.

    What Andy posted creates a director on the SD card and then tells the system to use that directory to download to it rather than /cache/download/ the problem with this method, is that it now causes the play store to FC. (It may work now, but 5 or 6 months ago when I last used it, it caused a lot of problems). This method used to work great.

    I know you said "other users of the rom don't have this problem." But did you check for this file? You may be using a build of the ROM that has it and they are not. The YMMV also applies to this situation.
  10. AndyOpie150

    AndyOpie150 <strong> <a href=" Contributor

    OK. Now I'm really confused MacFett??? This is taken from your post below: If you do have this script rename it 01mvdalvik.bak or move it to /sdcard/ and reboot into recovery.

    Didn't you just suggest for them to move it to the /sdcard/ as a solution??? Lol
    Maybe my eyesight is playing tricks on me, or is it my brain (duh, where did it go George)
  11. MacFett

    MacFett Well-Known Member

    Yes I suggested moving the script, by moving the script it no longer does anything. If it isn't in the /etc/init.d/ folder the device doesn't run it at boot.

    It is like the Startup folder in Windows. If the program is removed from the folder it no longer starts at boot.
  12. AndyOpie150

    AndyOpie150 <strong> <a href=" Contributor

    Duh! I think the newb in me was sneaking out.
  13. francisco1

    francisco1 Member

    Ok so now im confused. Should i try the terminal emulator thing as my solution or not? If not then how can i successfully rename the file and move it to my sdcard? If the device no longer does anything with the dalvik file how does that solve my problem?

    Ok so i found out how to rename the file using es file explorer. I renamed the file successfully,cleared cache,and cleared dalvik cache. I booted up and now i have 36.29mb used of 110mb. I can install apps now. One last question, will this work again when it fills up again?
  14. MacFett

    MacFett Well-Known Member

    You can if you want move 01mvdalvik back to /etc/init.d/ reboot clear cache and dalvik again. You may have the problem again, you may not.

    Otherwise keep it the way it is, you won't have as much space but you will be able to download and update apps.
  15. dfunk44

    dfunk44 Member

    I can't delete, rename or move this 01mvdalvik file. Every app I've tried to manipulate it just tells me it can't be done. Any suggestions?

  16. AndyOpie150

    AndyOpie150 <strong> <a href=" Contributor

    Are you using a root file explorer, or a terminal emulator?
    ES File explorer is the best free file explorer, but you have to go into the settings to set everything up. Make sure you mount the file system as r/w (read/write) or you will not be able to make any changes to the file system. Change it back to r/o when your done.
    dfunk44 likes this.
  17. dfunk44

    dfunk44 Member

    I've tried both ES and the stock one on the Mirage ROM.

    My terminal crashes every time I launch it, so I guess I'm SOL.

  18. AndyOpie150

    AndyOpie150 <strong> <a href=" Contributor

    Not yet.
    There is still your PC, Andriod SDK, ADB, and shell commands.
    Let me know if your up to it. It's actually really easy.
  19. dfunk44

    dfunk44 Member

    Please tell me the easiest way if u have time. So far I've used a terminal app, a couple mounting rw apps, but still get invalid packages and insufficient space all the time. Nothing seems to let me manipulate that file. Thanks in advance.
  20. AndyOpie150

    AndyOpie150 <strong> <a href=" Contributor

    Do You have the Java6 JDK and the Android SDK installed and in your computers system path?
    I'm assuming you have the LG USB drivers already installed, right.
  21. dfunk44

    dfunk44 Member

    Usually I use my mac, and that is rarely. It will mount the USB but I don't have any of the programs you mention on it. I could access a pc and install them tonight though.

    When I use the mounting apps to make it rw, the phone reads that it was a success. But I still can't do anything to that file, so maybe I'm doing something wrong.

  22. AndyOpie150

    AndyOpie150 <strong> <a href=" Contributor

    I have no experience with mac's. I'm just learning Linux on a computer with Ubuntu 12.04 and Gnome Classic (learned a little with the phone).

    Not a whole lot of mac user's here. If you can get access to a Windows computer, then install all these:
    1. The LG USB drivers- leave phone unpluged from PC. After install restart computer so the other two drivers will install. After restart plug phone in to finish install.

    2. The Java6- Java Downloads for All Operating Systems Version 6 Update 35

    3. The Android SDK- New pre-packaged ADB installation The easiest way to get the SDK installed with the path to the adb.exe in your system path. If you don't get the proper out put after typing in: adb devices with the phone plugged in then finish the rest of the tutorial. There is a link that shows you how to put the path to the adb.exe in manually.

    4. Open up a command prompt (terminal) and type in this:
    adb shell (you should get a # after, if not you will need to type in: su)
    cd /cache
    mv download download.old
    mkdir -p /sdcard/cache/download
    ln -s /sdcard/cache/download download

    Note: MacFett knows some more script for moving the dalvik. Try the script I used first and see if that helps.
    dfunk44 likes this.
  23. MacFett

    MacFett Well-Known Member

    Andy do you currently use that script ( in step 4)? Because the last time I used it it made the play store force close and I couldn't use it at all any more.
  24. AndyOpie150

    AndyOpie150 <strong> <a href=" Contributor

    I haven't had to use it in a while. The OP needs something that might work. I never had it force close the Market before?
    I didn't know how long before you would come along with the shell commands for the dalvik, so I gave him something that has worked for me in the past.

    If you throw it out there, I'll write it down so I won't forget it. Then I'll use it instead of the other.
  25. MacFett

    MacFett Well-Known Member

    What you posted is correct, but as far as I have seen with both of my Optimus Vs, it no longer works.

    If a file explorer is crashing, you can use terminal emulator to rename the file.
    Launch terminal emulator. $ and # mean the prompt, not something to enter. <- means press enter.

    $ su <-
    # mv /etc/init.d/01mvdalvik /sdcard/01mvdalvik <-

    This will move the script from the folder that is read on start up to the SDcard where it won't be read. After do this clear the cache and data for the Play Store, reboot into recovery and clear your cache and dalvik partitions then reboot. Just as a precaution you may want to uninstall one or two of your larger apps to ensure you don't run out of room when your dalvik is rebuilt on the internal storage.
    dfunk44 likes this.

Share This Page