Insufficient Storage Space Available when downloading apps?Support


  1. GoonerKing

    GoonerKing Member

    Hi,

    When i try and install apps from the market, it says that i have insufficient storage space available, when i have enough, both internal memory and on the sd card. i have tried the good old turn off and on again, and clearing the cache and data from the market, but both didn't work :mad: any one got any ideas?

    btw phone is unrooted htc desire on 2.2

    Advertisement
    :
  2. screamer

    screamer Well-Known Member

    i'll bump this, as i'm having the same problem, i've moved as much as i can onto my SD card, hardly have any photos on the phone, cleared all text messages & only have a few emails.
    i wouldn't say i have that many addps installed.

    any ideas before i do a factory reset??
  3. Jon_LTD

    Jon_LTD Well-Known Member

    Hi guys,

    How much is "enough" memory? If i remember correctly, you start to get warnings when your phone has less than 15 MB free. As I'm sure you guys are aware, a lot of people suffer from the lack of memory on the Desire and may not be a fixable problem due to the Desires limitations. The Froyo standard Apps to SD can only transfer parts of the app over and not the entire thing so that in itself is quite limiting. I'm sure I read that Gingerbread is more efficient at this and can store more on the SD so it could be worthwhile upgrading to the official update. But I don't think it would be a good long term solution.

    Wiping emails and messages wont really make too much impact unless you have plenty of large attachments saved on your phone, but they should automatically save on to your SD card.

    There are ways around low memory issues if you are unrooted with some of the guides provided on this forum. I can't link as I'm on my phone at the minute but will provide one if you can't find it later :)

    I know it may not be what you're after but the other option would be rooting and having apps2sd+ or something similar to help expand your memory. This is probably the best long term solution but obviously you can't do this if you don't root.

    Hope this sheds a bit of light for you as I remember how frustrating it was culling apps.
    screamer likes this.
  4. GoonerKing

    GoonerKing Member

    Hi screamer, I'm not sure I explained myself very well, what I mean is at the mo, I have around 14mb free on the internal memory and almost a gig on the SD card, but when I go to download an app, that according to the market, is 2mb, it tells me I have insufficient sorage, also it only seems to be happening since the update to the market was released
  5. rgs

    rgs Well-Known Member

    Could be Google+. It needs a huge amount of space. I had to uninstall it on my Desire running Leedroid. Even moving to sdcard left very little internal memory.
    R
  6. screamer

    screamer Well-Known Member

    no, that sounds just like my phone

    ok, i just updated 4 apps & didn't see the limited space message this time.

    my phone has

    sd card
    total space 7.9=39GB
    Available space 5.96GB

    internal phone storage
    Available space 22.33MB



    bloody annoying :(
  7. Jon_LTD

    Jon_LTD Well-Known Member

    Hmm. Which app(s) are you trying to download? I do know that the market size isn't necessarily an accurate reflection on how much memory it will take up. Angry Birds is 18.65 mb in the Market, but my phone reports it as 21.65 mb. Not a HUGE difference, but there is that difference there, I have a feeling the market displays the "zipped" apk file, and when it installs, it shows its true size. This is just speculation though.:p

    As mentioned in my earlier post, the guide for forcing Apps to SD without root is here.

    But with 22.3 mb.. There should be some room for movement. At least 7 mb to play with before the phone starts warning you that you are running out of room.
    sandozer likes this.
  8. screamer

    screamer Well-Known Member

    cheers for that link, i'll look into it [​IMG]
    sandozer likes this.
  9. Jon_LTD

    Jon_LTD Well-Known Member

    No problems. Be interested in the results if you follow it through :).
  10. screamer

    screamer Well-Known Member

    as i said, i'll have a look at it.


    i'm able to upgrade in 2 weeks time, the phones updating ok just now, i see adobe flash just installed through the night.

    i'm looking at the sensation :cool:
  11. Nagrom

    Nagrom Well-Known Member

    Well I'm suffering from the same problem, and I think I can top these stats.

    I've got 88MB internal free
    1.2Gig Free SD Card.

    And the app I'm TRYING to update is a hefty 453k.

    Insufficient Space Available.

    Go figure.

    Rooted running GV3.3

    Andy
  12. Nagrom

    Nagrom Well-Known Member

    Any solution to this yet? I can't update ANYTHING anymore. REALLY PISSING me off now.

    Andy
  13. Jon_LTD

    Jon_LTD Well-Known Member

    Nagrom, yours sounds like a bad flash IMO. Have you tried to apply apps2SD+ or anything similar? If so it could be something down that end. You have bags of room but refusal to install any more apps sounds like a dodgey flash.

    I'd back up with Titanium, wipe everything and reflash the rom. Sorry bud!
    Nagrom likes this.
  14. Nagrom

    Nagrom Well-Known Member

    Sounds like a plan. Thanks for the idea.

    It'll piss the missus off though as she hates me messing with my phone all the time.

    That'll make it worth it if nothing else LOL.

    Andy
    SscoootzZ likes this.
  15. Jon_LTD

    Jon_LTD Well-Known Member

    Ah mate, I know that feeling. As I've only rooted about 6 weeks ago, I tend to wait until the weekends on little "projects" as I work through the week and also work in the evenings so I can't do it then. I spend most of Saturday on the XDA board and Sunday flashing Roms, scripts creating backups etc and generally playing with my phone and reading. My missus thinks I'm obsessed. But I'm really enjoying learning all about this! In ways I like having my phone misbehave as I feel like I've achieved something when I've fixed it and learnt a little bit more.

    Everyone needs a hobby! :D

    Also, I'm the first person she runs to when her Wildfire is playing up a bit. Go figure :rolleyes:
    SscoootzZ likes this.
  16. bssasidhar

    bssasidhar New Member

    I have been facing similar problem for months now. certain apps wont update. This has nothing to do with amount of free space available!!!!!!!!!!!!. ITS A BUG.
    There are certain apps which give this error.
    The thing which worked for me was to uninstall those apps and install them back again(after making sure that u have little more than the required memory)
  17. of the way

    of the way New Member

    I also have this problem with a Desire. Only recently started happening. This is a rooted phone with apps2sd. I deleted apps until I had over 80 MB free on internal storage. I was finally able to install an app. Now I'm at 78 MB free, and I can't install anymore. Haven't done a lot of testing to see if 80 is a strict limit, but this is a little ridiculous.

    I don't know if this is relevant, but the Apps2SD gui no longer shows me any system info (internal storage space, sd card space, etc.).

    Edit:
    Ok, apparently my cache folder had a random 16.apk sitting in it that was thirty-some MB. Deleting that appeared to solve my problem.
  18. Nagrom

    Nagrom Well-Known Member

    You sure you're not married to my missus as well? LOL. Shes got a WF, and is always saying "Sweetheart.....what does this mean" when she buggers it up.

    Maybe I should get her a Nokia 3210 for xmas LOL
  19. wankel7

    wankel7 Member

    106mb free samsung epic 4g...can't install or update apps.

    Update....
    I ended all running apps and cleared the memory via thbe stock task manager....it let me downlaod and install a new app.
  20. TylerwLuke2

    TylerwLuke2 New Member

    I have an unrooted droid x, with only 5 small, non-default phone apps on it. And I have:
    7.40gb- total sd space
    4.02gb available sd space
    6.26gb available application storage space

    Yet I can't download an app that is only 9.37mb, due to "insufficient storage available".
    I've cleared browser history and cache and everything, and moved all the apps that would allow it, to my sd card. To no avail. Any suggestions on what's going on with my phone?:confused:
  21. NS4G Samuel

    NS4G Samuel New Member

    So I've had this issue for a while and i know i have enough space to download many apps.

    App2sd didn't fix the problem but what has worked so far is killing all the running apps in background while downloading the new app(s).

    I'll keep you guys updated if i find anything else.

    Running a stock Google Nexus S 4G 2.3.7

    Hope this helps
  22. pyoriainen

    pyoriainen New Member

    Hi, I came across the same problem after flashing to Gingerbread 2.3 on my Samsung Galaxy S. Although, maybe not a 'proper' fix, I noticed that unchecking "Unknown sources - Allow installation of non-Market applications" in Settings / Applications resolved this issue for me.
  23. NS4G Samuel

    NS4G Samuel New Member

    I'm going to give this a try. I might be having this issue because of the Amazon App Store. It requires the unknown sources box checked
  24. andyjwang

    andyjwang New Member

    apps2sd+ did resolve my insufficient storage issue
  25. andyjwang

    andyjwang New Member

    apps2sd+ did resolve my insufficient storage issue.
    My phone is Droid A855 with 16 GB sd.
    The software did say that I have 261.76 mb total and 69.27 MB left after I moved all eligible appls to SD.

    I had used the ROM Manager to clear the cache as well as Remap cache folder to my SD card, per the instruction on this url: http://forum.xda-developers.com/showthread.php?t=1329994
    But it did not resolve the issue. apps2sd+ did resolve my insufficient storage issue.

    1.) Download and install a terminal emulator
    2.) Open the terminal emulator and type su
    3.) Allow the app to always have root access and exit
    4.) Restart the terminal emulator and type su, the prompt should change to a #
    5.) Type the following commands:
    # cd /data/data/com.android.vending
    # rm -R cache
    # mkdir /sdcard/cache/
    # mkdir /sdcard/cache/marketCache
    # ln -s /sdcard/cache/marketCache cache
    ainoltabnz likes this.
Loading...

Share This Page