1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Insufficient storage spaceSupport


  1. Gabrandli

    Gabrandli Member

    I have an EMDOOR EM63 android tablet, I have recently done a factory reset. I have not installed anything to it because every time I try it says "insufficient storage space" please help.

    Advertisement
  2. waynus

    waynus Member

    Go into settings/ storage and see how much it says is actually available. How much are you supposed to have? Also do you have a memory card installed?
    Gabrandli likes this.
  3. Gabrandli

    Gabrandli Member

    Checked in settings/storage it says I have 4.7Gb of available space, and no I don't have an SD card installed.
  4. hiredgun

    hiredgun Well-Known Member

    Strange for sure, but everyone sooner or later has "insufficient storage space" problems so you are not alone. The strange thing is that even after factory reset you still get the message. Hook it up to the PC and see if there is anything in there that didn't get deleted even though there shouldn't be. Another factory reset could also help if all else fails.
  5. Gabrandli

    Gabrandli Member

    I have all ready done three factory reset and it has not fixed anything. As for checking with a PC for anything that hasn't been uninstalled, I just did that and there is nothing still on it. I did a test and downloaded nearly 2 GB of music to it, I can see all of the music and listen to it all.
  6. waynus

    waynus Member

    Confused as to why you have 4g of available storage and it says you are low? Have you tried restarting and/or pulling out the battry?
  7. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    funkylogik, Unforgiven and EarlyMon like this.
  8. Gabrandli

    Gabrandli Member

    I tryed to install your Storage Truth app but I get the same "Insufficient storage" notification and it doesn't let me install it. Do you think that if I root my tablet I might be able to find out what is wrong, and maybe fix it? Also I have heard some talk about side loading apps, maybe that will work.
  9. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Aw poo. Sorry, but as hiredgun said, that it is strange that after multiple resets you get the same message

    Hmmmmm, I think I'm going to have to sleep on that one and check around tomorrow
  10. Gabrandli

    Gabrandli Member

    @waynus I have tryed restarting my tablet, when I do it has trouble turning back on and can take up to ten minutes. As for taking out the battery it is saudered in and cannot be removed.
  11. EarlyMon

    EarlyMon The PearlyMon Moderator

    Rooting is not going to fix this.

    Neither is sideloading.

    Did you install apps again after you did the factory data reset?

    Did your installed apps go away after the factory data reset?
  12. hiredgun

    hiredgun Well-Known Member

    I'm certainly no expert in this, although I have had my share of "insufficient storage space" issues when there was enough, but if he could put 2g of music in there that pretty much confirms what we are all thinking that he does have the space and somewhere down the line it's the software that's dropping the ball on this right??

    P.S. As long as they are free apps, you could try to download them on the PC and pass them over to the tablet and install them like that. A lot of times if my phone says I don't have enough room when I'm trying to install and app I download it and put it on the SD card and it lets me install it from there!

    Gabrandli likes this.
    Last edited: Mar 2, 2015
    #12
  13. EarlyMon

    EarlyMon The PearlyMon Moderator

    Space where?

    Space has to be free in the temp area for the Play Store download and apps are going to install into /data (even if you put a part of them on the internal storage earmarked for media).

    If it's the temp area that's hosed, yes putting it in SD card storage (real or simulated) via a pc will bypass that problem.

    But if a factory data reset isn't clearing temp storage, you really can't trust what all else it's not clearing out.

    And that's a problem.

    PS - the Play Store is known to use /cache and /data/dalvik-cache for temp storage.

    Factory data reset has to clear those or its useless.

    If the device has a bootloader/fastboot mode, then you can try to clean out the worst of it by trying

    fastboot erase cache

    From a pc.
    Last edited: Mar 2, 2015
    #13
  14. hiredgun

    hiredgun Well-Known Member

    I assume on the actual Phone EarlyMon, as the SD card always has more than enough room. I don't know why it works, but it has for me on more than one occasion when I tried to download an app from the Play Store and the download was interrupted because it said I didn't have enough space. I downloaded it on the PC, passed it to the SD card and was able to install it that way. However, if you don't think this is the solution for everyone I won't suggest it again. As I said I'm far from an expert, but on my behalf I will say that I suggested it because it has worked for me, lol.
  15. EarlyMon

    EarlyMon The PearlyMon Moderator

    You misunderstood me.

    The Play Store downloads to a temporary area first, then installs to the final destination (/data), and then is *supposed* to go back and clear out the temporary area.

    When you've run into trouble, it's because your temporary area hasn't been cleaned - and so you're doing the work of the Play Store and using your SD card as the temporary area that you can see, download to, and erase after the install completes.

    There's absolutely nothing wrong with that advice besides it being too complicated for some people to want to try.

    And while I said no earlier, it's ok to try from your pc -

    adb sideload name-of-app-file.apk

    And see if it works out.

    That gets into having the right, working adb drivers and a lot of people never get that sorted out.

    Hence my advice - try for the fastboot erase cache.
  16. hiredgun

    hiredgun Well-Known Member

    Yes I misunderstood you, been living abroad too long I think, lol. Thanks for explaining it to me, I never knew all that was going on!!!
    EarlyMon and scary alien like this.
  17. Gabrandli

    Gabrandli Member

    @EarlyMon No I was not able to install any apps on it after the factory reset. I mentioned rooting because I thought that maybe I can go in and manually erase the temporary data you mentioned. If I go into the "fastboot mode" and try to erase the cache it just sits there for hours saying it is trying to erase, but it never does anything.
    EarlyMon likes this.
  18. EarlyMon

    EarlyMon The PearlyMon Moderator

    :(

    Is there a safe rooting method for your device?

    It may be your only option then.

    Apologies for shutting down the idea so quickly, my mind didn't see the problem clearly at the time. (embarrassed)
    Gabrandli likes this.
  19. Gabrandli

    Gabrandli Member

    I have heard that TowelRoot is good but that requires a download to my tablet, and I cant do that. If you have any suggestions for a safe rooting method, please let me know. I know a great computer guy, but he works mostly with Desktop PCs. He has already helped me with a few other problems on this tablet.
  20. Gabrandli

    Gabrandli Member

    Do you think it would be possible to install an app to an SD Card in another tablet, and then move the SD Card to this tablet and run the app?
  21. EarlyMon

    EarlyMon The PearlyMon Moderator

    Have you tried the suggestion to copy the apk to your SD card and tap it from the device file manager to install it?

    Problem with app installed on sd card is that only part of the app will go there. Without the matching piece from /data it won't work.
  22. Gabrandli

    Gabrandli Member

    No I have not tried that. if you could give me some instructions on how to do that that would be great.
  23. EarlyMon

    EarlyMon The PearlyMon Moderator

    Backup any free app on other working tablet to sd card using Astro File Manager.

    Place sd card in your tablet - and use file manager to browse into Astro backup folder. Tap apk to install, Astro restore not required.

    Or, download Towelroot to your pc. Plug in tablet. Drag and drop to tablet with Windows Explorer. Try to install as described above, using file manager on your tablet (not pc).
  24. Gabrandli

    Gabrandli Member

    I cant seem to figure out the Astro File Manager, It keeps saying "Copy Paste Fail".

    I can get the Towelroot to download to my pc, then I drag and drop it to my tablet after that I go into FileBrowser on my tablet and try to install it says "towelroot could not be installed. Free up some space and try again"
  25. Gabrandli

    Gabrandli Member

    I have solved it.

    I used an app called My APK's to make a backup copy of the app I wanted on my working tablet. I then connected my working tablet to my pc and copied the backup .apk file to my pc. I then connected my broken tablet to the pc and copied the backup .apk file to it. Finally I went into my Filebrowser on the broken tablet and installed the app from there.

    I know it is complicated, but it is all I can do to be able to install to it.
    Thnx to all that helped, I have been trying to solve this for almost a year and I couldn't have done it without your help.

Share This Page