Insufficient StorageSupport


Last Updated:

  1. daithidearg

    daithidearg Active Member

    Hello,

    I'm trying to install an update to Google maps and it says it's 6 MB in size but if I go to:
    Settings --> Applications --> Manage Applications it shows23 MB free.

    Is there a gap in my understanding?
    Is it a problem with the Google Play Store?

    My kernel version is 2.6.35.7 and the build number is Gingerbread.

    I already have app2sd which moves my apps to the memory card?

    I went into Task Manager and Clear Memory and it made no difference.

    Reading a small bit on similar threads. Would it be worth getting hboot?

    I deleted data from the Google maps apps to resolve this but just wondering is there a more permanent solution.

    Any suggestions?

    Regards,
    David

    Advertisement
  2. Powie21

    Powie21 Active Member

    Is your phone rooted ?
    Using app2sd on an unrooted phone is not effective as apps will still leave most of their data in the device memory.
    Using Task Manager and Clear Memory only clears the Ram that's currently being used by any running apps, this is nothing to do with the amount of device memory you have.
    To try and free up some memory try using a cache cleaner from google market and delete old call logs, unwanted sms, old apps etc.
    Unfortunately due to the Ace's small internal memory the only viable solution if you want to install lots of apps is to root your phone.
  3. daithidearg

    daithidearg Active Member

    Yes I do have it rooted. I have the Root uninstaller and I have removed apps with this.

    I suppose the biggest thing I'd be looking for is how can I tell the actual memory I have free.

    Settings --> Applications --> Manage Applications doesn't seem to give an accurate reflection of this.

    Appreciate any inputs people have.
  4. ayush29k

    ayush29k Well-Known Member

    What do you mean the 'manage applications' does not give an accurate reflection of the memory??
    You memory is exactly what it says it is.
    If you don't believe it then look in the Settings>Storage and see the status of your internal memory.
  5. daithidearg

    daithidearg Active Member

    The reason that I don't believe what it says to me is that it failed to install a 6 MB package when it showed 29 MB was free.

    I have emptied cache and removed data from some applications and succeeded in applying updates but Settings --> SD Card and Phone Storage --> Internal Phone Storage now shows as 26.61 MB which suggests this shows more or less the same thing.

    It's Droidsall Super App2SD I am using. Is there an alternative version that might be better?

    Confused why the install failed when I have enough space but these phones seem to have a crappy amount of space amnd maybe that's just something I need to live with.

    Appreciate the inputs.
  6. ayush29k

    ayush29k Well-Known Member

    Any app2sd app is useless without root, all it does is what you can do yourself through the manage applications setting.
    The ace stops installing apps and receiving messages when internal memory drops below 20mb. Above it there shouldn't be any problem, you should be able to install it now even if the memory drops below 20 after installation.
    Try a reboot and see if it works, also try a different application, maybe the fault is with the application.
  7. daithidearg

    daithidearg Active Member

    As mentioned in the third post it is already rooted. Also I believe I have it rooted correctly as when I set it up initially I could move a load of apps and saved a heap of space.

    Interesting to note that you can't install once the memory goes below 20 MB and I can keep this in mind. That might explain what was happening as when I did the 6 MB install with 23 MB free to start with it seemed to gradually increase till half way on the install and them immediately complete giving a message insufficient Storage. Strange that it would give this when there is still 10% but if that's the way it is I suppose there's nothing we can do.

    Thanks for your inputs.
  8. ayush29k

    ayush29k Well-Known Member

    I'm sorry let me amend my previous post, even with root you have do some modifications to the system to use your sd card as internal memory, root is only the first step, there's tonnes to do after that to get rid off all the restrictions and useless features samsung has added in their stock firmwares.
    You need an ext partition and a mount script to use the sd card like that.

    I have 500mb of internal memory, and i am not including the original phone's internal memory in that. :D


    If you had 23mb before starting a 6mb update, you should have been able to do the update, after the update the you should get the 'low internal memory notification' and your memory should show 17mb. There should be no problem in updating. I have done similar updates and my internal memory reduced to near 4mb, but the updates were successful.
  9. Mackinon

    Mackinon Well-Known Member

    Clear your Google Play app data and try again may be its the google play app that is having the false information about your storage
  10. HWR

    HWR New Member

    I found something that was taking up alot of cache space and it was Google Maps.
  11. tmf33uk

    tmf33uk Member

    Hi,

    My name is Teresa and I
  12. ayush29k

    ayush29k Well-Known Member

  13. tmf33uk

    tmf33uk Member

    Well, I was installing clockworkmod recovery in order to get the menu that would let me partition the SD card and mount it as internal memory. I may be mistaken in this.

    I think I can easily get back to version 2.3.6 and root my phone again, but I
  14. ayush29k

    ayush29k Well-Known Member

  15. tmf33uk

    tmf33uk Member

    I thought I had read quite a lot, but obviously not enough...well, it may be forever wrecked now. :eek:( If it does revive, I will definitely read a lot more and run it by you before attempting. If not....well, I guess I
  16. ayush29k

    ayush29k Well-Known Member

  17. guitarjay

    guitarjay New Member

    I have been trying to update 4 files from PLAY for about 2 weeks now. On 10/31, had 4 files to update. Sizes were 16MB, 13, 6 and 4. None of them would update due to the insufficient memory storage error. Got up this morning 11/1, tried again and the 16MB and 6 did update. The other 2 didnot do to this on-going problem. Trust me , I did not change anything on my phone from the 31st to the 1st. How could that happen?

    I tried this a few minutes ago and it worked. I moved the two largest Apps that I could to the SD card. Then I updated the remaining 2 Apps and they all succesfully updated, then moved those apps back to the phone! ( HTC Evo 4G)

Share This Page