Intermittent Blue tooth issues in 2.1.2


Last Updated:

  1. GoDDROID

    GoDDROID Member This Topic's Starter

    Joined:
    Mar 22, 2010
    Messages:
    13
    Likes Received:
    0
    I make a call and it connects but I can't hear them and they can't hear me. It doesn't matter if it is a incoming or an outbound call. Sometimes I have to power down the phone and turn it back on, the call then connects correctly. I'm totally bewildered!!! I have fresh 2.1.2/ a gumbo kernal. Any advice and help. Is greatly appreciated.
     

    Advertisement
  2. speedboat

    speedboat Member

    Joined:
    Oct 28, 2009
    Messages:
    8
    Likes Received:
    0
    I have the same issue. It seems to happen with any 2.1 rom. I'm actually considering the OTA sprint update to 2.1.
     
  3. GoDDROID

    GoDDROID Member This Topic's Starter

    Joined:
    Mar 22, 2010
    Messages:
    13
    Likes Received:
    0
    Damn! I didn't want to have to do that!!! I guess nobody is trying to fix the blue tooth issue?!
     
  4. cephraim

    cephraim Well-Known Member

    Joined:
    Feb 23, 2010
    Messages:
    169
    Likes Received:
    3
    FWIW, I also have this problem. I was able to "fix" it by toggling BT on/off/on whenever I get into my car. As you might expect, this causes a connect/disconnect/connect, and the audio problem is fixed (for me, at least)!

    To simplify this process, I've been working with the developer of Bluetooth Power Profile (in the market). This app's base capability is to turn on bluetooth when you plug in power. He has added a setting for we Hero/2.1 users with issues, that automatically does the toggle when you plug in power.

    I am not affiliated with the dev. I am just very impressed with how responsive he was to my request. The app has a 10-day trial, and is $1 after that. Well worth it for me. Your mileage may vary.

    Maybe this fix will work for you guys?

    Eph
     
  5. jeremysm1

    jeremysm1 Active Member

    Joined:
    Jan 5, 2010
    Messages:
    31
    Likes Received:
    2
    I have the same Bluetooth issues. The OTA update seemed to fix some of the BT connectivity...but the big issue that I currently have is when I'm already on a call and run to my car. I turn on the car, and in a few seconds the bluetooth connects--but leaves the call in limbo. The call is still active on the phone, and shows on the car's bluetooth screen---but I cannot hear the caller and the caller cannot hear me.

    I then have to hang up and call them back. Sometimes, I toggle on/off the bluetooth (I put a widget on my phone's home screen) and try the call again in 1 minute or so.

    BTW--this particular car is a newer Mini Cooper and has worked flawlessly with Bluetooth for every single phone that I've ever tried (maybe 6 phones over 2 years). Yeah, I've had quite a few phones. This is the first phone that the automatic connection is flawed---and this was not flawed in Android version 1.5.
     
  6. 330D

    330D From My Cold Dead Hands VIP Member

    Joined:
    Mar 4, 2010
    Messages:
    2,863
    Likes Received:
    779
    My guess is that you guys all have the audio loss problem. I had it, and flashed the eris fix from the link, and don't have it at all anymore. (I don't have an eris, that is where the fix is from)

    [FIX] Audiofix. Update as promised - xda-developers

    Good Luck!
     
    GoDDROID likes this.
  7. cephraim

    cephraim Well-Known Member

    Joined:
    Feb 23, 2010
    Messages:
    169
    Likes Received:
    3
    Holy crap!
    Does the Eris fix require a wipe? Or can you just go into recovery and "Flash Zip from Sdcard"?
     
  8. 330D

    330D From My Cold Dead Hands VIP Member

    Joined:
    Mar 4, 2010
    Messages:
    2,863
    Likes Received:
    779

    Put it on the root of the sd, boot to recovery, nandroid backup, flash away!
     
  9. jmonahan

    jmonahan Active Member

    Joined:
    May 8, 2010
    Messages:
    40
    Likes Received:
    3
    I have flashed both of the audio fix files and still have the problem with the bluetooth (in the two weeks that i have flashed the fix it has only dropped the audio 2 or 3 times on the handset but bluetooth was never fixed). The fix that cephraim discovered does work 99% of the time. It appears that the two are independent of one another.
     
  10. cephraim

    cephraim Well-Known Member

    Joined:
    Feb 23, 2010
    Messages:
    169
    Likes Received:
    3
    You tried the Eris fix? There are four on that page, right? What were the two you tried?
     
  11. 330D

    330D From My Cold Dead Hands VIP Member

    Joined:
    Mar 4, 2010
    Messages:
    2,863
    Likes Received:
    779
    I was just trying to give a solution... I did hear that when the audio loss does it's thing, that bluetooth doesn't work either, that is why I thought it may help.... I know how frustrating the audio loss is, so I know where you guys are at with the bluetooth... I hope you can find a solution:(
     
  12. GoDDROID

    GoDDROID Member This Topic's Starter

    Joined:
    Mar 22, 2010
    Messages:
    13
    Likes Received:
    0
    Thanks, for the info I'm going to try that app first and see how that goes, if that doesn't help I'll have to go back to fresh 1.1 or 2.1 which ever one is problem free.
     
  13. cephraim

    cephraim Well-Known Member

    Joined:
    Feb 23, 2010
    Messages:
    169
    Likes Received:
    3
    I assume you are talking about BT Power Profile. Please let us know how it goes for you.
     
  14. GoDDROID

    GoDDROID Member This Topic's Starter

    Joined:
    Mar 22, 2010
    Messages:
    13
    Likes Received:
    0
    I've tried it and it isn't helping. I use my bluetooth ear piece 100% of the time. Even w/ the settings set on for powered and unpowered my blue tooth still disconnects. I may have to try the eris update. Is this app working for anyone else?
     
  15. 330D

    330D From My Cold Dead Hands VIP Member

    Joined:
    Mar 4, 2010
    Messages:
    2,863
    Likes Received:
    779
    I'm sorry if I confused the issue.... It sounded to me that you guys were having an audio loss problem, and it was affecting your bluetooth also. As I read more into it, I don't think that is the case. You can try the audio fix, and it won't hurt anything, but I'm not sure it will solve your problems....
     
  16. speedboat

    speedboat Member

    Joined:
    Oct 28, 2009
    Messages:
    8
    Likes Received:
    0
    I experienced the audio loss issue once and the eris update did fix it. This bluetooth issue is definitely a different animal. I drive a 2009 Maxima and bluetooth worked flawlessly until I started messing around with 2.1 roms. I think I'm just going to flash fresh 1.1 because nothing seems to work. Really a shame everything just can't work...
     
  17. cephraim

    cephraim Well-Known Member

    Joined:
    Feb 23, 2010
    Messages:
    169
    Likes Received:
    3
    Speedboat - try the BT Power Profile. I drive an Altima, and the fix works to enable audio.

    GodDroid - you want to cycle the BT on/off/on. You can try this manually to see if it solves your problem. Probably won't, since your problem as yours sounds like you can't even connect.
     
  18. speedboat

    speedboat Member

    Joined:
    Oct 28, 2009
    Messages:
    8
    Likes Received:
    0
    Very much appreciated. This seems to do the trick so I'm sticking with Fresh 2.1.2 and I'll gladly plunk down the dollar for BT Power since Sprint/Htc/Google have issues working together on fixes.
     
  19. cephraim

    cephraim Well-Known Member

    Joined:
    Feb 23, 2010
    Messages:
    169
    Likes Received:
    3
    FYI - the Eris audio fix didn't work for me either.
    So, I guess I'm stuck with the BT Power Profile workaround.
     
  20. GoDDROID

    GoDDROID Member This Topic's Starter

    Joined:
    Mar 22, 2010
    Messages:
    13
    Likes Received:
    0
    Thanks 330D the Eris fix got me rockin' & rollin'!!!
     

Share This Page

Loading...