Internal Memory Full

Last Updated:

  1. Donchoudhry

    Donchoudhry Member


    I have bought Samsung Galaxy Gio a few weeks ago. Android LITERALLY changed my world. Amazing

    I am facing an issue though that has tied my hands to install some very imp apps. I have installed App2SD but still there are applications that cannot be moved to SD card, neither di I want to remove the apps I have already installed (all are important to me) and my internal memory is full. I badly want to install some more imp. aaps and games.

    I have heard there is a way to "root" the phone, make a partition in the SD card and, through some app, designate that partition to extended internal virtual memory. I have googled it and searched this forum as well but cannot find a workable and easy guide to do it.

    Please guide me. Need the solution urgently. Thanks in advance

    duytl.2006 likes this.
  2. asad1912

    asad1912 Member

    you see
    Android is a specialized type of Linux
    In linux...there is an almighty user called ROOT...this user has all the privileges to the system...

    so rooting your android phone is just the process of getting supreme privileges to your phone which the manufacture doesnt allow otherwise...

    the thing you are talking about(making another partition and installing apps on that)
    there is something called A2SD Darktremor

    first need to root
    then...follow this tutorial...make sure you use a card reader and not your phone

    and to enable Darktremor A2SD
    install this

    if you need more help...feel free to PM me

    Please do understand...I am not the most knowledgeable about android
    what i write might not be 100% correct but ill try my best to provide you with the most accurate information
    ByaKuro, duytl.2006 and Donchoudhry like this.
  3. Donchoudhry

    Donchoudhry Member

    Thanks Asad.

    I tried to root the phone. Followed following steps

    1. To begin, download the file from the link above and copy it to the root of your SD card.
    2. Power the phone off.
    3. Boot into recovery mode by holding the middle button and pressing the power button.
    When I powered the phone on holding the middle button. It didn't ask me to select any option but instantly gave me this message:


    I pressed the middle button again and it rebooted. But it has not rooted the phone I guess. Need help


    Attached Files:

  4. asad1912

    asad1912 Member

    When you pressed the power+ok entered Recovery Mode

    When in recovery just pressed the ok button...when the option 'reboot system now' was selected...
    use the volume buttons to navigate down and select 'apply'
    and press the ok button(middle button)

    this will root your phone :)
    if it doesnt restart your phone...just navigate to 'reboot system now' and hit ok :)
    Donchoudhry likes this.
  5. asad1912

    asad1912 Member

    by the way...
    i would really recommend installing a custom rom instead of rooting and all the installing darktremor and stuff

    i would recommend GioProLite...
    I have this too and am as happy as i could be :)

    Although im not using dark tremor
    Donchoudhry likes this.
  6. Donchoudhry

    Donchoudhry Member

    Thanks Asad. I have successfully rooted and created the partition (Did exactly as told)

    The next step to enable Darktremor A2SD mentioned here are too complicated for me to understand :). Can you please guide me in that.

    Thanks in advance
  7. PrimeGIO

    PrimeGIO Member

    hw many MB' s were free just after u bought ur GIO ? was it like 120/181 MB?? (i mean the phone free memory)....

    secondly, hw many apps did u installed ? and what are the apps that u were failed to moov ... pls specify...

    thanx in advance...
  8. asad1912

    asad1912 Member

    Download this
    Code (Text):
    Now extract this file...
    and rename '' to ''(without the quotes ofcourse :p )

    Now...put the two files: and in the root of your sd-card

    now install this app:
    Code (Text):
    this will let your run linux commands on your phone......
    run these commands on your phone:(on line at a time :p )
    Code (Text):
    1. su
    2. cd sdcard
    3. sh
    4. reboot recovery (reboot recovery)
    after you run this will reboot into recovery mode...
    choose this command:
    Code (Text):
    1. apply

    now install this app
    Code (Text):
    after you A2SD GUI
    choose the 'Delvik' Tab
    then select the Delvik's cache on SD-EXT
    and choose MOVE

    if your phone doesnt reboot automatically...reboot it yourself

    and...your good to go...this should(if performed right) transfer the apps to SD card :)

    I really hope I helped :) :) :)

    Do tell if you have any other problem...

    and dont forget to hit the thanks button if YOU think i deserve it! :) :)
    EngineBlock and Donchoudhry like this.
  9. asad1912

    asad1912 Member

    these are the apps which cant be moved to sd...unless you force them to sd...
    got this info from
    Code (Text):
    the red text is an example of the apps i added...
    Code (Text):
    1. If app uses any of the following features, it cannot be installed on the external storage. It's required by Android system.
    2. App Widgets, [COLOR="Red"]---Sense Analog Clock[/COLOR]
    3. Services, [COLOR="red"]---Watts[/COLOR]
    4. Input Method Engines, [COLOR="red"]---Swype[/COLOR]
    5. Live Wallpapers, [COLOR="red"]---Nexus Revamped Live Wallpaper[/COLOR]
    6. Live Folders,[COLOR="red"] ---*Never heard of them*[/COLOR]
    7. Alarm Services,[COLOR="red"] ---Alarm Clock Plus[/COLOR]
    8. Account Managers, [COLOR="red"]---*the built in app*[/COLOR]
    9. Sync Adapters, [COLOR="red"]---*no idea*[/COLOR]
    10. Device Administrators [COLOR="red"]---Lockout Mobile Security[/COLOR]
    Hope i helped...hit the thanks button...if YOU think i helped :)
    EngineBlock and PrimeGIO like this.
  10. Donchoudhry

    Donchoudhry Member


    You made such this complicated procedure so simple. This issue is so common and you gave the solution in such a layman terms that I think this post should be pinned.

    A small queries though:

    I made a partition of around 1 GB, yet the internal remaining memory is 107 MB? Why is that?
  11. asad1912

    asad1912 Member

    well...the android OS itself does need some space...

    you have almost twice as much as space i have without app2sd

    plus...i dont think you should make such a large partition for a2sd

    the biggest at most should be 400MB

    you really dont need that much space for apps...i mean the largest app i ever downloaded was angry birds rio...and i think thats about 19MB

    most apps are below 10MB...
  12. amd4phenom

    amd4phenom New Member

    A also has galaxy gio and i was little bit worry about memory thing. This solution is best but its very much difficult for newbies like us. I also has Huawei Ideos U1850 which is entry level android. For test purpose i root it and install custom ROM DroniX 0.4 version. For moving aaps i install App2SD and Titanium backup pro. search youtube "mazzahir" and you will find video tutorial.
    Huawei Ideos u1850 MOVE ALL APPS TO SD-CARD-URDU
  13. asad1912

    asad1912 Member

    @donchoudry...about your question in my visitors message
    to tell you the truth...
    i have absolutely no idea if upgrading to gingerbread will reset all the things you did....but im pretty sure it its a good practice to factory reset a phone after an upgrade....really actually helps a lot....

    the process of doing all these things will be the same i think...
    i havnt tested that out myself because i flashed a custom rom that already was rooted....and i dont use a2sd so i dont need the partitioning and then installing a2sd and the stuff...but the process of installing that is same...
  14. PrimeGIO

    PrimeGIO Member

    okay mate....thanx a lot...but this limitation is no more a concern for me ....(decided to roooooooooooooot :D)...and found da best/reliable tool (Super1 click)...

    good day..!!! :)
  15. duytl.2006

    duytl.2006 New Member


    I have upgraded my gio to gingerbread, and I wonder that does it work on this android version.

    Did you try on gingerbread ? Pls give me an advise.

    Thanks with best regards.
  16. illused

    illused Member

    Agree, pin it. I have to install Gingerbread because I want Flash, do I need to root?
  17. rutseg

    rutseg New Member

    I did the whole process on my phone and it worked like a charm until I tried "Dalvik Cache on SD-EXT" and "Move", it keeps saying "Not enough space left" and nothing happens. What to do?
  18. sahib071

    sahib071 Member

    I have also file in my sd card what should i do? shall i replace?
  19. sahib071

    sahib071 Member

    i tried that but still in my mobile 2nd sd card is not found? waht to do?
  20. jelleketorfs

    jelleketorfs New Member

    Doesn't really work for me I guess :s did all the steps and when i toggle dalvik cache on sd-ext and press Move! it reboots but it still stays on internal memoery for some strange reason

    So could you tell me what I did wrong please? :x
  21. EngineBlock

    EngineBlock Member

    It worked like a charm. Thanks Asad ! I had only 18MB available in internal memory and now 90 MB 8)

    One question, now will all apps be installed on SD card or i will need to transfer them individually by repeating the process you shared each time I get a new app ?
  22. leo89

    leo89 New Member

    ASAD the first file you said we should download is not available
  23. leo89

    leo89 New Member

    the first file is not available..... i manage to download from another site and everythin goes right but when I open A2SDGUI it says " better do a2sd check in terminal emulater, mayb my version is below
  24. illused

    illused Member

    Ok, now it took me forever to realise this but
    So if you have low memory, INEVITABLY you only need to chear your email cache. This is harder than it should be, the only way I found to do it is delete and add your email account. I tried Ti-backup Accounts, and email. Accounts doesn't do it, and email backs up and restores the files you don't want. The popular "cache clear" programs do not do this.
  25. putrifirus

    putrifirus New Member

    hello all,
    after i did all the steps as explained by asad,
    my Gio (android 2.3.6 after upgrade) stuck during reboot process,
    such a long, long, long time, still did not show the home screen..
    i don't know what's the problem.
    anybody can help me?

Share This Page