1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

Internal Partition(s) Corrupted?Support

Last Updated:

  1. cvhovey

    cvhovey Active Member

    First off, I have an older NookColor. Anyway, here's a little background:

    One day my NC was fine. Next time I tried to use it, it varies from bootloop to a dead screen. On rare occasions it will boot, but I get various system apps throwing me f/c right and left (Google Play, framework, etc).

    Let's see, I'm on an older CM7 nightly from a couple months back ... I believe nightly cm_encore_full-253m.zip. I believe the "m" nightlies were a modification (to minimize SOD).

    Anyway, I've tried various things from formatting system, cache, etc ... but all fail. I've tried the New Bootable CWM Recovery SD (XDA ... for Cyanoboot) as well as the CWM update (XDA), but not solving anything. Though the CWM update appears to install, it changes nothing as when I get back into recovery, I'm still on the old I've tried to install 7.2 and though it appears to go through the install okay (i.e. no errors), when I'm infrequently able to reboot nothing has changed. Still on the old CM7 nightly with the old CM skateboard bootanimation.

    I've tried the 8 interrupted boots to no avail ... possibly because the boot process fluctuates from going to recovery or bootlooping or black screen or succeeding ... so the 8 step process just doesn't work.

    Factory reset from within CWM recovery or from CM7 (when I luckily boot) does not work. Nothing wipes. All of my data and apps are still there. In short, no matter what I throw at it (try to flash) nor try to remove (format or reset), nothing changes.

    Its though something (system, emmc, or ???) has corrupted and locked me into where I was without allowing anything new to install or change?

    Any other suggestions on what I can do to wipe, go back to factory 1.0.1 stock, and start over ... or fix partitions to be able to move forward? The restore procedures that I have seen require formatting system, cache, etc. but as far as I can tell, noting is actually formatting anything. Nor is anything actually installing at all.

    In fact, when I try to remove CWR ... its still there. I have the nook-complete-restore-1.0.1.zip file, verified the md5sum to be correct, format system, format data, run the zip, but that doesn't do anything. Still have CWR.

    I'm usually able to back my way out of any problems, but since I don't know how this issue happened when my NC was fully charged and off ... turning into a battery dead NC for unknown reasons, not sure what next since I'm not making any headway. I've read various threads on similar problems, tried the steps (where links are working), but still stuck getting nowhere at all. I've even used different SD cards with differing bootable CWM images ... no dice.

    Any help you can offer would be appreciated ... otherwise I'm taking my 5# maul to this NC and dumping in the trash as I've spent too much time trying to fix without any progress at all. And not giving it away when I can't even get my own data to wipe clean.

  2. colchiro

    colchiro Well-Known Member

  3. cvhovey

    cvhovey Active Member

    Thank you ... I'm in the process of downloading the suggested files. I'll report back when I've followed your helpful guides!
  4. colchiro

    colchiro Well-Known Member

    I'm hoping you just have an old version of CWM and it's failing to format partitions.
  5. cvhovey

    cvhovey Active Member

    So far I'm not having any luck with the (C)rapidshare download of 1.4.1 ... 2 times the download has died on me. First time was 90%+ of the way and second time when almost 50%. Will give it one more shot.
  6. cvhovey

    cvhovey Active Member

    No luck! Though I was finally able to get 1.4.1 to download, similar to before, I cannot format /system, /data, nor /cache. Here is what happens with the bootable sdcard:

    1.) Formatting /system .... it just hangs and nothing happens until I finally have to hold power to shut it down.

    2.) Error formatting /data

    3.) Error formatting /cache

    Right now all I'm able to do is get a bootloop on the cyanogen(mod) ... skateboard ... bootanimation.

    Unless there's something else I can do, guess this NC headed to the junk pile. Still don't understand what happened since it went from running perfectly, fully charging, shut down (not even connected to anything at all at that point) .... to a piece of totally messed up crap.
  7. colchiro

    colchiro Well-Known Member

  8. cvhovey

    cvhovey Active Member

    CWM installed on my NC is ... same as that of the bootable sdcard you suggested. I checked on the 1.3, but like many NC links, its dead. I happened to have the restore to 1.1 that I'd saved from long ago, but it seems nothing I throw at the internal partitions goes anywhere.

    So I guess I'll check out an sdcard install of a rom ... if there is any around with a working link.

    Thanks for trying to find a fix.
  9. cvhovey

    cvhovey Active Member

    UPDATE: I was able to set-up CM 7.2 on sdcard using the size agnostic sdcard. However, I'm not able to flash the gapps after 7.2 installs. It appears because something is corrupted in the system that superuser is affected.

    With the sdcard bootable ROM, I tried the ADB flash of boot.img and system.img ... but even after that, it would not fix whatever the problem is. Though I can get into recovery with the size agnostic sdcard, recovery cannot mount/unmount the sdcard so cannot see the gapps to flash them.

    Looks like its time to consider the Kindle Fire or wait to see what's announced on a Nexus tablet......
  10. colchiro

    colchiro Well-Known Member

    If you're running a rom on your sdcard, I believe you copy your gapps to card like you did your rom.
  11. cvhovey

    cvhovey Active Member

    Tried that, unfortunately even when running a rom on sdcard I'm getting f/c right and left as well as NC crashing (black screen). Obviously something internal is corrupted to the point that I can't even run a rom off the sdcard without issues.
  12. colchiro

    colchiro Well-Known Member

    I gave away my NC over a year ago when I bought my HP Touchpad, but my wife still uses her's, even tho she also has a TP.

    The NC seems very slow to me and I don't understand why she likes it.

    Maybe it's time to move onto something faster?
  13. cvhovey

    cvhovey Active Member

    Yeah ... I'm actually checking out the Kindle Fire as its very economical, rootable, has some custom roms and appears to be some kernel tweaks, as well. The NC running a rom off the sdcard is even slower.
  14. colchiro

    colchiro Well-Known Member

    The class 4 (or class 2) Sandisk is regarded as the best disk for Android use, especially for a rom that boots off the card.

Share This Page