1. Good things coming in just a couple hours, stay tuned!
    Dismiss Notice

[International] A messed up ex-rooted S4 - please help!


Last Updated:

  1. Kasser

    Kasser Well-Known Member

    Hi all. I rooted my S4 successfully a few weeks back and it was working a treat. I have philz recovery which rooted and allowed me to perform the usual nandroid backups etc. I was also running stock firmware (Vodafone UK version).

    A few days back my backups would fail, and a message would say system error (or something like that). It did work before. Phone was still working well otherwise and was still rooted.

    A few days earlier Kies gave a message about new firmware. No problem I thought, will update with Kies then root again and all should be fine (I did this on my S2 all the time with no worries).

    Everything seemed ok with the update. The phone would take a long time to boot (still does) but all seemed normal (eg no longer rooted but working). However, my wifi no longer works. It does not even turn green when pressing the toggle switch in the notification area. Screen mirroring, which always worked previously, also fails to find my TV (dongle attached and lit up).

    I want to know if using odin and using stock firmware downloaded from the web will likely fix this issue? I am hesitating as Vodafone have said they will take my phone in for repair, but using odin will void warranty (I should be ok now as I used triangle away when I was rooted?).

    Looks like I also still have philz recovery rather than stock. Should I use odin to get stock recovery back on the s4 if I do decide to give back to Vodafone for 'repair'.

    I basically want advice from you experts about my best solution so that I can be up and running as before my idiotic decision to update via Kies. Of course, now Kies won't recognise my phone (i.e. says I cannot update using Kies) but it did before so I am in a whole heap of trouble.

    Do I just use odin and flash firmware and re-root (will it likely fix the wifi issue?), or do I just get stock recovery back on (I have the correct file, I think) and just give back to Vodafone who hopefully don't realise I was rooted and give me a new phone?

    Please help and forgive my stupidity!!

    Advertisement
  2. Shotgun84

    Shotgun84 Well-Known Member

    Have you tried a factory reset after the upgrade. 9 times out of 10 this will solve any problem caused by a firmware update. If the factory reset doesn't solve the problem personally I would reflash the firmware with Odin as that'll be the second thing Vodafone will do after a factory reset. If you do decide to hand your phone over for repairs having Philz recovery on there will mean that your warranty is void.
  3. Kasser

    Kasser Well-Known Member

    Hi yes have done numerous factory resets now but still wifi acts as if it's not a function on the phone!
  4. Rudedawg

    Rudedawg Well-Known Member

    Im confused. Kies recognised your phone while rooted? Its early and my eyes hurt. So excuse me if ive missed something.
  5. Kasser

    Kasser Well-Known Member


    Hi That's correct. Philz recovery was acting up (could not get it to complete a backup) so perhaps root was affected? I'm not so clued up on this (clearly!).

    Anyway, once I updated and realised I screwed up (very long start up time, no wifi) I got the usual message on Kies (your firmware cannot be updated etc etc...).

    It's with the network now and fully expecting them to tell me warranty is void. I'm definitely put off rooting the S4 for a while.
  6. Rudedawg

    Rudedawg Well-Known Member

    Silly question perhaps but the only times my back ups failed was because My sd card was full. This was something you checked I presume because you're not a silly puppy like me ?

    Also the kies thing baffles me as if your phone is rooted it shouldnt recognise it. Former S2 owner myself and it applied there too. I suspect a dodgy flash in the first place.

Share This Page