[International] Any advice on ROM flashing please?

Last Updated:

  1. Dai

    Dai Member

    Hey guys, I've been on android for a few months and just thought i'd share my failed ROM flashing experience with you all and see if anyone has any advice/suggestions.

    I have a UK version Galaxy S4 GT-I9505 on 4.2.2, which is locked to the 'Three' network and have been getting board with TouchWiz. Anyway I decided to Root and flash Cyanogenmod 10.1.3RC (from CM website under the S4 international section), using TWRP and ran into a problem. I rooted and installed TWRP fine using Odin3 v1.85, took a backup using TWRP and tried to install Cyanogenmod from the root of the sdcard and the fun began. Basically as TWRP began installing CM it would give an error along the lines of 'Failed to mount' (error message would disappear after a split second), then immediately kick me back to the boot screen where it would stay. I could still access download mode and TWRP, so i flashed the stock firmware using odin, rooted and installed TWRP, put the rom on the external sdcard and again the same thing happend when trying to install CM.

    This time I flashed the stock fw again and decided to restore my backup through TWRP. Clicked restore, selected the backup and partitions i wanted restored and would get the error messages

    E: failed to mount 'system'
    E: failed to mount 'data'
    E: failed to mount 'cache'
    E: failed to mount 'efs'

    After a few hours of trying i did manage to to get the backup to restore although each partition would restore randomly where others would fail, so I am basically back where I started with no custom rom.

    If anyone could share some suggestions, advice or solutions on why Cyanogenmod would fail to flash, it would be greatly appreciated.

  2. sntaylor

    sntaylor Well-Known Member Contributor

    I'd check on the cm10.1 thread over at xda, and find out what the recommended recovery is.

    I know when installing a cm10.2 based Rom I had to have the latest cwm to ensure it worked :)
  3. Dai

    Dai Member

    Just had a look over at xda and CWM seems to be the recovery of choice.

    I'll give it a go and post the results tomorrow, thanks for the pointer.
  4. Dai

    Dai Member

    SOLVED - I flashed the latest version of CWM and CM installed no problem, must have been something to do with TWRP.

    Thanks Again :)

Share This Page