[International] Can't ADB Sideload due to a driver


  1. matt190191

    matt190191 Well-Known Member

    Hey all trying to flash another rom for my HTC One via adb but my pc won't detect the phone when I put it in recovery mode (CWM touch). It seems to detect the phone when it is turned on but will not allow me to access the internal storage to drag and drop a new rom on it(Corrupt?)...which is why I'm trying to sideload as I don't have any other option.

    I have uninstalled all drivers for my htc one and previously had HTC Sync manager installed yet it still wasn't showing that my phone was connected when I type in "Adb Devices" while using the sideload feature in CWM.

    The driver that won't install is "HTC MTP DEVICE" every other driver seems to be fine, I've tried installing it via HTC Sync manager, A driver zip file from xda, and windows update and still fails everytime.


    Any Ideas? thanks

    Advertisement
  2. iowabowtech

    iowabowtech root@android:/ #

    Strange you can't access your storage when booted normally. Could be a sign of other issues and you may not be able to access it using adb either. Though you should be able to get adb recognition.

    The driver you're missing is what will show up in device manager as "adb interface" or similar. Not sure what you've tried so far but I've seen people successfully use the Unrevoked driver, the PDAnet drivers (loaded via the PDAnet install, and also the naked driver from xda claims it'll work on HTC as well.

    I'd perhaps try those in order. Also, if you still have HTC Sync installed, you may want to uninstall that as it can cause issues. Open device manager on your computer and after you install a new adb/fastboot driver, watch it while you plug in the phone to usb while in recovery. When you get a working driver, you should see Android Phone > adb interface pop up. Or similar, it could vary slightly.

    You can also test for adb devices without selecting adb sideload first. Just don't select any cwm menu options and issue the adb devices command. Should show up as Recovery + your device ID when you iron out the driver issue. Then you can switch to sideload. If you don't have a newer version of the sdk (or a mini sdk package that include tools and platform-tools), that could cause issues also. Old versions of the sdk didn't include sideload capability. Just mentioned that in case you haven't updated the sdk since a couple phones ago or something.
    scotty85 likes this.
  3. matt190191

    matt190191 Well-Known Member



    Hi, thank you for your reply i've done a little research and it appears I may have corrupted the internal storage as when I try and wipe/format using cwm I get this error "can't format unknown volume /external_sd" Not sure How i'm going to get around this. I will check out the drivers you suggested now. thank you. My sdk is all up to date as of today. not sure how i've made this mistake though :?.


    Read up a little more on the unable to format storage and found this on xda



    "Yes, I just fixed my problem yesterday after some serious trial-and-error.

    1) Use the All-in-One-Kit and flash your recovery back to stock

    2) Boot into the bootloader and choose to "clear storage" and afterwards to reset to factory defaults.

    3) Go back to the all-in-one-kit and flash a CWM recovery version again.

    4) Reboot into recovery (CWM). Your /sdcard should now be mounted and visible.

    5) Now, try the UTB rom (it worked for me), rename the zip file to something short (i.e. utb.zip), and push it to the sdcard using adb as follows:

    Code:
    adb push utb.zip /sdcard
    6) While still in CWM, flash the zip.

    The trick here is that only the stock recovery is capable of restoring access to the sdcard by it's proprietary "clear storage" option."


    I'm still in the same predicament though as I can't sideload the zip. also when I try and take a screenshot on the device it comes up with an error "Couldn't save screenshot storage may be in use" is this another sign that something somewhere is corrupt
  4. iowabowtech

    iowabowtech root@android:/ #

    I think that might be ok since you don't have an external sdcard on the HTC one right? It's probably just recognizing that fact and skipping it.

    You should be able to get adb working with your device though while in recovery. It's just a matter of getting the adb interface driver set up.
    scotty85 likes this.
  5. matt190191

    matt190191 Well-Known Member

    Currently uninstalling all of the old drivers and starting from scratch. with the drivers you have supplied.

    installed drivers recognizes htc but still cant access internal storage. When I reboot to sideload something it comes up "HTc one driver not installed" but before I put my phone in recovery it said the drivers were installed when the phone was switched on. the computer just forgets it's there and deosnt recognize it after going into cwm...wierd
    scotty85 likes this.
  6. iowabowtech

    iowabowtech root@android:/ #

    It may well recognize the phone under regular conditions but when its in recovery, another driver is required (adb interface).

    How does it show up in device manager while in recovery? Unknown device (yellow question mark)? Plug and unplug a few times while watching device manager and see if you can spot anything appearing/disappearing.
    scotty85 likes this.
  7. WoohooGuy

    WoohooGuy Well-Known Member

    Was the driver package you tried from XDA the Koush ADB driver?

    If not give it a try.

    Koush
    scotty85 and iowabowtech like this.
  8. matt190191

    matt190191 Well-Known Member

    when trying to sideload it just says "One" with a yellow exclamation mark next to it. yeah it says adb testing interface with a yellow exclamation mark also. it said the drivers were installed prior to rebooting to recovery

    [​IMG]
  9. Thom

    Thom Premium Guide Member Guide

    Thread moved from Android Lounge to sub-forum dedicated to root-related issues with this phone/carrier.

    ... Thom
    scotty85 likes this.
  10. matt190191

    matt190191 Well-Known Member

    I'll try it now thanks



    installed it. definitely getting somewhere htc sync manager popped up after the installation and actually recognized the firmware on my device.

    still got yellow exclamation mark on adb testing interface though.
  11. iowabowtech

    iowabowtech root@android:/ #


    Perfect, that'll work. So the ideal scenario here is to find a driver which is housed in a zip that just contains the driver files, not an installer. Then you could manually update the unknown device that is your phone. The naked driver would fit that bill. Unzip to desktop into a regular folder. Then right click on the unknown device and manually update driver pointing it to the location of that new folder on your desktop. You can point it to the entire folder, no need to pick anything specific inside. Windows will auto search subfolders and files within that parent folder and if the right driver exists, it'll load it.

    Might want to try the linked Koush driver package prior to the above. I've seen it work on many phones also but it's an installer. Still worth a shot though.
    matt190191 likes this.
  12. scotty85

    scotty85 Guides Guide

    as far as the adb issues with the phone in recovery,what version of windows are you using? if your on 8+ do you have an older machine you can try?

    other than that,dont forget the basics:
    -try different cables and ports
    -dont use usb 3.0
    -dont use any hubs
    -make sure anything that could possibly try and comunicate with the phone is uninstalled or otherwise disabled. pda net,htc sync,easy tether,even i tunes can cause prollems

    for what its worth,im still using the old unrevoked drivers with no issues. i stuck with win 7,32 bit since phone crap is 95% of what i do with my pc :eek: ;)

    another option for you might be to use a usb OTG cable and sd card/adater or flash drive. should work fine to get a nandroid or rom to the phone if sideload wont cooperate.

    random thot... wonder if you could fix your sd card issue with root explorer. depending on wether your on 4.1 or 4.2+ the "sd card" should be located either at data/media or data/media/0. maybe that location just isnt there?

    is your phone booting and working?
    iowabowtech, matt190191 and WoohooGuy like this.
  13. matt190191

    matt190191 Well-Known Member


    I thought of trying with the otg cable and loading a new recovery and rom on there but I cant find a USB at the moment but if all else fails i'll buy one tomorrow. and the rom I installed was this one:

    Google Play Edition ROM with Android 4.4 KitKat and Root for HTC One!HTCOneRoot.com | HTCOneRoot.com

    everything seemed to be fine until i flashed gapps (Made sure I flashed the 4.4GPE GAPPS) also installed teamsevensense OC kernel. The Wifi doesnt work at all So i cant download anything from play store or anywhere for that matter.
  14. matt190191

    matt190191 Well-Known Member

    Tried that and it says "the best driver software has already been installed (HTC MTP) even though it hasn't and still has the exclamation mark next to it
  15. WoohooGuy

    WoohooGuy Well-Known Member

    It wouldnt be the first time a manufacturer suite conflicted with development, you may want to consider uninstalling the HTC sync manager for testing.

    Keep in mind you should make sure any data the sync manager is currently storing will be safe and it may actually uninstall some of the drivers the Koush ADB package installed.

    To start clean you should use the respective uninstallers for both HTC sync and Koush ADB package, reboot, then reinstall the ADB package for testing.
    iowabowtech, matt190191 and scotty85 like this.
  16. scotty85

    scotty85 Guides Guide

    just so im understanding,will recovery see your sd card? if so,have you tried reflashing the rom without the kernel and gapps(theyre included,so you didnt really need to flash them)?
  17. matt190191

    matt190191 Well-Known Member

    Will uninstall both now


    thank you
    scotty85 likes this.
  18. matt190191

    matt190191 Well-Known Member

    Yeah it will see it. when it comes to formatting it gives an error. Stupidly I deleted the rom off internal storage after the flash procedure didn't think I'd need them I was wrong.....
  19. matt190191

    matt190191 Well-Known Member

    Done it! it showed up as galaxy nexus in device manager but I don't care..it worked haha

    Uninstalled HTC Sync then rebooted..then installed the universal driver updater and it found it straight away. I'm currently Sideloading CM11 now. all seems well.




    Thank you all very much for the help I was afraid that I'd completely broken it.

    Still have the same problem with formatting the error in CWM though.


    Thank you all again!
    WoohooGuy and scotty85 like this.
  20. iowabowtech

    iowabowtech root@android:/ #

    No big deal. Mine shows as a Gnex also and I'm running an LG G2. :D
    scotty85 likes this.
  21. chickent1ts

    chickent1ts Member

    Not to stray from topic, but I just went through similar issues on Linux with ADB. I had unmet dependencies, and had to change (and generate) a couple of configuration texts. For some reason (info in cache maybe? I may have forgotten to wipe before my last build), ADB wasn't seeing my phone.

    Finally got it working and sideloading properly. Once you get it going, ADB is fantastic from the command line. If you should get it working, don't forget to make a backup with it! It's really easy to do, and you can store it off the phone so you can restore all your apps just as they were in case of total brickage/meltdown. Really handy.
    scotty85 likes this.

Share This Page