[International] ECHOE Rom

Last Updated:

  1. dynomot

    dynomot Well-Known Member

    The only sure fire way to get updates without any risk is to be completely on stock firmware that your phone came with out of the box or updated officially via Kies or Over The Air (OTA). Eventually you'll get 4.3.

    At the present time it is a bit like Russian roulette using PC Odin to flash. While obtaining root has been successfully cracked and won't trip Knox users are reporting tripping it afterwards flashing different ROMs.

    At the moment I haven't with two different devices, both Knox enabled and both running completely stock firmware (see my signature). One of them has to go before Christmas. As of now either can be sold as used but in perfect condition, I trip Knox on either and I can only sell it as used with Knox tripped, no ongoing warranty and partially "broken". So unless a complete solution to tripping the Knox flag arrives (and the devs are getting there) I shall hold off.

  2. ironass

    ironass Well-Known Member

    #1.0. My thanks go to our two resident kamkaze test pilots... iT0mm0 and Syd.

    As you will see from my details on the left, I am now running Android 4.3, Echoe SuperSlim ROM. 754MB compared to stock of 1.58GB.

    #1.1. Installation

    I, carefully and thoroughly, followed the installation instructions for installation that are contained in post #1 of the Echoe ROM thread on xda. See also the noobs guide at the end of this post.

    I was on the non Knox ROM, MH1, and this ROM has not given me the locked bootloader or Knox security. This ROM is not suitable for anyone who is already on Knox enabled firmware as the custom recovery will blow your Knox counter I'm afraid.

    As I was moving from Android 4.2.2 to 4.3 I decided to do a clean install, as recommended in the Echoe installation instructions.

    #1.2. I flashed the XXUEMJ5 modem from DjeMBeY's Radio Collection thread via Odin as modems do not get changed in this ROM. I then did the Full Wipe that was recommended and then flashed the Echoe ROM .zip using PhilZ recovery, v5.15.8. I also installed the latest XposedBridgeApi framework apk as I wanted to use the Wanam Xposed app from the Play Store to mod the Echoe ROM with various features such as coloured Notification icons, transparent Notification bar and centred clock, among other things.

    #1.3. I also downloaded the Deleted Stuff file as I needed to place the SecLiveWallpaperPicker.apk into system/apps, following the instructions here and using Root Explorer so that I could use live wallpapers... sad, I know! I could have just flashed the Full version, which has no removed apps and then frozen the ones I didn't want by using the instructions in the Bloatware removal - Dummies Guide.

    #1.4. I also chose to re-install my apps but not settings to be on the safe side. OK... I cheated on a few apps and restored them, with settings, from the Titanium Backup I had made, prior to flashing.

    So far, everything is hunky dory for me. The only problem that I have encountered is that OBackup is not working and I am using ROM Manager for my nandroid backups.

    So far I have tested...

    1. Signal strength with MJ5 modem is on a par with 4.2.2 modems. Can't comment on 4G as Vodafone are still only in half a dozen big cities and I have not bothered with a 4G plan. HSPA -75dBm 19asu at home

    2. Wi-Fi is strong and clear and connects automatically.

    3. AdAway v2.8 is working fine.

    4. Camera/video are OK

    5. Music, on PowerAmp and Syd's volume mod, OK

    6. Video on MX Player is OK

    7. Live wallpaper, with SecLiveWallpaperPicker.apk installed from Deleted Stuff, OK.

    8. Gallery is OK.

    9. Transparent Notification bar with centred clock and coloured icons is OK with Xposed framework and Wanam app. Prefer 3Minit to Wanam but beggars can't be choosers. Miss my toggle bar torch.

    10. Email with K9 and texts with Handcent and WhatsApp are OK, haven't had a chance to use BBM yet.

    11. Ausdim kernel with, as is, settings seems OK'ish. Battery drop is under 1% per hour overnight.

    12. Android Lost, after going to Menu > Advanced > Re register at Google, and Android Device Manager are spot on.

    Most of the Android 4.3 stuff is, "under the hood", but this ROM does bode well for those of us that are not on Knox and locked bootloader and do not want them!

    #1.5. My advice for anyone thinking of switching to this ROM is... read everything, carefully and thoroughly, first!

    Here is a total noobs guide to flashing Echoe Rom by fAiLOfax, over on xda...

    I9505 unique ECHOE-ROM v5PLUS Flashing-Guide

    ironass motto... "Flash in haste... repent at leisure" ;)
    Sydney99 likes this.
  3. dynomot

    dynomot Well-Known Member

    Another excellent guide, from our intrepid and helpful Ironass.

    Now, and this is quite a serious question shall I stick with my SGS4, say sod Knox and jump in and join the party. Or should I keep my Note 3 with its huge real estate, S-pen and 3 gig of RAM?

    When I defected to the SGSIII from my SGSII I actually missed the banter and help I got from you all. I was actually delighted to be back. I am currently using my SGS4 (for this week) and I'm missing my Note 3's size, S-pen and split screen display. That and it's incredible battery life and charging rate. (0% to usable in less than five minutes of plugging in charger and less than an hour to charge up to full via OEM lead plugged into a USB car charger adaptor - even with Sygic running with full screen brightness). I will, which ever I decide to keep, once one is gone, root and go "Knox blown" with the other and mod away. Sod the warranty.

    I am hoping to be really, really busy in a couple of weeks time on call. Then problem solved I can keep both and pay for my share of Christmas. Not looking likely though.

    I digress and move totally off topic, but hey at least I know none of you will be bothered, the banter is what makes this and previously the SGS2 root forum, what they are.
  4. ironass

    ironass Well-Known Member

    On the + side for keeping the Note 3 is the fact that if you currently start a thread on the All Things Root section for the International version... you will be responsible for 25% of the the total threads! ;)

    What banter??? :dontknow:

    For those of you on the Echoe ROM, a new Ausdim kernel is out, v4.3v11. Based on the latest Google Edition, 4.3, kernel sources it rectifies some of the problems with S-Health, etc:

    Just flashed it in PhilZ recovery and seems fine! :thumbup:
  5. dynomot

    dynomot Well-Known Member

    What banter? Well not above, granted, but you are kidding oh ferrite bottomed one, surely?

    Oh sod this for a game of soldiers, I'm flashing, sod Knox. I can wait on my Note until Kit - Kat, but this ROM actually looks the part. Also I would be contributing by jumping in with a locked bootloader and knox enabled. Something no one here has done yet. It will be interesting to see if coming to this ROM from where I am now has any problems.

    I'm going to keep both my devices. :) your right about the Note 3 SM-N9005 Root forum, Ironass, there's less life than a morgue in there.
  6. dynomot

    dynomot Well-Known Member

    Right shower, tea and then crank up the aging laptop.
  7. iT0mm0

    iT0mm0 Well-Known Member

    Dyno going where even myself and Syd haven't gone before


    We salute you Sir
  8. Sydney99

    Sydney99 Well-Known Member

    Just a bit of a Health Warning for those of you who are thinking of flashing this but wondering about downgrading from this ROM to an older 4.2.2 firmware in the future if you find its not for you......

    The bad news
    Both Hawker and I had all sorts of issues doing this

    The good news
    We both got there in the end, and no triggering of Knox. Fab!!

    Personally, I came off ECHOE yesturday coz for the life of me i couldnt get the exchange security bypass patch to work. but otherwise it is a fab rom......but im now thinking of trying aagain. suckeeeerrrrr
  9. iT0mm0

    iT0mm0 Well-Known Member

    the new ausdim kernel seems to have sorted a lot of problems for me
  10. ironass

    ironass Well-Known Member

    :ditto: The latest Ausdim kernel, 4.3v11, linked in post #54, is definitely an improvement. Also, it has cut my overnight battery drain down to 0.5% per hour without changing any settings.
    Sydney99 and sntaylor like this.
  11. sntaylor

    sntaylor Well-Known Member Contributor

    Now 0.5% drain per hour is siyah territory.....
  12. Hawker

    Hawker Well-Known Member

    I installed SLIM and added the things I required from the missing apps zip
    I was really liking echoe during my brief stint on in, but I have to admit, I dont find wanam exposed, good as it is, as good as 3minit.

    The one thing that made me revert back to MGA was that Navigation instructions were suffering a huge silence when also playing music through BT in my car. For example:

    1. Navigation (or Waze) running, music playing in car, both using BT link.
    2. Music pauses
    3. few seconds later music starts again without any navigation instructions
    4. get even nearer to a turn, music pauses
    5. few seconds later, hear the very end few words of the navigation instructions
    6. music starts again.

    on MGA, as soon as directions are given, music is paused and the directions are heard immediately.
    Does anyone else have this problem?
    I may try FULL to see if its any better but really worried in case I have to go back to MGA, as I had one hell of a job trying to do so, as I lost my baseband/imei.
    Perhaps its not an issue now that the new audism kernel has been released.
    Sydney99 likes this.
  13. Sydney99

    Sydney99 Well-Known Member

    hawker, what steps did you take to "get back" ie. did you try nandroid or flashing thru odin??? just want to avoid your problems in future!!

    i'm now back in echoe family, thought id give another crack as loved the rom. don't know if its the new kernel, or the fact that last time i tried patching my email app with a command shell (is that the term??) before installing the wanam workround, but this time the wanam workround is working and exchange security is bypassed. happy days.

    i love the minimalism of the superslim version.

    will try navigation on my way to work for you hawker
    Hawker likes this.
  14. Hawker

    Hawker Well-Known Member

    Thanks Syd.
    Ok, here was my scenario

    Installed EchoE....:thumbup:
    Navigation lag, which is very important for me, so revert back to MGA....:thumbdown:
    Restored latest MGA OBackup with PhilZ....No Baseband/IMEI....:thumbdown:
    No problem I thought, as still on MJ5 modem....:rolleyes:
    Flashed MGA modem...:thumbdown:
    Restored latest MGA OBackup again, just in case....:thumbdown:
    Restored last MGA backup taken by PhilZ....:thumbdown:
    Restored just the /system and /data partitions of last MGA OBackup....:thumbdown:
    Restored last known efs backup....:thumbdown:

    By this time, my anus was fluttering faster than a bumblebee's wing....:willy:

    I then remembered seeing a SE Context setting in PhilZ settings so I unset this and I decided to restore /system and /data from an MGA OBackup one previous to the last one I took....:thumbup:

    So, either it was this setting, or there was something wrong with my latest OBackup. Personally I think it was the SE Context setting, as the md5 sum was ok, and I suggested this to someone else on XDA who had my problem and it worked for him also.

    Also, in hindsight, I think I should have flashed the MGA modem back on first whilst still on MJ5 before restoring my MGA backup. If I am in this position again, I will do this firstly.

    I would really like to go back over to EchoE MJ5, but this Navigation problem is a big show stopper for me. If I hear that this works ok for you guys then I might very well give MJ5 another go. I'm hoping the new Audism kernel may have had a positive affect on this problem. If I do give it another go, I can guarantee you an immense squeaky bum session from myself again in my MGA restoration. :D
    Sydney99 likes this.
  15. Sydney99

    Sydney99 Well-Known Member

    Trying to install ad away. Get error message saying problem parsing the package. Any ideas what this means?
  16. Hawker

    Hawker Well-Known Member

    It worked fine for me (v2.8) but I've heard others had issues.
    I've heard v2.5 worked ok for them.
    Sydney99 likes this.
  17. Sydney99

    Sydney99 Well-Known Member

    2.5 working fine!

    Hawker, just been for a drive through the Yorkshire dales. Listened to music through spotify and had Google navigation on. Transition between spoken directions and music was seamless and instant, with no gaps. So all seems to be working here. It was through headphones though, so maybe a bt thing?? Or maybe New ausdim kernel has fixed??
    Hawker likes this.
  18. Hawker

    Hawker Well-Known Member

    Thanks Syd.
    Would need a BT test though unfortunately, just to be sure before jumping in again.
  19. Sydney99

    Sydney99 Well-Known Member

    And you shall have one sir, tomorrow!
    Hawker likes this.
  20. ironass

    ironass Well-Known Member

    Dear Hawker and Syd...

    Sorry but I'm in the middle of the back of beyond at the moment.

    Good news Syd about your AdAway. The latest one works fine for me... see earlier post yesterday. Even better news is that your BT - car - nav is working fine. That will come as a relief to Merlin Hawker. Did you flash full or Slim?

    Hawker, everything is A.OK, for me, on this ROM and latest kernel so far. Latest Ausdim improved a few things.

    Both of you... I had a devils own job about a week ago when I tried CM10.2 and needed to go back to MH1. I blame using the latest PhilZ recovery and have since reverted back to using 5.15.8 as this was the last known good one for me. My problem caused me to vanilla install everything from scratch again... no nandroid. The file issue in the PhilZ post might be a red herring. Be reasonable lads... use 5.15.8 for nandroids before going to 4.3. When I can, I'll try and revert back to 4.2.2 by using a nandroid, to test this.

    Keep up the good work!
  21. Sydney99

    Sydney99 Well-Known Member


    I'm hoping won't need/want to go back again, but if I do was going to just go for a straight "vanilla" to avoid issues. But looks like some reckless fool wants to test his hypothesis about philz.....look forward to your feedback ironass!
  22. Hawker

    Hawker Well-Known Member

    Alas my poor old rusty buttocks. Premature as usual!
    Please re-read Syd's post (#67) paying particular attention to the BT detail.
  23. ironass

    ironass Well-Known Member

    My bad!

    That's what I get for speed reading on Tapatalk in the back of a Land Rover.

    I blame Syd. He should test these things properly.
  24. iT0mm0

    iT0mm0 Well-Known Member

    could you link to 2.5 adaway for me guys, i cant get 2.8 running

  25. Sydney99

    Sydney99 Well-Known Member

    iT0mm0 likes this.

Share This Page