1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International] FAILED (REMOTE:24 parsing android-info fail)

Last Updated:

  1. aholloway21

    aholloway21 New Member

    Hi all,

    Firstly, thanks for any help you can provide!!
    Having a nightmare trying to return my HTC one to stock.

    Currently bootloader unlocked, s-off/ rooted and running viper rom.
    Trying to flash the 02 UK OTA zip to go back to standard (with bootloader locked) and every time I try I get the "FAILED (REMOTE:24 parsing android-info fail)" error message.

    I have tried a few things now including flashing stock recovery by itself (didn't work kept getting the red triangle!). Tried using the EU RUU .exe file which didn't work (im guessing because the version (cid??) numbers didn't match).

    I really need to get the phone back to stock asap. I'm not a developer but know my way around with a bit of trial and error.

    Any ideas???

  2. scotty85

    scotty85 Guides Guide

    youre having trouble becasue the OTA file cannot be installed via the bootloader. it must be installed by the correct stock recovery. your stock recovery install did work,as wht you describe is what the stock recovery looks like. holding vol up and power on the triangle! will get you a menu. you can wipe cache,and try to install the OTA file using this menu,but if your main version,cid,mid,firmware,recovery,and some other factors are not correct,the OTA will fail. phones nowadays are doing multiple complex checks to keep us from tinkering with them ;)

    your best bet to return to whatever your stock build was,is to find an older ruu thats got the same middle digits: x.xx.xxx.x

    example,if your stock build was 1.28.401.7 then youd need something else containing the 401.

    if you changed mid or cid,change them back to stock. run the ruu,do not install a custom recovery,and wait for the phone to OTA to current.

    if no ruu is available,you try restoring it with a nandroid,and the firmware.zip file from the OTA. you could also "restore" it to something like stock european if you cannot find a stock ruu or nandroid.

    is your phone booting and working? should be easy to fix since youre s off.
  3. knutomatik

    knutomatik New Member

    I,m exactly having the soma problem. And no clue how to solve it.

    I'm trying to use T-Mobile_1.27.531.8.zip by Team Nocturnal which is exactly my version.

    I'm not quit getting the OTA part, can you please assist?

    Thanks a lot.

    [HIGH][tknecht@knutair:~/Desktop/android] ./fastboot flash zip firmware.zip
    sending 'zip' (980707 KB)...
    OKAY [ 40.771s]
    writing 'zip'...
    (bootloader) zip header checking...
    (bootloader) zip info parsing...
    FAILED (remote: 24 parsing android-info fail)
    finished. total time: 55.191s[/HIGH]

    [HIGH][tknecht@knutair:~/Desktop/android] ./fastboot getvar all
    (bootloader) version: 0.5
    (bootloader) version-bootloader: 1.44.0000
    (bootloader) version-baseband: 4A.14.3250.15
    (bootloader) version-cpld: None
    (bootloader) version-microp: None
    (bootloader) version-main: 1.27.531.8
    (bootloader) version-misc: PVT SHIP S-ON
    (bootloader) serialno: HT35XW906855
    (bootloader) imei: 355972054997516
    (bootloader) meid: 00000000000000
    (bootloader) product: m7_ul
    (bootloader) platform: HBOOT-8064
    (bootloader) modelid: PN0713000
    (bootloader) cidnum: T-MOB010
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 3804mV
    (bootloader) partition-layout: Generic
    (bootloader) security: on
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: RUU
    ERROR: usb_read failed with status e00002e8
    getvar:all FAILED (status read failed (No such file or directory))
    finished. total time: 0.054s[/HIGH]
  4. scotty85

    scotty85 Guides Guide

    and your answer is basically the same. you are trying to flash a file in the bootloader that is not intended to be flashed that way.

    the name of your file makes it sound like a rom,wich is flashable via a custom recovery(twrp or CW)
  5. zabih08

    zabih08 New Member

    i have the same problem but a little more complex
    i have done s-off with rumrunner,
    and while trying to install a custom rom i accidently deleted all the files including system from twrp :(

    now i have been trying to get back to stock rom but nothing is working for me,
    i just want my phone to turn on, and run nothing more then that

    please help me out
  6. clsA

    clsA Well-Known Member

    You can sideload a rom of run a RUU it's your choice

    Set the device into ADB sideload mode. In TWRP you do this by going to Advanced then ADB Sideload.
    From the command line, type adb sideload /path/to/rom.zip

    or find the correct RUU for you device here
    Collection of HTC One Graphical Reset Downloads. Stock Rom + recovery
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    heres some more info on the sideload:
    [HOW TO] ADB Sideload/Push if you Wipe Internal Storage And have no ROM to Flash - xda-developers

    being s off,you can use any t mobile ruu,or you can use any ruu period if you temporarily change your cid to 11111111.

    to change cid,put the phone in fastboot,enter:
    fastboot devices

    fastboot oem writecid 11111111

    there are available ruus here:
    AndroidRUU | The #1 source for Android RUU files

    i may also have some that are not there,if you need a particular one.

    here is an older t mobile ruu: http://www.androidruu.com/getdownlo...50.20_10.40.1150.04_release_324846_signed.exe

    there are some others here:
    http://shipped-roms.com/index.php?category=android&model=HTC One

    including the t mo jb ruu:

    edit #2:
    the graphical reset downloads linked by clsa are a package flashed in recovery,not an actual ruu.
  8. clsA

    clsA Well-Known Member

    Thanks @scotty85
    The link I posted has a download tab with all the current RUU.exe and zips, just so you know
    Edit: maybe this link would have been better ->>
    scotty85 likes this.
  9. scotty85

    scotty85 Guides Guide

    Thanks,I hadn't noticed that tab. Wen I get back to my pc ill have to check and see if there's any I don't have :)

Share This Page