1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International] Galaxy S4 USB no longer working

Last Updated:

  1. Jpoel

    Jpoel New Member


    Hi All,

    I have a problem!

    I have had my Galaxy S4 for a few months now, and it has been rooted most of it's life.

    Thursday night, it was fairly wet and I had my phone out whilst it was raining. When I got home, I put my phone on charge and went to bed. When I woke up, I found that my phone was stuck in a loop.

    The phone booted to the battery icon as if it would if it was charging. But the battery icon has a white "loading" circle infront of it. After about 5 seconds, the battery icon will vanish, and the phone reboots itself and does this in an infinite loop. The phone doesn't charge. I can't provide a picture of this as this is my first post.

    If I turn the phone on whilst it isn't plugged into USB, the phone will boot up and seems to operate just fine. But, upon boot, a notification appears:
    "USB Connector Connected"...well, it isn't.

    I can't connect the phone to the computer via USB and can't charge whilst the phone is turned on - nothing happens.

    My first thoughts are that the rain caused some kind of short in the micro USB port, but I don't recall the phone actually being that wet... I've tried the rice trick.

    My next idea is to unroot the device and revert to stock firmware to see if that makes any difference. And if it doesn't, then I want the phone to be in a position where I can hand it over to Samsung/O2 for repair without them throwing it back at me telling me it's been rooted.

    Ive reset my flash counter with triangle away but the device status still shows as "custom" in the settings menu...

    Can anyone shed any light on my USB issue or give me a guide on how to properly unroot my phone so I can return it for repair? Remember - I cannot connect via USB, so everything needs to be done on the phone only.

    Please Note:
    I've tried 3 different OEM batteries
    2 different USB leads
    2 different USB plugs
    Taking memory card/SIM card out
    Cleaning the USB port
    Rice Trick

    I'm currently using my phone by charging the batteries separately from the device in a wall adapter.



  2. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Welcome James:)
    We can move this for you...we just need to know what carrier you have ;)

    Check your p.m. inbox also .
    Thanks, and no worries...we'll getcha squared away:)

    Edit: D'oh I think I see you have the International version? Is that correct?
  3. Jpoel

    Jpoel New Member

    Yeah, I have the I9505, I'm thinking of flashing back to stock firmware using mobile odin as I think it's my only option.... thoughts? :(
  4. Jpoel

    Jpoel New Member

    Reset my flash counter with Triangle Away and flashed to stock with moble odin, problem still exists so I assume it's a hardware issue. You think I'm safe to hand this over to samsung now? In download mode, my device status says "Samsung Official". And in the settings menu, the status says "Official" too. Strange thing though, if I insert my old memory card, the status changes to "Custom"... anyone know why this is?
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Moved to the SGS4 root section, thanks. :)
  6. sntaylor

    sntaylor Well-Known Member Contributor

    What was the custom Rom you were running when this happened?I had very similar issues(without the rain) when I had been trying out a GE Rom, as it turned out it would work ok plugged into the computer in download mode, so I flashed complete stock(recovery and all) left it unrooted for a while and it's been fine since!

Share This Page