[International / GSM] Connecting Galaxy Nexus to Windows PC


Last Updated:

  1. Old Member

    Old Member Well-Known Member This Topic's Starter

    Joined:
    Mar 23, 2010
    Messages:
    2,586
    Likes Received:
    1,905
    I have installed the "Naked Samsung" drivers on my computer but when my Gnex connects I can't get it to display files in MTP mode only in PTP mode. It won't let me put any files on my Gnex in PTP mode.

    Does anyone know how to connect my Gnex in MTP mode?
     

    Advertisement
  2. trophynuts

    trophynuts Well-Known Member

    Joined:
    Jul 6, 2010
    Messages:
    5,630
    Likes Received:
    1,792
  3. ssick92

    ssick92 Well-Known Member

    Joined:
    Jan 19, 2010
    Messages:
    289
    Likes Received:
    41
    At least when I connect my GNex to my PC, in the notification bar, I can click on "Connected as a media device"

    After I click on that, it gives me 2 options: PTP, and MTP. Mine is defaultly on MTP, so you may need to switch it.
     
  4. Old Member

    Old Member Well-Known Member This Topic's Starter

    Joined:
    Mar 23, 2010
    Messages:
    2,586
    Likes Received:
    1,905
    It's not working.

    I plugged in my Gnex. I installed drivers manually with the "Naked Samsung" drivers. It didn't work so I uninstalled the "Naked Drivers" and installed "ADB Drivers" and it still doesn't "work". This is much harder than the Dinc. I don't like it.
     
  5. pool_shark

    pool_shark Well-Known Member

    Joined:
    Aug 21, 2010
    Messages:
    2,482
    Likes Received:
    540
    I haven't installed any drivers. Windows did the install as soon as I plugged it in. I've already transferred files that way as well as over wifi.
     
  6. ArXane

    ArXane Well-Known Member

    Joined:
    Nov 6, 2009
    Messages:
    113
    Likes Received:
    25
    Does Device manager see an unknown device? I could fastboot, but couldnt see it in windows. I changed USB cables and that fixed my problem.
     
  7. nExUsTiMe

    nExUsTiMe New Member

    Joined:
    Dec 25, 2011
    Messages:
    3
    Likes Received:
    0
    any resolution here?

    im havin this issue.. installed the necessary drivers, but windows wont accept them?? and then when just havin windows find the drivers, it says nothing found or failed... the last 2 days ive been tryin to find an answer or just mess around with PC settings.. no phone settings have changed and all settings listed above have been confirmed, so im really lost

    if anyone can assist.. greatly appreciated.. merry xmas
     
  8. nExUsTiMe

    nExUsTiMe New Member

    Joined:
    Dec 25, 2011
    Messages:
    3
    Likes Received:
    0
    windows is showin it as an unknown device on my PC.. im even usin the cable that came with the phone. still nothing
     
  9. nj02vette

    nj02vette Well-Known Member

    Joined:
    Jul 9, 2010
    Messages:
    2,346
    Likes Received:
    2,034
    Correct, no special drivers are needed for MTP mode. For anyone with problems, I'd suggest uninstalling whatever drivers were used and using the ones built into Windows. I didn't have any trouble connecting to XP, Vista32, Vista64, Win7 32.

    I lied in the above, I did have a problem initially where everything installed fine, I saw all the files, but when trying to transfer anything large, the file transfer hung, and the device acted like it was disconnected.

    I finally traced the problem to the USB cable. Even though that cable worked fine for other devices, for the GNex, it really likes the cable that comes in the box. After using that, everything worked without issue. So if anyone is having issues connecting, that's the first thing I'd look at.
     
  10. nExUsTiMe

    nExUsTiMe New Member

    Joined:
    Dec 25, 2011
    Messages:
    3
    Likes Received:
    0
    from what i read and have been told by a few friends, that its a win7 64bit issue.. ive already tried uninstalling those drivers, but windows still wont find the right ones or even accept the ones trying to be used..

    since then tho ive found alternative ways to get my media off my pc to phone .. much better than any wire. hopefully some type of fix comes soon for those with issues. i may just forget about it and sttay wireless for good
     
  11. newdif

    newdif New Member

    Joined:
    Jan 3, 2012
    Messages:
    1
    Likes Received:
    0
    Dear nExUsTiMe, could you please tell me what is the alternative way to connect with the Nexus to Windows XP? Many Thanks
     
  12. alexorr

    alexorr New Member

    Joined:
    Jan 10, 2012
    Messages:
    1
    Likes Received:
    0
    When connected, the 'search for new hardware wizard' box comes out with the content of 'error in installing the hardware of "samsung mobile mtp device", unable to find the necessary part in INF

    I translated what I said from Chinese

    Thank You:confused:
     
  13. Sportzcaster

    Sportzcaster Member

    Joined:
    Jun 19, 2010
    Messages:
    9
    Likes Received:
    0
    Yes, I too need help locating a program or software which will allow me to transfer pictures using MTP from my GNex to my XP desktop.
     
  14. DixieChim

    DixieChim New Member

    Joined:
    Apr 10, 2012
    Messages:
    1
    Likes Received:
    1
    I don't usually post to these type of forums, but this broke my heart for a long time too and I managed to figured it out.

    Under "Settings" -> "Developer options", Select "USB debugging".

    If you're like me and haven't used Windows Media Player since you first turned on your PC, you need to ensure that you have Windows Media Player version 10 or higher installed to get MTP working.

    Hope this works for you too.:)
     
    scary alien likes this.
  15. scary alien

    scary alien not really so scary Moderator

    Joined:
    Mar 5, 2010
    Messages:
    20,621
    Likes Received:
    20,113
    Welcome to the AndroidForums and thank you very much for that nice tip, DixieChim! :)

    Hope you hang-around and post a little more--we don't bite (much ;) :)).

    Cheers!
     
  16. maicou3834

    maicou3834 New Member

    Joined:
    Apr 26, 2012
    Messages:
    3
    Likes Received:
    0
    I was looking for some foruns and reading about.
    I don't know if all this files are necessaries, but With me it works perfectly well !!

    Samsung_USB_Driver_for_Moblie_Phones_v1_4_6_0.exe

    mtppk12.exe

    PdaNetA302.exe

    Install Windows Media Player 11

    ...and it works!!!!
     
  17. chenjie

    chenjie New Member

    Joined:
    Oct 11, 2012
    Messages:
    3
    Likes Received:
    0
    Haisst, Question on connecting SGnexus on pc Dude help me please..i tried everything i've read in here...
    I have the same problem with alexorr..

    When connected, the 'search for new hardware wizard' box comes out with the content of 'error in installing the hardware of "samsung mobile mtp device", unable to find the necessary part in INF


    and in addition to that i cant see my android phone on device manager, all i can see is a question mark then samsung nexus and sub by question mark icon again MTP...
    what was that?please help me...badly needed..Tnx
     
  18. scary alien

    scary alien not really so scary Moderator

    Joined:
    Mar 5, 2010
    Messages:
    20,621
    Likes Received:
    20,113
    chenjie,

    See if either of these two threads help you:

    http://androidforums.com/verizon-galaxy-nexus-all-things-root/480632-im-going-make-hardest-part-rooting-easy-newbs-right-here-yup-i-am.html

    How to install the adb & fastboot USB drivers (MS/Windows users only)

    Getting MS/Windows to recognize the device over USB seems to be somewhat of an issue for some folks. It's been a while since I've had to do this, but hopefully one of the above links will help you out.

    Cheers and best of luck!
     
  19. Fuzzy13

    Fuzzy13 Well-Known Member

    Joined:
    Dec 8, 2011
    Messages:
    7,289
    Likes Received:
    2,503
    You are using the factory Samsung USB cable right? Had that problem myself.
     

Share This Page

Loading...