[International / GSM] [HOW TO] Root the GSM/HSPA+ Samsung Galaxy Nexus


Last Updated:

  1. residualimages

    residualimages Member

    Joined:
    Dec 15, 2011
    Messages:
    14
    Likes Received:
    3
    not I.
     

    Advertisement
  2. thetomas

    thetomas Member

    Joined:
    Dec 18, 2009
    Messages:
    9
    Likes Received:
    0
    I got the bootloader unlocked with oem unlock, but when I enter Fastboot boot boot.img it says cannot load 'boot.img'. My boot.img file is in the same directory as fastboot, so I'm not sure why it's not working. Can anyone help me out?
     
  3. WormDoes

    WormDoes Well-Known Member

    Joined:
    Aug 8, 2010
    Messages:
    3,199
    Likes Received:
    1,270
    So, I'm seeing varying reports, does the superboot method work?
     
  4. hali9

    hali9 Member

    Joined:
    Dec 7, 2011
    Messages:
    17
    Likes Received:
    22
    Does it say "downloading 'boot.img'...FAILED <status read failed <too many links>> when i try boot.superboot.img
    When i try boot.img it says <data transfer failure<too many links>>

    I get this when i try to boot using superboot.img
     
  5. cggorman

    cggorman Well-Known Member

    Joined:
    Mar 25, 2010
    Messages:
    676
    Likes Received:
    664
    Alright, so this is my first time with broken root. I know this isn't new to some of you guys, so...

    Is there a best-practice I should use to repair?
     
  6. thetomas

    thetomas Member

    Joined:
    Dec 18, 2009
    Messages:
    9
    Likes Received:
    0
    No, it specifically said cannot load 'boot.img'. However, I decided to try the superboot method at that point and it seems to have worked. It rebooted, stayed at the boot animation for long enough to make me worry, then rebooted again and prompted me for activation. I've just checked root via adfree and it is rooted.

    Now it's just a matter of installing the update and hoping It keeps root. Anyone know if the update kills root?

    Edit: updated and still rooted! mission accomplished.
     
  7. civicsisedan

    civicsisedan Well-Known Member

    Joined:
    Apr 26, 2010
    Messages:
    840
    Likes Received:
    178
    I have updated and have root.

    I updated before root though so worst case is you can reroot.
     
  8. xkingofgodzx

    xkingofgodzx Well-Known Member

    Joined:
    May 15, 2010
    Messages:
    342
    Likes Received:
    23
    Why does superboot wipe the SD? i didnt know it did this. Kinda pissed because transferring stuff from my Bolt's SD to it took like an hour.
     
  9. efApple

    efApple Well-Known Member

    Joined:
    Nov 18, 2011
    Messages:
    61
    Likes Received:
    29
  10. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Joined:
    Jan 19, 2010
    Messages:
    22,479
    Likes Received:
    9,222
    Waiting for the update prior to rooting seems like the way to go.

    But, instant gratification rules. :D
     
  11. sgrinavi

    sgrinavi Well-Known Member

    Joined:
    Nov 7, 2011
    Messages:
    300
    Likes Received:
    227
    So where's a good place for a noob to learn about ROMs ?

    I DL'd the ROM manager & did the Flash Clockwork Mod Recover deal, but I don't understand the whole Google Wallet deal. I put the GW zip file on the phone, but I really don't understand the next steps.
     
  12. burntorangefan

    burntorangefan Well-Known Member

    Joined:
    Aug 7, 2010
    Messages:
    308
    Likes Received:
    213
    Quick update here:

    Took FOREVER to get the fastboot unlock done for whatever reason, but once I did, I just followed the superboot instructions. Got stuck for about 15 minutes at the Google logo with the unlocked icon and just did a battery pull. Turned the phone back on and superuser was installed. Downloaded ROM Manager, Titanium Backup and Root Explorer and they all work, so I'm evidently good to go. Easy peasy. Will flash CWR when Koush gets it updated this evening. Til then, I haven't bothered with a nandroid...
     
  13. GorillaTheHutt

    GorillaTheHutt Well-Known Member

    Joined:
    Nov 17, 2009
    Messages:
    227
    Likes Received:
    40
    if you use the boot.img from the first post and get stuck at the Google screen, you can still run the adb commands!!!

    it is confusing because the instructions say "make sure USB debugging is on" which you can't do at the Google screen, but if you just go ahead and type the adb commands anyway, they should work. at least, they did for me.

    so to repeat, after you soft boot with the boot.img, you will get stuck at the Google screen. don't reboot or battery pull. just type in the adb commands on your attached computer while you are still stuck at the Google screen.
     
  14. ericabiz

    ericabiz New Member

    Joined:
    Apr 27, 2011
    Messages:
    4
    Likes Received:
    0
    HOLY CRAP I GOT IT

    Okay, here is exactly how I got root on my Verizon Galaxy Nexus:

    I grabbed the superboot files and downloaded them onto my computer
    I then followed the "slightly less manual" instructions, and unlocked my phone

    Then, instead of using the "manual" boot.img, I just copy/pasted the boot.superboot.img into that folder and ran

    fastboot boot boot.superboot.img

    instead.

    Waited for the auto reboot...this takes FOREVER (give it 10-15 minutes or more)

    Device did come back up normally

    Set up Google account, synced, and superboot was on there. No adb, anything needed.

    Only issue was that the Nexus had trouble finding Verizon's network...give it a reboot to fix that and it will come right back up.

    -- I ALSO did this on my fiance's Nexus, which I had previously loaded the boot.img from the zip file onto. That was not successful, so he had a working, unlocked phone but no root.

    I held both volume keys and rebooted into recovery, ran

    fastboot boot boot.superboot.img

    and let it do its thing and reboot. His hung at the Google screen. I gave it 15 minutes...still hung...pulled battery, powered it back up, and he had root, too. Had the same issue with not finding Verizon's network...a quick reboot fixed that on his phone as well.

    Installed wireless tether and we are off and running, grandfathered in to the old Verizon unlimited data plan. Rock on!
     
  15. trophynuts

    trophynuts Well-Known Member

    Joined:
    Jul 6, 2010
    Messages:
    5,630
    Likes Received:
    1,792
    I updated the Drivers section of the OP to contain the following drivers

    [ADB/FB Driver] Naked Samsung Driver 1.7

    a lot of members where having success with these drivers instead of some of the other ones.
     
  16. hali9

    hali9 Member

    Joined:
    Dec 7, 2011
    Messages:
    17
    Likes Received:
    22
  17. jaydotelloh

    jaydotelloh Well-Known Member

    Joined:
    Feb 10, 2010
    Messages:
    362
    Likes Received:
    291
  18. metlcat

    metlcat Well-Known Member

    Joined:
    Oct 24, 2010
    Messages:
    547
    Likes Received:
    221
    Thanks guys, I was able to get root using the boot boot.superboot.img method.
     
  19. chanop

    chanop Well-Known Member

    Joined:
    Jul 24, 2011
    Messages:
    216
    Likes Received:
    419
    disregard
     
  20. vandyman

    vandyman Well-Known Member

    Joined:
    Sep 9, 2011
    Messages:
    1,209
    Likes Received:
    730
    I have win7 64bit and tiring to get the drivers to work in boot mode was crazy. Well anyway I did a manual root install.

    The only method that would work and see the Nexus was the easy manual method. The other methods will not see the Nexus/drivers.

    You can manually unlock the boot loader and then use super boot as well.
    The Nexus has to be manually unlocked using fast boot in the terminal window.
     
  21. scary alien

    scary alien not really so scary Moderator This Topic's Starter

    Joined:
    Mar 5, 2010
    Messages:
    20,613
    Likes Received:
    20,108
    Okay guys, still haven't caught-up with all of the posts from today, but I have updated the OP/first post to reflect my experiences and what I've learned so far for the VZW Galaxy Nexus. Here's a quick summary:

    1. The Naked Samsung 1.7.zip USB drivers from here [ADB/FB Driver] Naked Samsung Driver 1.7 - xda-developers (thanks to XDA's 1wayjonny), worked great for me for 64 bit Windows 7 Professional.

    2. After you've unlocked the bootloader, your first boot is going to take a while (about five minutes), so be patient. I'm pretty sure that since a bootloader unlock does a factory reset, it cleared you dalvik-cache, which needs to be rebuilt on first boot. So don't do a battery pull--just be patient and let the two cycles of the boot animation run their course.

    3. The unsecured boot.img files used by the first two manual methods as well as the boot.superboot.img file in the Superboot method seem to hang and not finish booting (or I really didn't wait long enough). The Superboot boot.superboot.img file will, however, get the root package installed and gets your phone rooted. You'll still have to do a battery pull after a letting it try its boot thing for a few minutes, but you should find that Superboot get the root part done.

    Been a long day...got a lot more threads and posts to read...

    Cheers!
     
    sgrinavi likes this.
  22. teddyearp

    teddyearp Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    2,404
    Likes Received:
    826
    I'm sorry, but I disagree. Don't hate me. Mac is based on (closed source) Unix. Linux is the open source 'version' of Unix, as it was developed by one of the guys who worked on the Minix branch of Unix, Linus Torvalds who was frustrated by the closed source nature of Unix. But, yes, because of this similarity sometimes the same terminal commands work on either.
     
  23. teddyearp

    teddyearp Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    2,404
    Likes Received:
    826
    John, my warning still stands. I do not yet have this phone, but I consider myself fairly savvy on cell phones in general, especailly when it comes to GSM vs. CDMA (LTE in this case). I am going to try to post more info soon, as now I read more and more problems with folks using the files/methods posted for the GSM version of the phone.

    I asked for the GNex section to be split between the i515 and the GSM model #, but . . . . . .
     
  24. teddyearp

    teddyearp Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    2,404
    Likes Received:
    826
    @scary: I am really thinking that maybe P3Droid's rooting files (and specifically his boot.img file) need to be used as from what I've seen with all the problems here and your recent edit of your OP those might be the best way to go. I _think_ that Pete Alfonso's 'boot.img' file (and all the others linked) have given major problems as you have edited the OP to reflect. Unfortunately, p3 has removed the downloads from his thread at mydroidworld.com. Fortunately I grabbed them.

    I have a bit more to say in this matter, but I fear I would be stepping on your toes, plus I have other pressing things to do. Suffice it to say, I will be editing the guide at my site to reflect my latest revelations in view of those problems posted in this (now blowing up) thread.
     
  25. ItsASamsung

    ItsASamsung Well-Known Member

    Joined:
    Dec 8, 2011
    Messages:
    97
    Likes Received:
    171
    OP - Please update the CDMA/LTE ClockworkMod is officially out: Link
     
    sgrinavi likes this.

Share This Page

Loading...